Full speed fans at startup and after suspend issue

Hello there,

I know there are other threads with similar issue, but I just couldn’t find any solution to my problem.

At first, my issue was the fans going full speed after suspend, and after many researches and tweaks, my issue is the same but even after startup. So basically my fans are always on full speed. I messed up somewhere but I don’t know where exactly.

Here is a little list of what I found and what I did:

  • lm-sensors doesn’t show fan speed even after detect.
  • tried to modify some grub parameters by adding “acpi_enforce_resources=lax” or “acpi_osi=! acpi_osi=‘Windows 2015’” to “GRUB_CMDLINE_LINUX=”""
  • pwmconfig obviously doesn’t work as no sensor modules are installed.
  • tried different kernels : 4.20, 4.19, 4.14 and it makes no difference.
  • installed thermald
  • tried to add this module via this command: modprobe w83627ehf force_id=0x8860
    but it shows 0 rpm fan speed in lm-sensors, and obviously pwmconfig returns an error.

It really seems as my system can’t read my fan sensors values.

some details about my setup:

OS: manjaro budgie
Kernel: Linux 4.20
Video driver: video-hybrid-intel-nvidia-390xx-bumblebee
GPU: Geforce GTX 1050 mobile
CPU: i5-7300HQ
Dual-boot with windows

Has anyone solved this issue ? I’m getting really desperate right now :frowning:

[UPDATE] The problem seems to be coming from my video driver. I installed optimus-manager and switched to nvidia driver (at startup too) and it seems to have fixed my problem. Although I feel a bit worried only a daemon is dealing with drivers. If I do something that crashes the program, then i’d have no video driver to load on boot…

Why not the video-hybrid-intel-nvidia-bumblebee instead? The one you have installed is the legacy one. Not sure if will influence the fans speed tho …

Could be a starting point related to the difference between the legacy driver and the latest one …

2 Likes

Sorry for the late reply.

I tested video-hybrid-intel-nvidia-bumblebee before, and had the same result.
I got back to bumblebee driver because optimus-manager drains battery way too fast.
I’m still seeking for the solution but nothing i’ve tried worked beside optimus-manager.

if somebody has any clue on what to do, please do tell. thanks.

Not sure if this is a confusion or you wanted to say something else. What you mentioned above are one and the same thing. The 390xx-bumblebee is the legacy driver, much older than video-hybrid-intel-nvidia-bumblebee

Sorry, what I meant to say is that I tried drivers in this order :
1:video-hybrid-intel-nvidia-bumblebee
2:video-hybrid-intel-nvidia-390xx-bumblebee
3:optimus-manager
4:video-hybrid-intel-nvidia-bumblebee

Bu I still have that fan issue…

This is quite old post, but maybe will help you out
https://bbs.archlinux.org/viewtopic.php?pid=1239445#p1239445

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.