Full screen video on second monitor

I am looking online and it seems there are several people reporting this issue but I have not been able to find a solution. Everyone just stats moving to a new distro works but I am really with manjaro so far. For some weird reason when i play vlc with a local file on my second monitor in full screen everything works as expected but when I try to use a web browser with full screen video it is just a black screen. I am currently on kde 5.20.2, kernel 5.8.18-1, and using a gtx 1070 with the proprietary drivers version 455xx installed.

See: I use dualscreens, whenever I choose fullscreen on Youtube/twitch/... it always go fullscreen on my main monito,anyway to make it fullscreen on other instead? | Firefox Support Forum | Mozilla Support
If that doesn’t work/help i would suggest to file another topic at their support.
Because IMHO it is something specific to FireFox, maybe there is a special config setting added in mean time.

At this point I have tried with chromium, firefox, brave, and opera. All of them seem to have the same issue. The weird part is the first time I tried with vlc it did not work but ever test I have done since then with vlc has worked. This is what is making me think it is not related specifically to firefox.

Well i once had a dual monitor setup also, but my other monitor died.
So under current circumstances i’m not able to provide better help wrt Multi monitor stuff unfortunatly :woman_shrugging:

Had the same issue for me disabling hardware acceleration in the browser fixed it.

So tr y to disable the in browser hardware acceleration

Some time ago I had problems with dual monitor setup getting the layout messed up after each reboot and wired dpi settings.

What I did is, use the nVidia Xserver Settings, tweak the X Server Display Configuration to my needs and use that as the primary X11 configuration.

Since then, I didn’t have any problems with the setup anymore. And yes, Fullscreenplayback in chrome and firefox working on both displays.

To update the config use the preview option in nVidia X Server Settings and copy it into /etc/X11/mhwd.d/nvidia.conf

I’m not sure if the original config generated by mhwd had the same name but if not, make sure to adjust the symlink in xorg.conf.d

So here is the layout of my etc/X11 folder:

[/etc/X11]$ ls -l *
insgesamt 8
-rw-r--r-- 1 root root 1864  8. Nov 17:51 nvidia.conf
-rw-r--r-- 1 root root 1458  8. Nov 14:24 nvidia.conf.bak

insgesamt 12
-rw-r--r-- 1 root root  739 10. Okt 16:27 xinitrc
drwxr-xr-x 2 root root 4096  4. Okt 16:11 xinitrc.d
-rw-r--r-- 1 root root   45 10. Okt 16:27 xserverrc

insgesamt 4
-rw-r--r-- 1 root root 266 15. Okt 2016  00-keyboard.conf
lrwxrwxrwx 1 root root  27  8. Nov 14:24 90-mhwd.conf -> /etc/X11/mhwd.d/nvidia.conf

insgesamt 4
-rw-r--r-- 1 root root 397 15. Okt 15:29 90xbrlapi

My system config is

Betriebssystem: Manjaro Linux
KDE-Plasma-Version: 5.20.2
KDE-Frameworks-Version: 5.75.0
Qt-Version: 5.15.1
Kernel-Version: 5.9.3-1-MANJARO
Art des Betriebssystems: 64-bit
Prozessoren: 8 × Intel® Core™ i7-6700 CPU @ 3.40GHz
Speicher: 15,6 GiB Arbeitsspeicher
Grafikprozessor: GeForce GTX 960/PCIe/SSE2

Hope this helps and good luck :slight_smile:

I have made modification in nvidia-settings and saved them to the /etc/X11/mhwd.d/nvidia.conf . After doing this I rebooted my system but I am still having the same issue. I almost forgot to mention that I checked the system link on the file 90-mhwd.conf in the xorg.conf.d folder and it is pointing to the nvidia.conf that I have overwritten with nvidia-settings

I take everything back. I am not sure what exactly is causing it to work now but after several reboots I am able to play full screen video on both screens at the same time.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.