Fstab issue : i can't write

fstab

#1

Hi,
First of all sorry for my english …
I used debian for a long time and recently adopt Manjaro. Everything went very well during the install and I think i will stay on Manjaro. The only issue that i haven’t solved concern the fstab. I use NFS to mount an ressources from a synology NAS. The ressources mount correctly but are only readable and not writable. However I didn’t change anything when i compare with the debian Install
Here is the fstab line
192.168.1.13:/volume1/Donnees_parents /media/Donnees_parents nfs defaults,_netdev 0 2

I someone can help i’ll appreciate. Regards


#2

Archwiki is useful
https://wiki.archlinux.org/index.php/NTFS-3G


#3

Try the systemd mount method in fstab.

192.168.0.102:/srv/nfs/3tb /media/nfs/3tb nfs noauto,x-systemd.automount,x-systemd.device-timeout=10,timeo=14,x-systemd.idle-timeout=1min 0 0

#4

thanks for your help. I’ve tried ntfs-3g and @tbg systemd mount method but it doesn’t work.

Notice that when I use root, i can write in the mounted devices. It’s probably a permission issue but I don’ t find the solution. Here are user and group of media rep

drwxr-xr-x 14 root root 4096 30 nov. 19:02 media


#5

You need to specify “nfs” as the mount option not “ntfs-3g”. You also could try writing systemd mount units for your NFS mounts.

Here is info on mounting nfs shares in fstab.


#6

Thanks. I solved the problem by using CIFS.


#7

This is a server-side configuration issue.

Given NFSv3 doesn’t resolve your username, but instead relies on a numeric UID, if these don’t match between local machine and the resources on the server then you won’t have ownership of them.

Simple answer is to ensure the file ownership matches the local UID.