Fstab custom drive throws me into emergency mode!

Hello there!

I’m writing this thread while hoping that someone might be able to solve my problem.
I’ve been using manjaro for a decent bit over a year without this ever being a problem for me.

I’ve been mounting my “gaming” drive onto manjaro via fstab, it’s an ext4 partition.
Looks somewhat like this:

UUID=6b1c6249-f336-4d02-89c5-64760ddf8acf /home/storage ext4 defaults 0 2

But when i tried to start my PC this morning i was thrown into emergency mode.
After looking into it i found an error message using systemctl --failed

  UNIT                                                                                      LOAD   ACTIVE SUB    DESCRIPTION                                                                
● systemd-fsck@dev-disk-by\x2duuid-6b1c6249\x2df336\x2d4d02\x2d89c5\x2d64760ddf8acf.service loaded failed failed File System Check on /dev/disk/by-uuid/6b1c6249-f336-4d02-89c5-64760ddf8acf

The drive mounts correctly after system boot, and i checked the partition through gparted, no errors came up.

Anyone got any idea to fix this so i can auto mount this drive without the emergency mode?

Hi @MrCaira,

Perhaps use systemd mount units for better control?

See [root tip] Use systemd to mount ANY device and [root tip] systemd mount unit samples.

Using this, you can set it to only mount when it’s accessed, I have one like that and it works a treat! You can also set it per-user, which would mean, according to me, that it’ll only be mounted when the specified user logs in. Or set other dependencies.

Hope it helps!

Maybe it’s a tiny bit slow to mount? I have a similar issue with an internal drive, i need to add nofail to the mount options, and it still mounts correctly once the user session is open. :man_shrugging:

1 Like

I tired that and it absolutely worked!
I always preferred using fstab as I’ve been told that it is the “right” way to do it.

Thanks alot!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.