Frozen screen after lock - KDE

Hello, I have been troubled by the following problem for a few weeks.
When I lock the screen, sometimes it freezes after a few minutes, and I can't unlock it anymore. The mouse is responsive, but I can't even get to the unlock screen asking for the password.

The funny fact (hopefully useful to debug) is that the clock is frozen to a certain point in the past. It sometimes freezes faster or slower (quite random) but, having 2 screens, the time displayed on them is always different by precisely 3 minutes -- the laptop screen seems to freeze before the external connected through a docking station.

I tried to follow a few suggestions from other posts but without success. How could I properly debug?

I attach the screen showing the different times and a few system info.


mhwd -li

Installed PCI configs:
-----NAME | ---VERSION | FREEDRIVER | TYPE
video-linux | 2018.05.04 | ----------true | PCI
Warning: No installed USB configs!


inxi -SGMxxxz

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "en_US:de:it",
LC_ALL = (unset),
LC_ADDRESS = "de_CH.UTF-8",
LC_IDENTIFICATION = "de_CH.UTF-8",
LC_MEASUREMENT = "de_CH.UTF-8",
LC_MONETARY = "de_CH.UTF-8",
LC_NAME = "de_CH.UTF-8",
LC_NUMERIC = "de_CH.UTF-8",
LC_PAPER = "de_CH.UTF-8",
LC_TELEPHONE = "de_CH.UTF-8",
LC_TIME = "de_CH.UTF-8",
LANG = "en_US"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
System: Host: lorenzo-sdsc Kernel: 5.4.2-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0
Desktop: KDE Plasma 5.17.4 tk: Qt 5.13.2 info: docker wm: kwin_x11 dm: SDDM Distro: Manjaro Linux
Machine: Type: Laptop System: Dell product: XPS 13 9370 v: N/A serial: Chassis: type: 10
serial:
Mobo: Dell model: 0F6P3V v: A00 serial: UEFI: Dell v: 1.11.1 date: 07/11/2019
Graphics: Device-1: Intel UHD Graphics 620 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0
chip ID: 8086:5917
Display: x11 server: X.Org 1.20.6 driver: intel unloaded: modesetting alternate: fbdev,vesa
compositor: kwin_x11 resolution: 1368x768~60Hz, 3440x1440~60Hz
OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2) v: 4.5 Mesa 19.2.7 compat-v: 3.0
direct render: Yes

journalctl -p3 --no-pager --no-hostname

Dec 19 16:20:13 kernel: mce: CPU0: Core temperature above threshold, cpu clock throttled (total events = 1)
Dec 19 16:20:13 kernel: mce: CPU4: Package temperature above threshold, cpu clock throttled (total events = 21)
Dec 19 16:20:13 kernel: mce: CPU0: Package temperature above threshold, cpu clock throttled (total events = 21)
Dec 19 17:10:15 bluetoothd[704]: Unable to get io data for Headset Voice gateway: getpeername: Transport endpoint is not connected (107)
-- Reboot --
Dec 20 08:43:42 kwin_x11[1070]: kwin_xkbcommon: XKB: couldn't find a Compose file for locale "en_CH.UTF-8"
Dec 20 08:43:44 nmbd[1345]: [2019/12/20 08:43:44.356949, 0] ../../lib/util/become_daemon.c:135(daemon_ready)
Dec 20 08:43:44 nmbd[1345]: daemon_ready: daemon 'nmbd' finished starting up and ready to serve connections
Dec 20 08:43:44 smbd[1378]: [2019/12/20 08:43:44.777765, 0] ../../lib/util/become_daemon.c:135(daemon_ready)
Dec 20 08:43:44 smbd[1378]: daemon_ready: daemon 'smbd' finished starting up and ready to serve connections

So, you have checked this?
https://wiki.archlinux.org/index.php/Dell_XPS_13_(9370)

Thanks for the reference. Sadly, that page doesn't contain anything possibly related to this problem :slightly_frowning_face:

Are you able to switch to tty via ctrl+alt+f2?
If so, does it work again after switching back (usually ctrl+alt+f1)?

1 Like

Try disabling TLP, worked for me on a Thinkpad T495s.

You can also try disabling the compositor in Plasma. It has been known to mess up some suspend stuff in the past.

Thanks, I'll try disabling composition. And next time it'll appen, I'll also try to switch to tty to login on the lock screen, I am not sure if I actually tried that yet :thinking:

@Strit That may be an option but I prefer keeping the compositor on. Without it, the look and feel is a bit weird and I would need to tweak windows appearance since there are no borders and, without shadows, applications with similar color scheme seem to mingle together.

@freggel.doe I just tried and I can switch to tty and login from there, but switching back still brings me to the same frozen screen I posted ad the beginning, even though I see the mouse pointer.
Is there anything I could try from the tty console? I tried with

killall plasmashell
kstart5 plasmashell

but it doesn't produce any effect

I don't have similar problems, can't help any further :white_flag:
At least you're able to cleanly shutdown/reboot the system.

If anyone has a suggestion on how to try to fix stuff from the terminal, it would be of great help. This problem keeps happening too often, and I am not sure what could be responsible. Maybe the display server? :thinking:

One thing that works for sure, instead of a full reboot, is restarting the display manager from tty

systemctl restart display-manager

I don't really like this workaround because it's almost like a reboot since all the open applications get killed :slightly_frowning_face:

For what it's worth, I had begun experiencing this issue on a native Arch/KDE installation after running for over a year with no issues. HP desktop with good ol' i7 2600 and nvidia 8600gt using nouveau. Had no luck fixing after much searching, so decided to do a clean install of Manjaro/KDE today. After the install finished and after the first reboot, when I locked the screen using meta-L shortcut, this problem happened. Discouraging to say the least. Ctrl-alt-2, loginctl unlock-sessions, ctrl-alt-1 do nothing for me. Always have to reboot. Have resorted to turning off screen when I need to lock. Not a happy solution.

This is the first recent posting I found that referenced this exact problem, so at least I'm not alone. How can I determine if it's a KDE or Arch issue?

I wish I could offer a solution.

Just passing it along.

Followup.

Disabling the compositor seems to make the issue go away. As soon as I re-enable (with Wobbly enabled), the problem is back.

Too bad.

1 Like

Good to know! At least we have something to blame...
Anyway, disabling the compositor is lame. I don't mind the visual effects, but without shadows it's not even clear where a window finish and the other start (old good borders, where have you gone?)

Any ideas on how to go further in an attempt to fix?

Somewhere I saw a post about the option to allow apps to block compositing on the same compositor setup screen which I had not noticed. I unchecked it and left the compositor enabled on startup and haven't had the issue reoccur since doing so.

For what it's worth...

I've been having this EXACT same issue. I'll try unchecking "Allow applications to block compositing" like you said to see if it it helps.

Sometimes this issue can be worked around with a service I wrote to disable the compositor prior to suspend. The service automatically re-enables the compositor on resume.

Some people get the service working for them, and others never manage to get it working properly. Please don't expect me to debug the service for you, as that is next to impossible remotely. You need to debug the service yourself (if it is not working for you).

If you can't get the service to auto disable/enable the compositor then only use the disable portion of the service. You can restart the compositor after you login via a key combination. Not fully auto, but effective.
Good luck.

Well, what about isolating wobbly then ? Does it also happen without ?
And even if its compositing in general .. it could be the way your graphics is set up. Maybe dual-graphics?

Few days without a freeze now, I think this has fixed it! Thanks!

1 Like

Forum kindly sponsored by