From yesterday wont work the nvidia card in my laptop

What’s the output of

mhwd --listall

please because:

sudo mhwd --install pci video-nvidia

should have just worked (unless you made a typo instead of me now)

:grin:

mhwd --listall
> All PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
   network-broadcom-wl            2018.10.07                true            PCI
     network-rt3562sta            2013.12.07                true            PCI
       network-slmodem            2013.12.07                true            PCI
         network-r8168            2016.04.20                true            PCI
     video-modesetting            2020.01.13                true            PCI
          video-sisusb            2020.01.18                true            PCI
            video-vesa            2017.03.12                true            PCI
           video-linux            2018.05.04                true            PCI
       video-rendition            2020.01.18                true            PCI
video-hybrid-intel-nvidia-390xx-bumblebee            2020.11.30               false            PCI
    video-nvidia-390xx            2020.11.30               false            PCI
          video-voodoo            2017.03.12                true            PCI
  video-virtualmachine            2020.03.26                true            PCI
      video-openchrome            2020.01.18                true            PCI
              video-s3            2020.01.18                true            PCI


Warning: No USB configs found!

I tried to install the proprietary nVidia driver as written in Manjaro Wiki:

sudo mhwd -a pci nonfree 0300

Here is the result:

mhwd --listinstalled
> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
           video-linux            2018.05.04                true            PCI


Warning: No installed USB configs!

Why is it freedriver? It was in the command as clear as can: nonfree.
So, mhwd put up a free driver. Which one is misleading? The wiki or the mhwd?

Edit:
Finally I got rid the problem. Now it works.

Did you re-install while using non-free drivers???

:thinking:

Removed video-linux.
Installed nvidia-linux510. I think that was the solution.
That is freedriver but works.

changed original post to do just that and marked it as a solution so that the next person that has the same problem as you is helped too!

:+1:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.