Freshly installed virtualbox-problem in preferences

Hello. Installed virtualbox using the instructions on the manjaro wiki.
After the successful installation I began configuration with the preference tab.
Seasoned Virtualbox users will recognize the step I am about to describe - the default location of vms.
My virtual Machines store is actually on an external USB drive called “Store”.
The preference tab offers a drop down box so the user may navigate to “other” as in other location.
The navigation tool does open up and that is about as far as I can get because the file picker box becomes unresponsive and nothing can be chosen. The cancel button does not respond and the file chooser window can be closed with x button (top right hand corner).

My manjaro installation is the latest fully updated Plasma release.
I do not observe any problem using dolphin to access my External USB Store drive. I thought at first that virtualbox was incapable of reaching across to another drive but that can’t be the case as I can’t pick any item on the left hand side of the file chooser/picker.

I may as well say that this is the second attempt installation. In the first install I also added the optional extension pack as I see no reason not to.
So that wasn’t the issue - as far as I can tell.

Any thoughts, further information required?

i just tried what you described and got the same behavior;it gets stuck and only the X button can close this window.
i can chose “other” when creating a machine,but it’ll probably won’t be set as default,or maybe it’ll remember it for the next time?
you can report it somewhere in the VB Linux section if you want.

Edit: you may be able to change it with a command,check this out:

vboxmanage setproperty machinefolder /path/to/directory/

I am also storing my vms in another location - using a slightly different approach and I have therefore never had this issue.

I symlink the folder VirtualBox VMs to the partition mountpoint. This has the benefit that the complete vm is available - not only the vdisk - but I assume this would also be the case with your approach.

Just for the sake of testing the issue

  1. create new vm
  2. name
  3. machine folder → navigate → Computer → / → data → nas → data → new folder icon → test-vm
  4. Choose
  5. The machine folder is now /data/nas/data/tes-vm
  6. continue to create vdisk etc

It should be fairly obvious the nas/data is a remote network share - but for the sake of this test - I cannot reproduce it.

My system is based on Openbox window manager - this may cater for the lack of issues on my system.

the issue is on the main window; preferences/General/default machine folder/drop down menu->other.

I’m pretty sure this might be a KDE issue as I haven’t had any issues using vbox with Gnome.You can choose create a Virtual Optical Disk and it works.Also if you have any vbox os’s on your drive you can also open the VirtualBox VMS file click on the os click whatever.vbox and it will open it in vbox.

Thanks to Linub.
The command line approach worked a treat.
I mentioned I did an installation before this one. The only way I could get the extension pack to install was via the command line.
Well done, and thanks to the other folks who offered help.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.