Fresh manjaro KDE install - no sound card detected

Did install the 2 packages, rebooted my computer and did the 2 previous commands

Here is the output from journalctl -f when i run : sudo rmmod snd_sof_pci && sudo modprobe snd_sof_pci
https://pastebin.com/X8ZHHjPi

still no input or output device detected btw

I’m not seeing in the logs that you ran sudo modprobe snd_sof_pci.

However I launched the command, here are the logs if I launch each command separately without the &&.

[florian@florian-20s6cto1ww ~]$ sudo rmmod snd_sof_pci
[florian@florian-20s6cto1ww ~]$ sudo modprobe snd_sof_pci

https://pastebin.com/rHj42T2w

sept. 05 17:06:45 florian-20s6cto1ww kernel: INFO: task rmmod:3048 blocked for more than 368 seconds

That’s not good. Can you reboot and send the output of lspci -k, pa-info, sudo dmesg | egrep -i '(sof|snd)'?

Sorry I had to go !

Here are the logs

lspci -k : https://pastebin.com/w2sMVDCa
pa -info : https://pastebin.com/5ezPmyDT
sudo dmesg | egrep -i ‘(sof|snd)’ : https://pastebin.com/ntA0DFQD

EDIT : IT WORKS ! I had to do pulseaudio --start then pulseaudio -k THANKS A LOT

Glad to hear it. Please mark one comment as solution so that people coming here immediately know what’s up.

Here is the steps that solved my problem for T15 Lenovo on manjaro KDE

Install 5.8 Kernel
mhwd-kernel -i linux58

Reboot computer
reboot

Check your kernel version it should be 5.8 at least
mhwd-kernel -li

Currently running: 5.8.3-2-MANJARO (linux58)
The following kernels are installed in your system:

  • linux57
  • linux58

Install pulseaudio-git https://aur.archlinux.org/packages/pulseaudio-git
git clone https://aur.archlinux.org/packages/pulseaudio-git
cd pulseaudio-git/
makepkg -si

Install missing firmware and conf
sudo pacman -S sof-firmware alsa-ucm-conf

Reboot (yes again and i don’t know if it’s necessary but do it anyway)
reboot

Start pulseaudio then kill it then start it again (weird but thats what fixed the problem for me after following the previous steps)
pulseaudio --start
pulseaudio -k
pulseaudio --start

And voila !

Full credits goes to pobrn and bogdancovaciu for the solution

5 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.