Fresh Manjaro install - External monitors over Dell dock blank displays

Hi guys! :slight_smile:
I just installed my first Manjaro ever - basically just switched from Windows.
I’ve been in the Linux server department for a while and finally pulled myself together to get a good client OS.

I’ve connected a Dell Universal D6000 dock via USB-C to my Dell computer which is running my fresh Manjaro install. The dock is detected and labelled correctly by the system when plugged in and the connected Mouse and external keyboards are working.

My 2x Monitors (Samsung and AG Neovo) are on the other hand, not working. They are connected to the docking station via displayport. It looks like the monitors are detected somewhat when plugged in (they briefly flash and display input device), but arent displaying anything.

Here is some info from inxi and xrandr:

 System:    Kernel: 5.8.18-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 root=UUID=8584837c-d083-4056-a121-d84e912742ef rw 
           quiet apparmor=1 security=apparmor resume=UUID=0a3fb447-9e2f-4c75-8fb3-a90e24b6c280 
           udev.log_priority=3 
           Desktop: KDE Plasma 5.20.2 tk: Qt 5.15.1 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: Dell product: Latitude 7490 v: N/A serial: <filter> Chassis: type: 10 
           serial: <filter> 
           Mobo: Dell model: 0KP0FT v: A00 serial: <filter> UEFI: Dell v: 1.13.1 date: 11/08/2019 
Battery:   ID-1: BAT0 charge: 44.0 Wh condition: 44.4/60.0 Wh (74%) volts: 8.4/7.6 
           model: Samsung SDI DELL V494081 type: Li-ion serial: <filter> status: Charging 
Memory:    RAM: total: 31.25 GiB used: 1.35 GiB (4.3%) 
           RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:       Info: Quad Core model: Intel Core i7-8650U bits: 64 type: MT MCP arch: Kaby Lake family: 6 
           model-id: 8E (142) stepping: A (10) microcode: D6 L2 cache: 8192 KiB bogomips: 33615 
           Speed: 700 MHz min/max: 400/4200 MHz Core speeds (MHz): 1: 700 2: 700 3: 700 4: 700 5: 700 6: 700 
           7: 700 8: 700 
           Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art avx avx2 bmi1 bmi2 bts 
           clflush clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept 
           ept_ad erms est f16c flexpriority flush_l1d fma fpu fsgsbase fxsr hle ht hwp hwp_act_window hwp_epp 
           hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor 
           movbe mpx msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni 
           popcnt pse pse36 pti pts rdrand rdseed rdtscp rep_good rtm sdbg sep smap smep smx ss ssbd sse sse2 
           sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx vnmi 
           vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 
           mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort mitigation: Clear CPU buffers; SMT vulnerable 
Graphics:  Device-1: Intel UHD Graphics 620 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:5917 
           Device-2: Sunplus Innovation Integrated_Webcam_HD type: USB driver: uvcvideo bus ID: 1-5:2 
           chip ID: 1bcf:2b96 
           Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: intel unloaded: modesetting 
           alternate: fbdev,vesa display ID: :0 screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9") 
           Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 157 size: 310x170mm (12.2x6.7") diag: 354mm (13.9") 
           OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.2.1 direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell driver: snd_hda_intel v: kernel 
           alternate: snd_soc_skl bus ID: 00:1f.3 chip ID: 8086:9d71 
           Device-2: DisplayLink USB3.1 Hub type: USB driver: cdc_ncm,snd-usb-audio bus ID: 4-1.1:3 
           chip ID: 17e9:6006 serial: <filter> 
           Sound Server: ALSA v: k5.8.18-1-MANJARO 
Network:   Device-1: Intel Ethernet I219-LM vendor: Dell driver: e1000e v: 3.2.6-k port: f040 bus ID: 00:1f.6 
           chip ID: 8086:15d7 
           IF: enp0s31f6 state: down mac: <filter> 
           Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel port: f040 bus ID: 02:00.0 
           chip ID: 8086:24fd 
           IF: wlp2s0 state: up mac: <filter> 
           IP v4: <filter> type: dynamic noprefixroute scope: global broadcast: <filter> 
           IP v6: <filter> type: noprefixroute scope: link 
           IF-ID-1: enp59s0u1u1i5 state: down mac: <filter> 
           WAN IP: <filter> 
Drives:    Local Storage: total: 238.47 GiB used: 9.59 GiB (4.0%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda vendor: LITE-ON model: CV8-8E256-11 SATA 256GB size: 238.47 GiB block size: 
           physical: 512 B logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: 10B scheme: GPT 
           Message: No Optical or Floppy data was found. 
RAID:      Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci v: 3.0 port: f060 
           bus ID: 00:17.0 chip ID: 8086.282a rev: 21 
Partition: ID-1: / raw size: 203.80 GiB size: 199.60 GiB (97.94%) used: 9.59 GiB (4.8%) fs: ext4 dev: /dev/sda2 
           label: N/A uuid: 8584837c-d083-4056-a121-d84e912742ef 
           ID-2: /boot/efi raw size: 300.0 MiB size: 299.4 MiB (99.80%) used: 312 KiB (0.1%) fs: vfat 
           dev: /dev/sda1 label: N/A uuid: 0501-F856 
Swap:      Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
           ID-1: swap-1 type: partition size: 34.37 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda3 
           label: N/A uuid: 0a3fb447-9e2f-4c75-8fb3-a90e24b6c280 
Unmounted: Message: No unmounted partitions found. 
USB:       Hub: 1-0:1 info: Full speed (or root) Hub ports: 12 rev: 2.0 speed: 480 Mb/s chip ID: 1d6b:0002 
           Device-1: 1-5:2 info: Sunplus Innovation Integrated_Webcam_HD type: Video driver: uvcvideo 
           interfaces: 2 rev: 2.0 speed: 480 Mb/s chip ID: 1bcf:2b96 
           Device-2: 1-7:3 info: Intel Bluetooth wireless interface type: Bluetooth driver: btusb interfaces: 2 
           rev: 2.0 speed: 12 Mb/s chip ID: 8087:0a2b 
           Hub: 2-0:1 info: Full speed (or root) Hub ports: 6 rev: 3.0 speed: 5 Gb/s chip ID: 1d6b:0003 
           Hub: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 speed: 480 Mb/s chip ID: 1d6b:0002 
           Hub: 3-1:2 info: Genesys Logic Hub ports: 4 rev: 2.1 speed: 480 Mb/s chip ID: 05e3:0610 
           Hub: 3-1.2:3 info: Genesys Logic Hub ports: 4 rev: 2.1 speed: 480 Mb/s chip ID: 05e3:0610 
           Device-1: 3-1.2.2:5 info: Cherry type: Keyboard,HID driver: hid-generic,usbhid interfaces: 2 rev: 2.0 
           speed: 1.5 Mb/s chip ID: 046a:0113 
           Device-2: 3-1.2.4:7 info: SteelSeries ApS type: HID,Mouse driver: hid-generic,usbhid interfaces: 2 
           rev: 1.1 speed: 12 Mb/s chip ID: 1038:1729 
           Hub: 3-1.3:4 info: Genesys Logic Hub ports: 4 rev: 2.0 speed: 480 Mb/s chip ID: 05e3:0608 
           Device-1: 3-1.3.1:6 info: Bizlink USB2.1 Hub type: HID driver: hid-generic,usbhid interfaces: 1 
           rev: 2.0 speed: 12 Mb/s chip ID: 06c4:c411 serial: <filter> 
           Hub: 4-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 speed: 10 Gb/s chip ID: 1d6b:0003 
           Hub: 4-1:2 info: Genesys Logic USB3.1 Hub ports: 4 rev: 3.1 speed: 5 Gb/s chip ID: 05e3:0620 
           Device-1: 4-1.1:3 info: DisplayLink USB3.1 Hub type: <vendor specific> driver: cdc_ncm,snd-usb-audio 
           interfaces: 7 rev: 3.2 speed: 5 Gb/s chip ID: 17e9:6006 serial: <filter> 
           Hub: 4-1.2:4 info: Genesys Logic ports: 4 rev: 3.1 speed: 5 Gb/s chip ID: 05e3:0620 
Sensors:   System Temperatures: cpu: 40.5 C mobo: N/A 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 216 Uptime: 20m Init: systemd v: 246 Compilers: gcc: N/A Packages: pacman: 1175 lib: 329 
           flatpak: 0 Shell: Bash v: 5.0.18 running in: konsole inxi: 3.1.08

xrandr:

    Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
    eDP1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 310mm x 170mm
       1920x1080     60.01*+  59.93    48.01  
       1680x1050     59.88  
       1400x1050     59.98  
       1600x900      60.00    59.95    59.82  
       1280x1024     60.02  
       1400x900      59.96    59.88  
       1280x960      60.00  
       1368x768      60.00    59.88    59.85  
       1280x800      59.81    59.91  
       1280x720      59.86    60.00    59.74  
       1024x768      60.00  
       1024x576      60.00    59.90    59.82  
       960x540       60.00    59.63    59.82  
       800x600       60.32    56.25  
       864x486       60.00    59.92    59.57  
       640x480       59.94  
       720x405       59.51    60.00    58.99  
       640x360       59.84    59.32    60.00  
    DP1 disconnected (normal left inverted right x axis y axis)
    DP2 disconnected (normal left inverted right x axis y axis)
    HDMI1 disconnected (normal left inverted right x axis y axis)
    HDMI2 disconnected (normal left inverted right x axis y axis)
    VIRTUAL1 disconnected (normal left inverted right x axis y axis)

Hello,

Have you followed this
https://wiki.archlinux.org/index.php/DisplayLink
and especially this part
https://wiki.archlinux.org/index.php/DisplayLink#Displays_disconnect_at_random_intervals_when_using_the_Dell_D6000_docking_station
?

1 Like

Thanks <3
You are a champ.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.