Fresh KDE install. Cant install NVidia drivers, second monitor is recognized but has "no signal"

Hey guys! I am pretty new to manjaro in general but used Linux for a few years now (not as a power user, though)

Due to problems with multi monitor support on manjaro Cinnamon, I wanted to switch to KDE so i decided to reinstall manjaro KDE (erasing the disc and installing new)

  1. Problem: Installation

The installation sadly never finished. Manjaro KDE got stuck at 95% (with “misc post configuration” or so. sadly i dont remember the full text now) on 2 seperate tries. Simply force rebooting the system worked to get into Manjaro and update the system with

sudo pacman -Syyu

But i do not know if something was lost or broken because of this.

  1. Problem: Second Monitor

My second Monitor is a 4k one. If i connect it to my Machine, its recognized and even has some windows start over there. Problem is that the monitor itself stays black with the “no signal” message. changing the primary Monitor does not help and i am forced to currently disconnect it to even reliably work on my desktop

  1. Problem: Nvidia drivers and MHWD

the MHWD script seems to be broken.

when i tried to install it through the system settings i get the following error message:

 Waiting for user input...
 Starting
 > Installing video-nvidia-450xx...
 Sourcing /etc/mhwd-x86_64.conf
 Has lib32 support: true
 Sourcing /var/lib/mhwd/db/pci/graphic_drivers/nvidia-450xx/MHWDCONFIG
 Processing classid: 0300
 Sourcing /var/lib/mhwd/scripts/include/0300
 Processing classid: 0302
 : Synchronizing package databases...
 warning: nvidia-450xx-utils-450.66-1 is up to date -- skipping
 error: target not found: linux56-nvidia-450xx
 core is up to date
 extra is up to date
community is up to date
multilib is up to date
Error: pacman failed!
Error: script failed!

Done ...

I tried to install the driver directly through

pacman -S nvidia

and choosing the 450 driver, but i do not know if this actually worked, as the system settings still show the free driver as installed.

can you guys please help me? this is my main working machine and i can not even get tstzarted moving my files here if i cant even get the graphics card or monitors to function properly. I am afraid this will cost me my weekend.

Please run inxi -Fza and sudo mhwd -li.

Hi!
The kernel 5.6 is end of live,you need to install 5.7/ 5.8 or a lts one. I always recommend having 2 kernels, one let’s say for backup

on it!

here the output for inxi -Fza

System: Kernel: 5.8.6-1-MANJARO x86_64 bits: 64 compiler: N/A
parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 root=UUID=341a7eca-86c7-4e4a-9ae3-0969dc58c526 rw quiet apparmor=1
security=apparmor resume=UUID=c14af20f-9a64-464c-a500-fbf2e1e734b4 udev.log_priority=3
Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.0 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux
Machine: Type: Desktop System: Gigabyte product: N/A v: N/A serial:
Mobo: Gigabyte model: Z170-HD3P-CF v: x.x serial: UEFI [Legacy]: American Megatrends v: F2
date: 07/27/2015
CPU: Topology: Quad Core model: Intel Core i5-6600 bits: 64 type: MCP arch: Skylake-S family: 6 model-id: 5E (94)
stepping: 3 microcode: D6 L2 cache: 6144 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 26411
Speed: 800 MHz min/max: 800/3900 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled
Type: mds mitigation: Clear CPU buffers; SMT disabled
Type: meltdown mitigation: PTI
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: disabled, RSB filling
Type: srbds status: Vulnerable: No microcode
Type: tsx_async_abort mitigation: Clear CPU buffers; SMT disabled
Graphics: Device-1: NVIDIA GM204 [GeForce GTX 980] vendor: Gigabyte driver: nouveau v: kernel bus ID: 01:00.0
chip ID: 10de:13c0
Display: x11 server:X.Org 1.20.8 compositor: kwin_x11 driver: modesetting alternate: fbdev,nouveau,nv,vesa
display ID: :0 screens: 1
Screen-1: 0 s-res: 2560x1440 s-dpi: 96 s-size: 676x380mm (26.6x15.0") s-diag: 775mm (30.5")
Monitor-1: DP-2 res: 2560x1440 dpi: 109 size: 597x336mm (23.5x13.2") diag: 685mm (27")
OpenGL: renderer: NV124 v: 4.3 Mesa 20.1.7 direct render: Yes
Audio: Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: Gigabyte driver: snd_hda_intel v: kernel
bus ID: 00:1f.3 chip ID: 8086:a170
Device-2: NVIDIA GM204 High Definition Audio vendor: Gigabyte driver: snd_hda_intel v: kernel bus ID: 01:00.1
chip ID: 10de:0fbb
Device-3: Astro Gaming type: USB driver: snd-usb-audio bus ID: 3-1.4.3:5 chip ID: 9886:002b
Sound Server: ALSA v: k5.8.6-1-MANJARO
Network: Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Gigabyte driver: r8169 v: kernel
port: d000 bus ID: 06:00.0 chip ID: 10ec:8168
IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac:
Drives: Local Storage: total: 4.77 TiB used: 2.62 TiB (54.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda vendor: SanDisk model: SDSSDA240G size: 223.57 GiB block size: physical: 512 B logical: 512 B
speed: 6.0 Gb/s serial: rev: 00RL scheme: MBR
ID-2: /dev/sdb vendor: Western Digital model: WD30EZRZ-00GXCB0 size: 2.73 TiB block size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s rotation: 5400 rpm serial: rev: 0A80 scheme: GPT
ID-3: /dev/sdc type: USB vendor: Western Digital model: WD Elements 25A1 size: 1.82 TiB block size: physical: 512 B
logical: 512 B serial: rev: 1012 scheme: GPT
Partition: ID-1: / raw size: 197.78 GiB size: 193.68 GiB (97.92%) used: 11.15 GiB (5.8%) fs: ext4 dev: /dev/sda1
Swap: Kernel: swappiness: 60 (default) cache pressure: 100 (default)
ID-1: swap-1 type: partition size: 25.79 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda2
Sensors: System Temperatures: cpu: 40.5 C mobo: 29.8 C gpu: nouveau temp: 33 C
Fan Speeds (RPM): N/A gpu: nouveau fan: 1361
Info: Processes: 205 Uptime: 28m Memory: 23.44 GiB used: 1.72 GiB (7.4%) Init: systemd v: 246 Compilers: gcc: 10.2.0
Packages: pacman: 1207 lib: 339 flatpak: 0 Shell: Bash v: 5.0.18 running in: konsole inxi: 3.1.05

here the output of sudo mhwd -li

Warning: No installed PCI configs!
Warning: No installed USB configs!

From this i can already see that this might have had soemthing to do with the failed installation (under problem 1) because i think its not normal to not have any USB or PCI configs 0o

yep! i did that first. I have installed Kernel 5.8.6-1. Its shown to be installed and running in my settings

1 Like

Hi!
Now install the driver

1 Like

The problem accured after installing the new kernel! Sadly i still get the same error.

1 Like

Hi!
Did you uninstall the 5.6 kernel? If you have it installed when you try to install the drivers it would install it for all kernels.

1 Like

Oh? i didnt know that! let me uninstall the old kernel. i will post the result.

1 Like

quick update: the error has not yet appeared, but the script now seems stuck on

Waiting for user input…
Starting
Installing video-nvidia-450xx…

i will wait for a while, then post again.

1 Like

Excellent! the Nvidia driver is reported to be successfully installed! Thank you for that @visone !

Now there is still the problem with my second monitor.

Hi!
Search in the forum, there’re some threads about dual monitor configurations

just reconnected the monitor. NOW it works (drivers do wonders it seems)

Thx all! now i can start with moving my files! you may have saved my day! I will post if new problems arise, but if not, a Mod can close this one!