fresh installation freezes on t490

Hello, I installed manjaro (KDE and XFCE) on my laptop (free and non free drivers). While booted from the flash drive everything works fine, I get no error during the installation. But once I boot into the system everything freezes after about 1 minute and I have to shut down the laptop by holding the power button. I am unable to run most commands via the terminal like "inxi -G", when trying to switch to tty I only get a black screen.

Neofetch on the live system reports:

██████████████████  ████████   manjaro@manjaro 
██████████████████  ████████   --------------- 
██████████████████  ████████   OS: Manjaro Linux x86_64 
██████████████████  ████████   Host: 20N3S02L00 ThinkPad T490 
████████            ████████   Kernel: 4.19.28-1-MANJARO 
████████  ████████  ████████   Uptime: 9 mins 
████████  ████████  ████████   Packages: 1093 (pacman) 
████████  ████████  ████████   Shell: bash 5.0.0 
████████  ████████  ████████   Resolution: 1920x1080 
████████  ████████  ████████   DE: KDE 
████████  ████████  ████████   WM: KWin 
████████  ████████  ████████   Theme: Breath [KDE], Adwaita [GTK2], Breath [GTK3] 
████████  ████████  ████████   Icons: breath [KDE], Adwaita [GTK2], maia [GTK3] 
████████  ████████  ████████   Terminal: konsole 
                               Terminal Font: Noto Mono 10 
                               CPU: Intel i7-8565U (8) @ 4.600GHz 
                               GPU: NVIDIA GeForce MX250 
                               GPU: Intel UHD Graphics 620 
                               Memory: 1620MiB / 15695MiB

Just a little more information since this could be a number of problems. Which video drivers are are installed? What flash writer did you use to make the live USB?

My guess is kernel related.

If you have a ISO'ed stick which works - boot it.

Then open a terminal and chroot (default pass is manjaro)

sudo manjaro-chroot -a

Then install kernel 5.2

sudo pacman -Syu linux52

Or

sudo mhwd-kernel -i linux52

Then

exit

And

reboot

Grub selects the latest installed kernel by default.

Which video drivers are are installed?

Running inxi -G took about 30 seconds.

Graphics:  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel 
           Device-2: NVIDIA GP108M [GeForce MX250] driver: nouveau v: kernel 
           Display: x11 server: X.Org 1.20.5 driver: intel,modesetting resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics (Whiskey Lake 3x8 GT2) v: 4.5 Mesa 19.1.3

What flash writer did you use to make the live USB?

balenaEtcher on Ubuntu

I installed kernel 5.2. And now I am able to run commands without the system freezing. Looks like a GPU (nouveau) problem. My dmesg log is here https://pastebin.com/raw/w7wRHn0A.

Changing to nvidia drivers fixed most of my problems. Thank you