Fresh installation failed

Hello, I tried installing Manjaro Gnome daily build (210804-linux510) but I get this unusual error:

Partition setup:

  • fat32 /boot/efi/ flag: boot
  • linuxswap flag: swap
  • ext4 / flag: root
  • ext4 /home/

Secure boot disabled. Drive is clean, no Windows or anything installed. A fresh install.

Do you know what might be the problem? I’m more than happy to provide any information you need regarding the installation/hardware used. Thanks!

Edit: There IS a Windows installation but it’s on another drive. So I suppose this doesn’t mean I’m dual booting?

Don’t know if this will help or not but try it anyway.

Load the live session of manjaro. Open the user guide. Start at page 73. Especially pg 75 & 76.

Have a look through there to see if you missed a selection.

1 Like

Thanks, but nothing I didn’t do before. I even selected “Erase disk” instead of manual partitioning and still the same error.

Additional information, the file that the installer is looking for is actually in a separate directory: /tmp/.../boot/efi/EFI/grub/grubx64.efi. I wonder why it’s not in the right place or why the installer is looking for it in the wrong place.

This is most likely a error with the installer.

The EFI specification suggests that different distributions uses a subfolder of EFI to avoid collisions between when multibooting systems.

What is a bit puzzling is the file being looked for is in the EFI folder but the actual file being in EFI/grub - usually Manjaro creates a folder EFI/manjaro where the grub bootloader is stored.

I suggest you open an issue at Issues · Applications / calamares · GitLab - add a link to this topic.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.