Fresh install of Manjaro results in unrecognised UUID error (check solution and comment #9)

Hello everyone

I just migrated from Pop!_OS after a botched update left me with some screen issues. I don’t like to keep old traces of a former OS so during installation I went with the erase disk option and let the installer do its own thing. Everything went smoothly but after I restarted when prompted I was greeted by ERROR: device "<UUID here>" not found. Skipping fsck. mount: /new_root: can't find UUID=<UUID here>

Then I got dropped into an emergency shell with tty: job control turned off. I was a little surprised since this is the first time I’ve run into errors because of leaving the installer to do its thing. I’ve tried installing Manjaro 8 different times already, including manually partitioning the SSD but still no go. I’ve looked up solutions online including disabling my RAID drive but still no go. Due to my research, I have a fair idea of what I need to post in order to receive help so they are below

Running cat /etc/fstab results in this,inxi gives me this output, sudo fdisk -l gives me this and finally lsblk gives me this text.

Please help me because I can’t boot my PC up to get any work done and currently sending this from the Manjaro LiveUSB! Oh yeah also for some reason no network devices detected and can only connect online using a cable hooked to my MiFi but I’m interested in successfully booting first.


Since you use encryption the UUID is set here: cat /etc/crypttab

Intel RST? Try adding vmd MODULE to mkinitcpio for early loading.



then run

sudo mkinitcpio -P

:warning: It have to be on the local disk via chroot if you are on a live session.

1 Like

Hello, first post here to try to help.
Let me see, you are trying to upgrade from PopOS to manjaro?
“only Linux distribution that enables pre-installed full-disk encryption out of the box”
An ecrypted partition will give to the installation a different blkid (that is my guess).
For what i see in your messages, you got an nvme drive with only Linux.
Easy way, backup your data and wipe the disk with the fully auto installation of manjaro.
The try way, get the block id of the partition (# blkid), put it at /etc/fstab
If it is an raid0. The raid creates at the bios a HEADER, needed to be exclude IN the BIOS, gparted or any other one Partition Manager can not undoit.
Enter your bios, create new raw partition.

Hi thanks for your reply.

I checked /etc/crypttab and I got

# Configuration for encrypted block devices.
# See crypttab(5) for details.

# NOTE: Do not list your root (/) partition here, it must be set up
#       beforehand by the initramfs (/etc/mkinitcpio.conf).

# <name>       <device>                                     <password>              <options>
# home         UUID=b8ad5c18-f445-495d-9095-c9ec4f9d2f37    /etc/mypassword1
# data1        /dev/sda3                                    /etc/mypassword2
# data2        /dev/sda5                                    /etc/cryptfs.key
# swap         /dev/sdx4                                    /dev/urandom            swap,cipher=aes-cbc-essiv:sha256,size=256
# vol          /dev/sdb7                                    none

I don’t know if that’s very useful

I had Intel Optane which I reset in the BIOS so I don’t know if it’s still there. I’ve tried the vmd option before but not with chroot. How would I do this but with chroot please?

Thanks again

I guess manjaro-chroot -a will not work with an encrypted device. You will have to decrypt the device an then mount it:

sudo mount /dev/mapper/root-image /mnt


manjaro-chroot /mnt /bin/bash

There you should be able to add it:

nano /etc/mkinitcpio.conf

and put this in (or replace it)



mkinitcpio -P
1 Like

Hey thanks for the reply

Your comment is similar to the thought process I went through. In order not to create any conflicts between the two distros, my general rule of thumb is to always fully erase disk the of the previous distro with the new one’s installer and that’s what I did with Pop!_OS.

I don’t know if there are any remains of Pop but checking my Boot Device Order it’s Manjaro and Windows only (Windows has always being there regardless of whether I have it installed or not and it just boots to the Linux installation anyway so that’s not a problem).

To clarify I have already done a full disk erase already before (like 8 times with Manjaro already) so I doubt there’s any Pop encryption stuff (unless…) and it installs on nvme0n1px (x being partition number). If there’s any more help you can provide or anything else I can provide please let me know!


I get an error on this one

mount: /mnt: special device /dev/mapper/root-image does not exist

I don’t want to proceed after this :frowning:

As i said:

and maybe it has a different name. Search the web. I don’t use encrypted drives.

I did it haha!

So I took your suggestion and realised I’m supposed to mount THE partition with Manjaro root installed and so I took the following steps

sudo mount /dev/nvme0n1p2
manjaro-chroot /mnt /bin/bash
nano /etc/mkinitcpio.conf

edit the line


and then did

mkinitcpio -P

I reboot and the output was something-something clean and now I am officially using Manjaro! I’ve rebooted a couple of times to make sure it’s a permanent fix and so far so good!

Thanks a bunch @megavolt, you just saved my bacon :sob: :sob:


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.