Freeze with log entry: kernel NULL pointer dereference


Some weeks ago my system had random freezes (without any specific error messages in the logs), ignoring all keyboard and mouse inputs, so I had to hard reset the PC. Since memtest86+ and smartctl didn’t show any errors and after some trying I changed the SATA cables and the system was stable again.

Today the PC froze again with following log entries:

$ journalctl -b -1 -p3
-- Logs begin at Wed 2020-07-15 22:24:38 CEST, end at Thu 2020-08-27 18:19:55 CEST. --
Aug 27 15:39:56 ferdl colord-sane[983]: io/hpmud/pp.c 627: unable to read device-id ret=-1
Aug 27 15:39:56 ferdl lightdm[1024]: gkr-pam: unable to locate daemon control file
Aug 27 15:47:24 ferdl kernel: BUG: kernel NULL pointer dereference, address: 0000000000000030
Aug 27 15:47:24 ferdl kernel: #PF: supervisor read access in kernel mode
Aug 27 15:47:24 ferdl kernel: #PF: error_code(0x0000) - not-present page

My system:

$ inxi -Fxza
  Kernel: 5.4.58-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 
  root=UUID=0d3c6dbf-652b-49d7-8ef1-5d6daec8003c rw apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: Xfce 4.14.2 tk: Gtk 3.24.20 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
  Type: Desktop Mobo: MICRO-STAR model: 785GM-E51 (MS-7596) v: 1.0 
  serial: <filter> BIOS: American Megatrends v: 2.12 date: 02/18/2011 
  Topology: 6-Core model: AMD Phenom II X6 1075T bits: 64 type: MCP 
  arch: K10 family: 10 (16) model-id: A (10) stepping: N/A 
  microcode: 10000DC L2 cache: 3072 KiB 
  flags: lm nx pae sse sse2 sse3 sse4a svm bogomips: 36012 
  Speed: 960 MHz min/max: 800/3000 MHz boost: enabled Core speeds (MHz): 
  1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass status: Not affected 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 
  mitigation: Full AMD retpoline, STIBP: disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: AMD RS880 [Radeon HD 4200] vendor: Micro-Star MSI driver: radeon 
  v: kernel bus ID: 01:05.0 chip ID: 1002:9710 
  Display: x11 server: X.Org 1.20.8 driver: ati,radeon unloaded: modesetting 
  alternate: fbdev,vesa display ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: DVI-0 res: 1920x1080 hz: 60 dpi: 92 
  size: 531x298mm (20.9x11.7") diag: 609mm (24") 
  OpenGL: renderer: AMD RS880 (DRM 2.50.0 / 5.4.58-1-MANJARO LLVM 10.0.1) 
  v: 3.3 Mesa 20.1.5 compat-v: 3.0 direct render: Yes 
  Device-1: AMD SBx00 Azalia vendor: Micro-Star MSI driver: snd_hda_intel 
  v: kernel bus ID: 00:14.2 chip ID: 1002:4383 
  Sound Server: ALSA v: k5.4.58-1-MANJARO 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Micro-Star MSI driver: r8169 v: kernel port: e800 bus ID: 03:00.0 
  chip ID: 10ec:8168 
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Local Storage: total: 14.10 TiB used: 10.06 TiB (71.3%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda vendor: Hitachi model: HDS723020BLA642 size: 1.82 TiB 
  block size: physical: 512 B logical: 512 B speed: <unknown> 
  rotation: 7200 rpm serial: <filter> rev: A5C0 scheme: MBR 
  ID-2: /dev/sdb vendor: Seagate model: ST31500341AS size: 1.36 TiB 
  block size: physical: 512 B logical: 512 B speed: 3.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: CC1H scheme: MBR 
  ID-3: /dev/sdc vendor: Seagate model: ST10000DM0004-1ZC101 size: 9.10 TiB 
  block size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: DN01 scheme: GPT 
  ID-4: /dev/sdd vendor: Hitachi model: HDS723020BLA642 size: 1.82 TiB 
  block size: physical: 512 B logical: 512 B speed: 3.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: A180 scheme: MBR 
  ID-5: /dev/sde type: USB vendor: Verbatim model: STORE N GO size: 3.73 GiB 
  block size: physical: 512 B logical: 512 B serial: <filter> rev: 5.00 
  scheme: MBR 
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
  ID-1: / raw size: 30.00 GiB size: 29.40 GiB (98.00%) 
  used: 22.60 GiB (76.9%) fs: ext4 dev: /dev/sda3 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 44.6 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 227 Uptime: 1h 39m Memory: 13.43 GiB used: 1.80 GiB (13.4%) 
  Init: systemd v: 245 Compilers: gcc: 10.1.0 Packages: pacman: 1282 
  lib: 387 flatpak: 0 Shell: Bash v: 5.0.18 running in: xfce4-terminal 
  inxi: 3.1.05 

What can cause the freeze? Shall I provide more information?

Thanks and regards

When booting after that last hard reset I got the error message:

mount: /new_root: can't read superblock on /dev/sda3

With fsck.ext4 this problem was solved again.

That sounds like a hardware problem: one of the components in your machine might be failing. Does this also happen:

  • on a newer kernel?
  • while logged on as a newly created user?

Please, please please read all of this:


I’ve only tried with an older kernel (4.19), but I will try now with a newer one and, if needed, with a new user.

Ad REISUB: I already knew about it and I’ve also tried, but it didn’t work. Now I’ve learned you first have to enable it with grub… But, now it works, thanks! :wink:

1 Like

With the newer kernel 5.7 the system froze again.

I created a new user, logged in and the system did not freeze anymore since then. Also, when logged in as the old user.

But how should a new user has an effect on the stability of the system?

BTW: After the last freeze REISUB did NOT work, although enabled… The Keyboard didn’t show any reaction (not even the light of numlock changed, as at the former freezes).

Mostly due to new/fresh config files for DE and programs.
Theming is also reset.
Sometimes the cache resets make all the difference.

1 Like

That’s what I was trying to find out: Whether it was a profile or system issue and apparently it’s a profile issue. :innocent:

My further recommendation is to just forget about the old profile and copy not move your Documents, Music, … folders over to the new user and disable the old user and delete the old user’s home directory with all its files in 6 months time…

If you would not have enough space to do that, just copy Documents from old to new, delete documents, copy Music, delete Music etc… then disable user and delete user in 6 months.


Note 1 Don’t delete the old user. Just delete its home directory, just in case that in 1 year or so you still find a file from the old user you’ll still see its name instead of an ID (and that takes just a few KB on your system)
Note 2: If you need any specific help with any of the above, please leave another response.


@Fabby @freggel.doe Many thanks for your hints, so far!

It sounds scaring to me that a profile issue can freeze the system so that even REISUB doesn’t work anymore…

I want to move my system from my HDD to a new SSD anyway, following the Arch guide “Migrate installation to new hardware” → bottom to top (sorry, but I’m not allowed to post a link… :unamused:).

When creating a new user on the new installation/SSD, can I use the same name and ID as on the old installation/HDD?

Can I copy the old config files to the new user or should I config the system all from the start (which would be pretty much work…)?

My music and video files are now on a separate HDD and shall stay there. Do I nevertheless have to copy those files?

That’s a whole different topic and should not be approached the way you’re approaching it IMHO. So just get your current system in order first and when that’s done and it works:

  • press the Solution for your original problem. :+1:
  • search for “CloneZilla device to device” and that’s the solution to your new issue… If you would run into any problems with that new issue, just create a new question. :innocent:

It’s not like we charge you more for creating a new topic!

:stuck_out_tongue_winking_eye: :crazy_face:

OK, thanks again!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.