FreeCad


#1

Seguinte eu tinha o free cad instalado pelo AUR e em determinado momento apareceu uma atualização de dois pacotes: python2-shiboken2 e python2-pyside2. Sendo que eu não conseguia atualizar esses pacotes o erro era não é possível resolver uma dependência, acreditei que eu deveria possuir o python3 e decidi desinstalar esses pacotes, porém o freecad foi junto e agora quando tento instalar ele da erro justamente por conta desses pacotes


#2

Tu puedes intentar instalar la .appimage https://freecadweb.org/downloads.php

O reinstalar los paquetes de Phyton antes de instalar freecad desde Aur


#3

obrigado pela resposta XtyM, baixei o app do free cad e funcionou, porém apos fechar o aplicativo quando tento abrir de novo aparece essa mensagem


#4

Ao instalar os pacotes python2-shiboken2 e python2-pyside2, utilize a opção de editar, e em _qtver=5.12.1 você altere para _qtver=5.12.0.
O erro provavelmente acontece porque o pacote qt5-xmlpatterns do Manjaro ainda está na versão 5.12.0.

Ps: não atualize esses dois pacotes para uma versão superior a do qt5-xmlpatterns.


#5

oi tioguda você teria como me auxiliar nessa tarefa?
minha experiencia com linux é menos de um mês
só sei ir até aqui:


#6

Instale os dois pacotes que mencionei antes do Freecad para fazer a “correção”. Eu auxilio no processo.


#7

fiz a alteração no primeiro pacote mas apresentou o seguinte erro


#8

Adicione os números dessa linha no lugar da que contem no pkgbuild do python2-shiboken2 (além da alteração anterior).

sha256sums=('890149628a6c722343d6498a9f7e1906ce3c10edcaef0cc53cd682c1798bef51')

E no pkgbuild do python2-pyside2, você troca por essa (além da alteração anterior).

sha256sums=('890149628a6c722343d6498a9f7e1906ce3c10edcaef0cc53cd682c1798bef51')

#9

Se estiver com alguma duvida @andersonbruno02, é só perguntar.


#10

@tioguda não sei que tipo de bruxaria foi essa que você fez mas esta indo.
o shiboken compilou bem rápido porém o pyside esta demorando bastante.
acredito que agora vai da certo, porém ainda estou com algumas duvidas quando eles aparecerem para atualizar devo apenas ignorar?
alguma dica para que eu não faça besteiras como essa de novo?

obrigado pela ajuda, nem acredito que vou conseguir voltar a usar o cad tava quase para formatar o sistema por causa disso haha


#11

Não atualize eles agora (ignore), só atualize ele quando o pacote qt5-xmlpatterns do Manjaro for atualizado para a versão 5.12.1 ou posterior.
Sempre que acontecer algo do tipo com pacotes da AUR, verifique se o erro não é por causa das versões referentes a algum outro pacote (como foi esse o caso), os pacotes da AUR são para o Arch, como o Manjaro dá uma “segurada” nas atualizações para uma melhor estabilidade, pode ocorrer isso.


#12

no caso onde eu posso verificar a versão do qt5-xmlpatterns?


#13

No próprio Pamac, basta digitar o nome do pacote e verificar a versão que ele está.
Quando ele for atualizado, você faz o mesmo processo que fez hoje e só altera a versão e o sha256sums.
O sha256sums você pode retirar do arquivo baixado e que está na pasta /var/tmp/pamac-build-seuusuário/nomedopacote com o comando sha256sum *tar.xz. Altere as informações conforme necessário, já que alguns pacotes podem utilizar md5sum ou sha1sum, como o arquivo pode estar empacotado em outro formato como tar.gz, zip, etc…

Ps: a versão são os números anteriores ao hífen(-).


#14

https://forum.freecadweb.org/viewtopic.php?t=27784

Cambia las opciones de icono de arranque para arrancar una simple instancia.

Coloca esto como el comando de ejecución el las opciones del icono (propiedades del icono de freecad opciones de carga commando)

Exec=freecad-daily --single-instance %U

https://git.launchpad.net/~freecad-maintainers/+git/gitpackaging/tree/debian/freecad-daily.desktop?h=dailybuild-occt

Edit: Ésto trabajó para mi en su día. pero también puedes preguntar en su foro

Mucha suerte!


#15

tudo certo obrigado a todos pelas respostas