Fps drops almost to zero after few minutes

but i only play cs go and quake arena both 10+ years old.

Quake III Arena , that’s how much time there has to be :+1:

Very nice

CS Go over Steam ?

1 Like

cpu is stable around 58 and GPU around 70.
There is something still there i know.

If the screen froze and i switch with alt+tab terminal and back, the game is smooth again.
I can do this everytime, but more frequently around 2 min.
why is this problem only on linux?

Here is the same motherboard with Nvidia graphics and the following grub Option

acpi_osi=Linux acpi_osi='!Windows 2012' acpi_backlight=vendor dm_mod.use_blk_mq=1

no idea if this is all correct and needed for the board, test it

1 Like

yes over steam. I tried install also half life 2 without steam with wine, and sometimes i can play one hour straight sometimes i need 3 reboots because directx9 is not responding error. Really don’t know why all of this

ok, that means that i need try to install openmandriva distro?


many people use the option -vulkan for CS GO

tried already



modify this line
GRUB_CMDLINE_LINUX_DEFAULT="quiet udev.log_priority=3"


GRUB_CMDLINE_LINUX_DEFAULT="quiet mitigations=off acpi_osi=Linux acpi_osi='!Windows 2012' acpi_backlight=vendor dm_mod.use_blk_mq=1 nowatchdog nvidia-drm.modeset=1 udev.log_priority=3"

in Terminal update-grub


i did that. In one minute cs go froze and was not responding. Don’t know what can i still do…

I had a similar problem a long time ago and switching performance toggles in nvidia-settings helped. In particular I recall turning on “sync to VBlank”. I’d play with the settings there, downgrade quality too and see if it matters.

I have sync to VBlack turned on and all settings on performance.

You can copy and paste text directly into the board.
inxi -Fza > /home/<your account name>/log
and then open it with kwrite and copy and paste.

1 Like
  Kernel: 5.15.76-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=de406ee5-b06e-4029-8c04-81ebf3c50a75 rw quiet mitigations=off
    acpi_osi=Linux "acpi_osi=!Windows 2012" acpi_backlight=vendor
    dm_mod.use_blk_mq=1 nowatchdog nvidia-drm.modeset=1 udev.log_priority=3
  Desktop: KDE Plasma v: 5.26.2 tk: Qt v: 5.15.6 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: Gigabyte model: EP31-DS3L serial: <superuser required>
    BIOS: Award v: FC date: 09/16/2008
  Info: model: Intel Core2 Quad Q9550 bits: 64 type: MCP arch: Penryn
    level: v1 built: 2008 process: Intel 45nm family: 6 model-id: 0x17 (23)
    stepping: 0xA (10) microcode: 0xA0B
  Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
    desc: d-4x32 KiB; i-4x32 KiB L2: 12 MiB desc: 2x6 MiB
  Speed (MHz): avg: 3605 min/max: N/A cores: 1: 3605 2: 3605 3: 3605 4: 3605
    bogomips: 28845
  Flags: ht lm nx pae sse sse2 sse3 sse4_1 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: EPT disabled
  Type: mds status: Vulnerable; SMT disabled
  Type: meltdown status: Vulnerable
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_store_bypass status: Vulnerable
  Type: spectre_v1 status: Vulnerable: __user pointer sanitization and
    usercopy barriers only; no swapgs barriers
  Type: spectre_v2 status: Vulnerable, STIBP: disabled, PBRSB-eIBRS: Not
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GM206 [GeForce GTX 960] driver: nvidia v: 470.141.03
    alternate: nouveau,nvidia_drm non-free: 520.xx+
    status: current (as of 2022-10) arch: Maxwell code: GMxxx
    process: TSMC 28nm built: 2014-19 pcie: gen: 1 speed: 2.5 GT/s lanes: 16
    ports: active: none off: HDMI-A-1 empty: DP-1,DVI-D-1,DVI-I-1
    bus-ID: 01:00.0 chip-ID: 10de:1401 class-ID: 0300
  Display: x11 server: X Org v: 21.1.4 compositor: kwin_x11 driver: X:
    loaded: nvidia gpu: nvidia,nvidia-nvswitch display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 101 s-size: 483x272mm (19.02x10.71")
    s-diag: 554mm (21.82")
  Monitor-1: HDMI-A-1 mapped: HDMI-0 note: disabled model: Samsung S22E390
    serial: <filter> built: 2015 res: 1920x1080 hz: 60 dpi: 102 gamma: 1.2
    size: 477x268mm (18.78x10.55") diag: 547mm (21.5") ratio: 16:9 modes:
    max: 1920x1080 min: 640x480
  API: OpenGL v: 4.6.0 NVIDIA 470.141.03 renderer: NVIDIA GeForce GTX
    960/PCIe/SSE2 direct render: Yes
  Device-1: Intel NM10/ICH7 Family High Definition Audio
    vendor: Gigabyte GA-D525TUD driver: snd_hda_intel v: kernel bus-ID: 5-2:2
    bus-ID: 00:1b.0 chip-ID: 0951:16ed class-ID: 0300 chip-ID: 8086:27d8
    class-ID: 0403 serial: <filter>
  Device-2: NVIDIA GM206 High Definition Audio driver: snd_hda_intel
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 16 bus-ID: 01:00.1
    chip-ID: 10de:0fba class-ID: 0403
  Device-3: Kingston HyperX Cloud Alpha S type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Sound API: ALSA v: k5.15.76-1-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.21 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.59 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Gigabyte driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: d000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  Local Storage: total: 530.98 GiB used: 26.06 GiB (4.9%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT250MX500SSD1
    size: 232.89 GiB block-size: physical: 4096 B logical: 512 B
    speed: <unknown> type: SSD serial: <filter> rev: 023 scheme: MBR
  ID-2: /dev/sdb maj-min: 8:16 vendor: Hitachi model: HDT725032VLA360
    size: 298.09 GiB block-size: physical: 512 B logical: 512 B speed: <unknown>
    type: N/A serial: <filter> rev: A7EA scheme: MBR
  ID-1: / raw-size: 68.34 GiB size: 66.71 GiB (97.62%) used: 26.06 GiB (39.1%)
    fs: ext4 dev: /dev/sda1 maj-min: 8:1
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: file size: 5 GiB used: 0 KiB (0.0%) priority: -2
    file: /swapfile
  System Temperatures: cpu: 51.0 C mobo: N/A gpu: nvidia temp: 49 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 26%
  Processes: 178 Uptime: 1h 55m wakeups: 0 Memory: 3.83 GiB
  used: 2.1 GiB (54.8%) Init: systemd v: 251 default: graphical
  tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: pm: pacman
  pkgs: 1261 libs: 347 tools: pamac pm: flatpak pkgs: 0 Shell: Zsh v: 5.9
  default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.23

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

Your root partition is nearly full.
You need a bigger SSD (512GB or greater).

Can you change yor post: ``` before and after the log.

I have steam games on another partition.

I tried with just web online games which don’t require much ram and cpu power and it’s the same issue. But in this case the game doesn’t froze all the way, just for 2 sec and then it’s like a refresh button and works again. In other games (CS GO and Quake) i noticed that if you alt+tab before freze (like refresh) the game run, or if the game is loading and loading in infinity, i just alt+tab and i’m in the game. I tried some settings on nvidia drivers, looking for some refresh intervals or something,but i did’t find nothing. There is still something

RAM full + Swap full + Root partition full = Low FPS.

Yes i understand that, but why games on windows 10 which need alot more ram working like a charm?

Guys i found the problem. I tested ram with software and i saw that one of the 2gb is damaged. I changed damaged ram and woila everything
works like a charm. Thanks for help everyone.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.