Fotoxx does not run since last update

Since the substantial update at the weekend fotoxx (AUR) does not run anymore. It can be launched in the terminal, but it quits after a few seconds by a forced shutdown. It is a very good, lovable application that I do not want to miss. What is your opinion: will fotoxx in AUR be adapted soon, or will it not be maintained further in manjaro. If the latter is the case, it would be a great, great pity.
I myself am 76 years old, and my Linux knowledge is not enough to recreate fotoxx.
I’m using a german tuxedo AURA 15, with ryzen 7 and 16 GB RAM.

AUR packets are not supported or developed by manjaro team. You can try to rebuild it with the button in pamac for example? Otherwise you can write to its developer or look for a flatpak or appimage version of it.


There should be a log file at ~/.fotoxx/fotoxx.log, maybe you find some pointers about the reason for the shutdown. You have to enable ‘Show hidden files’ in your thunar file managers to view it.
There’s a known problem when handling more than 10000 photos.

AUR (en) - fotoxx shows last updated 1st of August '23, so it’s actively maintained. Monitor the site for relevant comments or post there yourself if the log file provides some clues. It’s probably a minor issue and will be fixed within a couple of weeks, don’t lose hope.

Thank you very much for your answers.
For me it would be a great pity if this application would no longer run in manjaro. For me it is by far the best after GIMP, and has it been for very many years! I can’t even understand why it is not available in the Official Software Sources.
Unfortunately for me that would also mean that I would have to look for another distribution. Also this would sadden me very much, because I have taken manjaro very much to my heart and some of my friends have become convinced Linux users and manjaro friends too. So let’s be confident that fotoxx will continue to be maintained in AUR.
Best regards from Lake Constance to this wonderful community!

I installed it just out of curiosity. Works fine, xfce stable branch here.

…so, recompile or look for errors.

1 Like

Same here, also xfce,I just installed fotoxx, it works.

As I said above, there is a known issue with the indexing of picture folders. The indexer has a problem when indexing more than 10 000 files and at first startup of the newly installed fotoxx a popup window lets you define the settings of the indexer and it warns:

If the indexer is pointed to folders that contain corrupt files the program will crash at startup.

This is most likely your problem; your picture folder contains corrupted files or more than 10 000 files.

To fix your issue either:

  • reinstall as @banjo said but point the indexer to a new empty folder. Then move the pictures from your old folder in batches over to the new one and restart fotoxx after every batch. The moment fotoxx crashes remove the last batch again and check if you find the corrupted file.
  • don’t reinstall but move all pictures from your current folder to a backup folder. Start fotoxx with the original picture folder empty. If it does start move pictures in batches from the backup folder back into the original one. After each batch restart fotoxx. Again, the moment fotoxx crashes remove the last batch again and check if you find the corrupted file.

Thanks for your suggestions, but unfortunately that’s not the problem. fotoxx doesn’t start at all, so I can’t change anything. ( Besides, there are only about 200 photos in the top folder).
Fortunately, I had a snapshot that is only two weeks old. If I reinstall that, everything runs again as it should - but then I should not make any more updates. You see, it’s not easy …
But I hope, the maintainer of fotoxx may have already become aware of these problems.

Have you tried that already? And it works?

Have you tried an appimage

Thank you!
I know how to handle appimages, but this one doesn’t work.

I also am able to install and run the program. If you already tried rebuilding it and it still doesn’t run, have you also tried making a backup of the ./fotoxx folder and try running it again, it is possible a config file or something got corrupted.

In any event, since there are at least two of us here that can run the program, that indicates to me that the problem is local to your machine.

1 Like

If you cannot run the appimage too, there are 2 reasons: the config because it is shared between the 2 installs, or a missing dependency. If you try to run it from terminal it will tell you what is missing. It is usually something like not found and then you can search which package has it with pacman -F

1 Like

I just now tried to install it. It failed. Got a bunch of error messages. Here is a log file:

log file: /home/xxxxxx/.fotoxx/fotoxx-23.60.log

start fotoxx Thu Sep 14 12:03:39 
modprobe: FATAL: Module nvidia not found in directory /lib/modules/6.5.2-1-MANJARO
A fatal error has occurred. 
See zappcrash file in home folder.
Warning: Missing charsets in String to FontSet conversion

*** zappcrash: x86_64 Manjaro Linux fotoxx-23.60 Sep 14 2023 16:01:07 fatal signal: segment fault 
*** zappcrash context: (null) | (null) 

*** zappcrash: x86_64 Manjaro Linux fotoxx-23.60 Sep 14 2023 16:01:07 fatal signal: segment fault 
*** zappcrash context: (null) | (null) 
*** please send this crash report to *** 
*** if possible, please explain how to repeat this problem *** 
zexit: Zexit zappcrash

I used to use this program. It was pretty good. I switched over to xnviewmp.

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

Hi, you guys really tried to help me with my fotoxx problem, but please understand: I’m 76 and now it’s starting to get too complicated for me. I can’t get the appimage to work and neither can fotoxx since the update. Something must be wrong with my computer (AMD ryzen 7, 16 RAM, xfce) - but I don’t get it. Everything else works as it should. I will report if there is a solution at some point, but for now I give up.

I’m looking at xnviewmp right now - it looks really good. I did not know this program! Fast, comfortable, easy to use, and it seems to have everything on board that I need. Maybe the solution to the problem comes from a completely different direction, as so often in life!

1 Like

I downloaded fotoxx and built it manually. I had to install
libchamplain-gtk when I ran make.

After installing that make worked as intended.

But sudo make install resulted in the exact same error messages as before. :frowning:

One more word about XnView: According to my first impressions, the program can do everything you need to organize, manage and edit photos. It’s very clear, intuitive and very fast. (And if you need more, then, there’s GIMP) So far, I’m really, really impressed. I probably won’t miss fotoxx very much!

For me, the poblem is solved. fotoxx does not run, but I have found a replacement that absolutely satisfies me. Even if fotoxx would work again, I would continue to use XnView. I thank everyone who tried to help me.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.