Forum font too small

In my Firefox settings I have set fontsize to 16, but this forum, wiki and main site ignores it. This 10pt'ish text is unreadable.

Ctrl + + changes the zoom level.

1 Like

On this forum, go to your preferences -> interface -> text size.

i didn't remember that was there! ...and i'll forget again, because it's not enough. "largest" text at 100% is smaller than "normal" text at my normal 133%.

I find that weird. My setting is on normal, and it looks fine on both Windows & Linux on my 27" 1440p monitor. Large and Largest are both very big to me.

also looks fine here.
I dont think I have ever messed with my browsers font settings
(just DPI like everything else)
but .. if I were so inclined .. I would ensure to enforce my font values everywhere ... the settings allow you to choose how much of a 'guideline' that setting is.

Would be nice if websites uses em and rem more rather than px. Would alleviate a lot of issues.

em .. or % is fine too.
(em is cool because it comes from oldschool printmaking :slight_smile:)

This answer is correct. It's hard to imagine a situation in which you would want to force the font size by any other means. Firefox will even remember the last zoom level the next time you visit a site.

The setting you've changed is for the default font size, which applies only if a site has not explicitly set a font size. All pages on Manjaro's sites have set the font size explicitly.

If you really must override the font size for a particular site in Firefox, it is possible to do so.

First, type about:config in the Firefox address bar, and press Enter. Click through the warning. Then search for this preference (paste the following text in the Search box or type the first several characters):

toolkit.legacyUserProfileCustomizations.stylesheets

Double-click this preference to change its value from false to true.

You can now close about:config.

Still in Firefox, press Alt+H and select Troubleshooting Information. Click the Open Directory button next to Profile Directory. Your Firefox profile folder should now be displayed in your file manager.

Open the chrome folder and create this file:

userContent.css

Open userContent.css in a text editor and paste this text:

@-moz-document domain(manjaro.org) {
    * { font-size: 24px !important; }
}

Save this file.

Now close and reopen Firefox, and go to any Manjaro page. You should find that the text is much larger than it was before. Adjust the font-size in userContent.css until it's as large as you like.

2 Likes

(nice css per-site tweak)
Also I just meant this if you want to 'force' fonts everywhere:


Also of course above it you can also see another useful option: "Minimum font size"

2 Likes

Forum kindly sponsored by