Foreign Keyboard and Minecraft

I switched to Manjaro a day ago, it’s my first linux distribution, everything works great, for games the performance (fps) is much better BUT
I will take as an example a game that everyone has already experienced: Minecraft.

If I press very quickly the keys 1 and 2 (above the a and z since I use an azerty keyboard) the active inventory slot does not change
so I can’t use an item quickly from my hotbar

Even if the keys 1,2,3,4,5,6,7,8,9 allow me to change the hotbar slot, I can’t put an item in my hotbar from the inventory

I took Minecraft as an example, but if these two things are solved it will solve the problems of other games, I have tried the solutions of similar topics without success
(I used deepl to translate, im french)

Thanks in advance!

original title : Bad layout for French keyboard and input latency

You have to add a US keyboard in addition to the French (or foreign) keyboard in fcitx

and I also solved the same problem for a friend who uses gnome:

:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    How to provide good information
    and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies…
  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information… (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.
  3. Notre forum en Français se trouve ici. Si tu remets tout en :fr: , je veux bien migrer ta question là-bas puisque des traductions automatiques son nuls quand on y mets des commandes en :uk:


P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you’re using, which CPU/GPU or Kernel, … you have without typing it every time

Hello @Oka1 :wink:

If you press keys very fast, then the system thinks you hold the button, thus it stops reacting and waits for the delay until it repeats the key. And while the delay is working, it rejects any input.

It probably has to do with “key repeat”. So the “delay” and the “speed”. You should be able to change that somewhere under “Keyboard” at the XFCE Settings.


here is the system information as well as the information concerning the keyboard

  Kernel: 5.10.36-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=d6923789-e6b9-40df-9ba0-5644ff786c9a rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.24 info: xfce4-panel wm: xfwm4 vt: 7 
  dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux

Device-2: 1-5:3 info: Logitech G910 Orion Spectrum Mechanical Keyboard 
  type: Keyboard,HID driver: hid-generic,usbhid interfaces: 2 rev: 2.0 
  speed: 12 Mb/s power: 500mA chip-ID: 046d:c335 class-ID: 0300 
  serial: <filter> 

  1. Have you tried another keyboard already? (Non-Logitech, non-mechanical)
  2. It’s better to provide all of the data: now we only have a partial view of your system.


1 Like


With the package “keyboard layout viewer” I see that the system does not consider that I maintain the keys

I also tried to modify the delay and speed in the parameters (I should have put that I had already tried), even if I put the delay at the minimum and the speed at the maximum then if I type in a row “1,2,3,4,5” then the slot will go from slot 1 to 5 directly

the problem is always present,
I forgot to mention that I can’t type the 3rd symbols of the keyboard with Ctrl+alt, I use AltGr instead.

I correct the title of the post

The parameters I use for the keyboard :

imgur com/wgo8f1F.png (I can’t put a link yet)

Could you test this in libinput?

Display all devices:

sudo libinput list-devices | grep "Device:\|Kernel:"

and run

sudo libinput debug-events --device /dev/input/event<N>

(replace <N> with the correct event number from the previous list)

Now test, if the input of the keys are received correctly.

oh thx,

-event7   DEVICE_ADDED     Logitech Gaming Keyboard G910     seat0 default group1  cap:k
 event7   KEYBOARD_KEY     +3.208s	*** (-1) pressed
a event7   KEYBOARD_KEY     +3.305s	*** (-1) pressed
z event7   KEYBOARD_KEY     +3.384s	*** (-1) pressed
e event7   KEYBOARD_KEY     +3.464s	*** (-1) released
 event7   KEYBOARD_KEY     +3.492s	*** (-1) released
 event7   KEYBOARD_KEY     +3.519s	*** (-1) released

in fact, the entries are incorrect, typing “aze”, it is marked that I have released the key ‘a’ after I press the other keys which is incorrect.

It should say pressed-released, pressed-released, pressed-released and not pressed-pressed-pressed released-released

At least you know now, that it is problem with keyboard and the driver. But honestly, i have no idea how this could be solved :man_shrugging:

1 Like

it’s normal the pressed,pressed,pressed , released,released,released , the real problem is that the pressed between the first pressed and the last pressed are not taken into account

thanks anyway


1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.