foobar does not install

Hello,

I cannot install foobar. The message I get (the last lines) is: 'Preparing...
Cloning foobar2000 build files...
Checking foobar2000 dependencies...
Building foobar2000...
/var/tmp/pamac-build-jojo/foobar2000/PKGBUILD: line 25: unexpected EOF while looking for matching `''
/var/tmp/pamac-build-jojo/foobar2000/PKGBUILD: line 45: syntax error: unexpected end of file
==> ERROR: Failed to source /var/tmp/pamac-build-jojo/foobar2000/PKGBUILD

Something similar perhaps happens when installing foobnix. Be warned that if you try to install foobnix it takes about four hours.

I have not met these in previous installations; I am on a fresh one.

Thank you!
'

That package is flagged out of date.

Have you tried qoob ?

Can you post contents of
/var/tmp/pamac-build-jojo/foobar2000/PKGBUILD

Please use code tags when you post it.

How do I know if a package is out of date? qoob is not to my liking. Clementine is the closest to foobar, I think.

# Maintainer: Mario Finelli <mario at finel dot li>

pkgname=foobar2000
pkgver=1.4.3
pkgrel=1
pkgdesc="An advanced freeware audio player (uses Wine)."
arch=(i686 x86_64)
url="http://www.foobar2000.org/"
license=('custom')
depends=(wine desktop-file-utils)
makedepends=(p7zip wget)
source=("foobar2000_v$pkgver.exe::https://www.foobar2000.org/download"
        "LICENSE"
        "${pkgname}.sh"
        "${pkgname}.png"
        "${pkgname}.desktop")
install="${pkgname}.install"
sha256sums=('1672c7435add7dc47d8b4e85cbe31b6906365a5443798dd97a8d9a87cd1544c3'
            '6a0aec62c077dae45b778b9e18ae6f470d5105c020e4e44a67ab267f0bf40e35'
            '3a1876b7f7f9b0297a633d7e6a480f92a2eeea46d8496a3546fcb1b0859be7aa'
            '2031e952d1d1d6cb4c2ff2b879421149f3f0780ca5d3ac03bc9c23fcbbd053d6'
            '2b6134997e55ce5ef5014dc266cda71b763949ad683d321246a5143333dd1fa0')
DLAGENTS=('https::/usr/bin/wget -nH --cut-dirs=3 -r -l 2 -A exe -R '*beta*.exe' %u')
# DLAGENTS=('https::/usr/bin/wget -nH --cut-dirs=3 -r -l 2 -A exe %u')

package() {
  # unpack NSIS installer .exe into destination
  7z x "${pkgname}_v${pkgver}.exe" -x'!$PLUGINSDIR' -x'!$R0' -x'!icons' \
    -x'!foobar2000 Shell Associations Updater.exe' -o"${pkgdir}/usr/share/${pkgname}"

  # correct filesystem permissions
  find "${pkgdir}" -type d -execdir chmod 755 {} +

  # run foobar2000 in portable mode
  touch "${pkgdir}/usr/share/${pkgname}/portable_mode_enabled"

  # Install the license
  install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"

  # Install the script
  install -Dm755 "${srcdir}/${pkgname}.sh" "${pkgdir}/usr/bin/${pkgname}"

  # Install the icon
  install -Dm644 "${srcdir}/${pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"

  # Install the .desktop
  install -Dm644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
}

Foobar 1.4.3 no longer exists on the server as 1.4.4 has been released.

==> Validating source files with sha256sums...
    foobar2000_v1.4.3.exe ... NOT FOUND
    LICENSE ... Passed
    foobar2000.sh ... Passed
    foobar2000.png ... Passed
    foobar2000.desktop ... Passed
==> ERROR: One or more files did not pass the validity check!

I bumped it to 1.4.4 and it builds successfully:

cd /var/tmp/pamac-build-jojo/foobar2000/PKGBUILD
nano PKGBUILD #or use your favorite text editor

Change pkgver from 1.4.3 to 1.4.4

updpkgsums
makepkg -si

I'm the AUR maintainer of foobnix. What problem did you have?

That's because it takes a long time to build one of the dependencies, webkitgtk. If you poke around the internet, you can find a precompiled package if you trust the maintainer.

Have you tried DeadBeef? I was a foobar2000 user myself back when I used Windows, but now DeadBeef is all I need Example Config

https://aur.archlinux.org/packages/foobar2000

Thank you! I did not know it ...

Yes, I have. I gave it up as I did not see how to configure shortcut keys.

The little brain as I have like Winnie the Pooh, I used to change to v. 1.4.4. in the pamac GUI installer. I also tried as you suggested the /var path. No luck

I do not understand ```
updpkgsums
makepkg -si


Perhaps here is the solution

As to foobnix, here is what error message I get:

running install
running install_lib
warning: install_lib: 'build/lib' does not exist -- no Python modules to install

running install_scripts
error: cannot copy tree 'build/scripts-2.7': not a directory
==> ERROR: A failure occurred in package().
    Aborting...

I don't understand... Just go to EDIT | PREFERENCES | and then SHORTCUT KEYS tab
(image below is in Portuguese, sorry)

AUR package is out of date since last Saturday because of new version released
if you cannot edit 2nd line of pkgbuild as already suggested:

AUR maintainer should get version change added soon

They're commands, run them after you update the pkgver to 1.4.4 in the PKGBULID.

I can reproduce that, I'll look into it. There was no issue the last time I built it, so it may be something that needs to be fixed upstream. It's not a very active project, so I may drop it if I can't fix it. Arch will be dropping Python 2 by the end of the year anyway.

Thank you very much! I have managed to install foobar as Yochanan suggested. I shall keep it in mind.

1 Like

Thank you very much! I have managed to install foobar as you suggested.

It is a pity foobnix will no longer be developed and maintained. I like it very much!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.