Fonts menu bug (BGR display, setting returns to RGB)

I am on the Manjaro 20.1 testing branch, KDE, amdgpu video-linux driver

When I apply the setting for BGR subpixel rendering (System Settings-Appearance-Fonts), the setting returns to RGB when re visiting the menu.

Is that a visual bug, or the setting does not work?
Thank you

(Cannot embed media, hope I explained well)

Problem stil persists with the most recent testing updates…

Bump! I can now embed media, so I’ve created an animation showing the problem:

Does setting it manually work ?

How can I do that manually? From a config file for KDE somwhere?

Looks quite weird as the compositor does reset when applying (screen elements flash), so it could’ve set it, but it still shows RGB there in the menu.

This would be one way.
(even more manual would be eschewing the links and just making your own conf file)

There is a problem. There is no file mentioning subpixel under /etc/fonts/conf.d/ nor is there any line in /etc/fonts/fonts.conf, but I found the preset files in /etc/fonts/conf.avail/.

So it means that the UI is not adding those symlinks.

Do you suggest to just dump the contents of the BGR plugin straight into /etc/fonts/fonts.conf to see if it changes anything, or I break the system?

You can create the symbolic link yourself, or you can manually create/edit a file with the options.
I do suggest using the xxx.d folder because its just more sensical for having custom options as ‘addon’ files.

It worked! Copied the file to conf.d and now the GUI shoes BGR. Text looks a lot better on my weird display now.

How can I formally report this bug? To the KDE bug tracker?

You might want to check for the same behavior on a new user to verify it isnt an issue with your config or something. But yeah … it would appear to be a plasma bug.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.