Folders disappeared

  GNU nano 6.2                .config/user-dirs.dirs                           
# This file is written by xdg-user-dirs-update
# If you want to change or add directories, just edit the line you're
# interested in. All local changes will be retained on the next run.
# Format is XDG_xxx_DIR="$HOME/yyy", where yyy is a shell-escaped
# homedir-relative path, or XDG_xxx_DIR="/yyy", where /yyy is an
# absolute path. No other format is supported.
#
XDG_DESKTOP_DIR="$HOME/"
XDG_DOWNLOAD_DIR="$HOME/"
XDG_TEMPLATES_DIR="$HOME/"
XDG_PUBLICSHARE_DIR="$HOME/"
XDG_DOCUMENTS_DIR="$HOME/Documents"
XDG_MUSIC_DIR="$HOME/"
XDG_PICTURES_DIR="$HOME/"
XDG_VIDEOS_DIR="$HOME/"
XDG_MYFOLDER_DIR="$HOME/Myfolder"

all my files disappeared don’t know what happened though.
I reinstall the xdg-user-dirs and xdg-user-dirs-gtk hoping it will fix it but it did nothing… I also edited the .config/user-dirs.dirs and when i reboot the config/user-dirs.dirs file still the same…
Any help will be appreciated.

Even if you change the xdg dirs - your files does not disappear - they are still there in their respective folders - whichever locale it was.

If your files really disappeared for good - you have other more serious problems.

everything is gone except Documents folder itself everything inside also gone too

Then you have other problems.

So I reckon you have gone over the content of your home folder to locate your files and not found them?

You must have run some delete or move operation - perhaps accidently - because files don’t just vanish.

Do you recall any drag and drop operation in the file manager?

Some file managers do not - unless the file drag and drop is cross device/partition - ask for confirmation on the move.

So you it is technically possible to select a lot of folders and drop them in an unexpected place - then you think - what? - where did they go - it has happened to me more times than I care to admit.

Another option is accidental deletion - but then you should be able to locate them in the trash - the physical location is ~/.local/share/Trash/files.

If the deletion has been done by means of a terminal command - the files are deleted on sight - which means no trash recovery only forensic recovery even then - if the folders has been rewritten the files may be very hard to recover.

1 Like

If you do,

ls -l -R -h -a /home/username/

…it shows nothing?

i wanted to uninstall mysql but the bash cound not find mysql so i deleted mysql files and later found out that it mariadb so i also deleted ralated files to mariadb and it dependencies :smiling_face_with_tear: then later found out that i could just use pacman to uninstall mariadb … i think that why all my files is vanished also my browser history and downloads of brave is gone forever… i just want to add those folders as it was :disappointed_relieved: :sob:

a bunch of stuffs is shown here but i don’t believe the folder i really wanted is among…(Downloads, Pictures, Videos, Music, Public) these are gone bro :disappointed_relieved:

With all due respect, what the heck were you doing?

now am enjoying what i reaped bro. :joy:

is there anyway i cound get them back or need to install manjaro again from the start?

We hope for you that you have a good backup :cry:

If you do use timeshift or btrfs & snapper or any backup-program, you can get them back.

You find good Information about Btrfs in the wiki

https://wiki.manjaro.org/index.php/Btrfs
and in
https://forum.manjaro.org/t/how-to-manual-rollback-with-btrfs/80230/5
https://forum.manjaro.org/t/how-to-rescue-data-from-a-damaged-btrfs-volume/79414/4

Make Backups:

i do but all my recent code i wrote need to be done again… thank God it not much… it can be done in a few hours :frowning_with_open_mouth:

thanks bro will check it out :+1:

Thanks to btrfs and snapper i get everything back that is older than 60 min. Even if i delete it accidentally, or overwrite it.
:smiling_face_with_three_hearts:

Take care :slight_smile:

btrfs

1 Like

yeah… i solved it but didn’t get my files back though

im glad i did it though… but i got a backup of my files before it happened… so no problem about that

1 Like

Please have a look at snapper-rollback@github and at snapshot-layout@wiki.archlinux for the suggested flat layout and the reasoning.

If you want to use graphic interface of snapper, then try btrfs-assistant-git from AUR. It was made by dalto.

  • Rollback supports custom flat layout and the default layout of snapper.
  • Simply creating and deleting snapshots.
  • Snapshot diff viewer has the ability to restore files.