Fn+F4 (speaker mute) doesn't work in chroot

This happens also with “aplay -D sysdefault” on host, but the same command works fine on Armbian. The device is a Pinebook Pro. I’ve been trying to fix this for weeks now.

Here’s what I know:

  • the issue is with the host OS as the audio from the same chroot can be muted on Armbian (XFCE) but not on Manjaro (tried KDE Plasma and XFCE)
  • tried both “sudo chroot” and “schroot -c” with same results
  • Armbian XFCE uses “xfce4-pulseaudio-plugin” to handle volume control (Fn keys) while Manjaro KDE Plasma uses “plasma-pa”
  • Armbian lists more devices with “aplay -L” because of “libasound2-plugins” package (“alsa-plugins” on Manjaro)

Any help is much appreciated!

So did you install alsa-plugins and power cycle to see if that helped?
I don’t know what magic Armbian invokes for this if any. And to be honest, I can’t see much of a use-case outside your niche.

Yes and no. I installed alsa-plugins (+shutdown) and no, it didn’t help. I would like to fix this, but it’s hard to debug since it’s a problem with the host OS.