Flowblade close immediately or freeze

About 8 month ago, after a Manjaro Cinnamon update, the video editor Flowblade stopped working.
Some month later I did a fresh installation of Manjaro KDE, but Flowblade does not work on this edition as well.
Most of the times it closes just a second after it opens or it opens and freeze immediately and needs a kill command to get rid of the window!
A reinstall does not solve the problem, nor a change of display resolution.

BTW, I’ve no idea why there are (now, recently) some firejail lines, even so it’s started normally, not by Firejail/Firetools and yes, Firetools got messed up by the last update, but Flowblade stopped working about 8 month ago!

$ LANG=C flowblade
Reading profile /etc/firejail/flowblade.profile
Reading profile /etc/firejail/allow-python2.inc
Reading profile /etc/firejail/allow-python3.inc
Reading profile /etc/firejail/disable-common.inc
Reading profile /etc/firejail/disable-devel.inc
Reading profile /etc/firejail/disable-exec.inc
Reading profile /etc/firejail/disable-interpreters.inc
Reading profile /etc/firejail/disable-programs.inc
Parent pid 9985, child pid 9986
Warning: /sbin directory link was not blacklisted
Warning: /usr/sbin directory link was not blacklisted
Warning: not remounting /run/user/1000/doc
Warning: not remounting /run/user/1000/gvfs
Child process initialized in 156.91 ms
Launch script dir: /usr/bin
Running from installation...
modules path: /usr/lib/python3.10/site-packages/Flowblade
MLT found, version: 7.12.0
numpy version: 1.23.5
Application version: 2.8.0
OS: Manjaro Linux
Python 3.10.9 (main, Dec 19 2022, 17:35:49) [GCC 12.2.0]
GTK+ version: 3.24.36
XDG user data exists.
Locale: en_US
Translations at /usr/share/locale were not found, using program root directory translations.
Use OS locale language.
Valid shortcut files found: ['flowblade.xml', 'premiere.xml']
Keyboard shortcuts file: flowblade.xml
Gtk version is 3.24.36, Flowblade theme is available.
Using Full Screen size for layout: 1920 x 1080
Small height: False
Small width: False
mlt_repository_init: failed to dlopen /usr/lib/mlt-7/libmltsox.so
  (libsox.so.3: cannot open shared object file: No such file or directory)
mlt_repository_init: failed to dlopen /usr/lib/mlt-7/libmltmovit.so
  (libmovit.so.8: cannot open shared object file: No such file or directory)
mlt_repository_init: failed to dlopen /usr/lib/mlt-7/libmltrtaudio.so
  (librtaudio.so.6: cannot open shared object file: No such file or directory)
Detecting environment...
  - a64multi
  - a64multi5
  - alias_pix
  - amv
  - apng
  - asv1
  - asv2
  - avrp
  - avui
  - ayuv
  - bitpacked
  - bmp
  - cfhd
  - cinepak
  - cljr
  - dnxhd
  - dpx
  - dvvideo
  - exr
  - ffv1
  - ffvhuff
  - fits
  - flashsv
  - flashsv2
  - flv
  - gif
  - h261
  - h263
  - h263p
  - huffyuv
  - jpeg2000
  - jpegls
  - ljpeg
  - magicyuv
  - mjpeg
  - mpeg1video
  - mpeg2video
  - mpeg4
  - msmpeg4v2
  - msmpeg4
  - msvideo1
  - pam
  - pbm
  - pcx
  - pfm
  - pgm
  - pgmyuv
  - phm
  - png
  - ppm
  - prores
  - prores_aw
  - prores_ks
  - qoi
  - qtrle
  - r10k
  - r210
  - rawvideo
  - roqvideo
  - rpza
  - rv10
  - rv20
  - sgi
  - smc
  - snow
  - speedhq
  - sunrast
  - svq1
  - targa
  - tiff
  - utvideo
  - v210
  - v308
  - v408
  - v410
  - vbn
  - vc2
  - wrapped_avframe
  - wmv1
  - wmv2
  - xbm
  - xface
  - xwd
  - y41p
  - yuv4
  - zlib
  - zmbv
  - libaom-av1
  - libopenjpeg
  - librav1e
  - libsvtav1
  - libtheora
  - libvpx
  - libvpx-vp9
  - libwebp_anim
  - libwebp
  - libx264
  - libx264rgb
  - libx265
  - libxvid
  - h263_v4l2m2m
  - h264_amf
  - h264_nvenc
  - h264_qsv
  - h264_v4l2m2m
  - h264_vaapi
  - hevc_amf
  - hevc_nvenc
  - hevc_qsv
  - hevc_v4l2m2m
  - hevc_vaapi
  - mjpeg_qsv
  - mjpeg_vaapi
  - mpeg2_qsv
  - mpeg2_vaapi
  - mpeg4_v4l2m2m
  - vp8_v4l2m2m
  - vp8_vaapi
  - vp9_vaapi
  - vp9_qsv
  - comfortnoise
  - s302m
  - aac
  - ac3
  - ac3_fixed
  - alac
  - aptx
  - aptx_hd
  - dca
  - dfpwm
  - eac3
  - flac
  - g723_1
  - mlp
  - mp2
  - mp2fixed
  - nellymoser
  - opus
  - real_144
  - sbc
  - sonic
  - sonicls
  - truehd
  - tta
  - vorbis
  - wavpack
  - wmav1
  - wmav2
  - pcm_alaw
  - pcm_bluray
  - pcm_dvd
  - pcm_f32be
  - pcm_f32le
  - pcm_f64be
  - pcm_f64le
  - pcm_mulaw
  - pcm_s8
  - pcm_s8_planar
  - pcm_s16be
  - pcm_s16be_planar
  - pcm_s16le
  - pcm_s16le_planar
  - pcm_s24be
  - pcm_s24daud
  - pcm_s24le
  - pcm_s24le_planar
  - pcm_s32be
  - pcm_s32le
  - pcm_s32le_planar
  - pcm_s64be
  - pcm_s64le
  - pcm_u8
  - pcm_u16be
  - pcm_u16le
  - pcm_u24be
  - pcm_u24le
  - pcm_u32be
  - pcm_u32le
  - pcm_vidc
  - roq_dpcm
  - adpcm_adx
  - adpcm_argo
  - g722
  - g726
  - g726le
  - adpcm_ima_amv
  - adpcm_ima_alp
  - adpcm_ima_apm
  - adpcm_ima_qt
  - adpcm_ima_ssi
  - adpcm_ima_wav
  - adpcm_ima_ws
  - adpcm_ms
  - adpcm_swf
  - adpcm_yamaha
  - libgsm
  - libgsm_ms
  - libmp3lame
  - libopencore_amrnb
  - libopus
  - libspeex
  - libvorbis
  - a64
  - ac3
  - adts
  - adx
  - aiff
  - alp
  - amr
  - amv
  - apm
  - apng
  - aptx
  - aptx_hd
  - argo_asf
  - argo_cvg
  - asf
  - ass
  - ast
  - asf_stream
  - au
  - avi
  - avif
  - avm2
  - avs2
  - avs3
  - bit
  - caf
  - cavsvideo
  - codec2
  - codec2raw
  - crc
  - dash
  - data
  - daud
  - dfpwm
  - dirac
  - dnxhd
  - dts
  - dv
  - eac3
  - f4v
  - ffmetadata
  - fifo
  - fifo_test
  - filmstrip
  - fits
  - flac
  - flv
  - framecrc
  - framehash
  - framemd5
  - g722
  - g723_1
  - g726
  - g726le
  - gif
  - gsm
  - gxf
  - h261
  - h263
  - h264
  - hash
  - hds
  - hevc
  - hls
  - ico
  - ilbc
  - image2
  - image2pipe
  - ipod
  - ircam
  - ismv
  - ivf
  - jacosub
  - kvag
  - latm
  - lrc
  - m4v
  - md5
  - matroska
  - matroska
  - microdvd
  - mjpeg
  - mlp
  - mmf
  - mov
  - mp2
  - mp3
  - mp4
  - mpeg
  - vcd
  - mpeg1video
  - dvd
  - svcd
  - mpeg2video
  - vob
  - mpegts
  - mpjpeg
  - mxf
  - mxf_d10
  - mxf_opatom
  - null
  - nut
  - obu
  - oga
  - ogg
  - ogv
  - oma
  - opus
  - alaw
  - mulaw
  - vidc
  - f64be
  - f64le
  - f32be
  - f32le
  - s32be
  - s32le
  - s24be
  - s24le
  - s16be
  - s16le
  - s8
  - u32be
  - u32le
  - u24be
  - u24le
  - u16be
  - u16le
  - u8
  - psp
  - rawvideo
  - rm
  - roq
  - rso
  - rtp
  - rtp_mpegts
  - rtsp
  - sap
  - sbc
  - scc
  - film_cpk
  - segment
  - stream_segment,ssegment
  - smjpeg
  - smoothstreaming
  - sox
  - spx
  - spdif
  - srt
  - streamhash
  - sup
  - swf
  - tee
  - 3g2
  - 3gp
  - mkvtimestamp_v2
  - truehd
  - tta
  - ttml
  - uncodedframecrc
  - vc1
  - vc1test
  - voc
  - w64
  - wav
  - webm
  - webm_dash_manifest
  - webm_chunk
  - webp
  - webvtt
  - wsaud
  - wtv
  - wv
  - yuv4mpegpipe
  - alsa
  - fbdev
  - opengl
  - oss
  - pulse
  - sdl,sdl2
  - video4linux2,v4l2
  - xv
MLT detection succeeded, 182 formats, 120 video codecs and 82 audio codecs found.
607 MLT services found.
Loading render profiles...
Loading filters...
Loading transitions...
MLT transition region not found.
RGB Adjustment dropped for Color Adjustment
Hue dropped for Color Adjustment
Gamma dropped for Lift Gain Gamma
G'MIC found
Player initialized with profile:  HD 1080p 30 fps
Selected color NOT detected
BG color detected
Create SDL1 consumer...
io.github.jliljebl.Flowblade dbus service already exists
Autosave started...
Saving project...
No user folders actions needed.

Parent is shutting down, bye...

Those files do exit in the /usr/lib/mlt-7 folder !!
mlt_repository_init: failed to dlopen /usr/lib/mlt-7/libmltsox.so
(libsox.so.3: cannot open shared object file: No such file or directory)
mlt_repository_init: failed to dlopen /usr/lib/mlt-7/libmltmovit.so
(libmovit.so.8: cannot open shared object file: No such file or directory)
mlt_repository_init: failed to dlopen /usr/lib/mlt-7/libmltrtaudio.so
(librtaudio.so.6: cannot open shared object file: No such file or directory)
Why that error messages appear ??

My Manjaro KDE edition is not crippled in any way !!

$ inxi --admin --verbosity=7 --filter --no-host --width
  Kernel: 5.15.89-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=c4ba3ad5-ce95-4bdb-aba6-846a5d7ea3f0 rw apparmor=1
    security=apparmor quiet resume=UUID=f265748a-60cc-49be-92f2-675fc6003862
  Desktop: KDE Plasma v: 5.26.5 tk: Qt v: 5.15.8 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: TUXEDO product: TUXEDO Aura 15 Gen1 v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: NB01 model: NL5xRU serial: <superuser required> UEFI: INSYDE
    v: 1.07.08TTR3 date: 03/18/2021
  ID-1: BAT0 charge: 43.4 Wh (100.0%) condition: 43.4/48.3 Wh (90.0%)
    volts: 16.6 min: 15.2 model: Notebook BAT type: Li-ion serial: <filter>
    status: full
  RAM: total: 30.73 GiB used: 3.09 GiB (10.0%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: model: AMD Ryzen 7 4700U with Radeon Graphics bits: 64 type: MCP
    arch: Zen 2 gen: 3 level: v3 note: check built: 2020-22
    process: TSMC n7 (7nm) family: 0x17 (23) model-id: 0x60 (96) stepping: 1
    microcode: 0x8600106
  Topology: cpus: 1x cores: 8 smt: <unsupported> cache: L1: 512 KiB
    desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB L3: 8 MiB
    desc: 2x4 MiB
  Speed (MHz): avg: 1397 min/max: 1400/2000 boost: enabled scaling:
    driver: acpi-cpufreq governor: ondemand cores: 1: 1397 2: 1397 3: 1397
    4: 1397 5: 1397 6: 1397 7: 1397 8: 1397 bogomips: 31952
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
    bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy
    constant_tsc cpb cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total
    cqm_occup_llc cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid
    f16c flushbyasid fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb ibrs ibs
    irperf lahf_lm lbrv lm mba mca mce misalignsse mmx mmxext monitor movbe
    msr mtrr mwaitx nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae
    pat pausefilter pclmulqdq pdpe1gb perfctr_core perfctr_llc perfctr_nb
    pfthreshold pge pni popcnt pse pse36 rapl rdpid rdpru rdrand rdseed rdt_a
    rdtscp rep_good sep sha_ni skinit smap smca smep ssbd sse sse2 sse4_1
    sse4_2 sse4a ssse3 stibp succor svm svm_lock syscall tce topoext tsc
    tsc_scale umip v_spec_ctrl v_vmsave_vmload vgif vmcb_clean vme vmmcall
    wbnoinvd wdt xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT disabled
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    disabled, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Renoir vendor: CLEVO/KAPOK driver: amdgpu v: kernel
    arch: GCN-5.1 code: Vega-2 process: TSMC n7 (7nm) built: 2018-21 pcie: gen: 4
    speed: 16 GT/s lanes: 16 ports: active: eDP-1 empty: DP-1,DP-2
    bus-ID: 05:00.0 chip-ID: 1002:1636 class-ID: 0300 temp: 40.0 C
  Display: x11 server: X.Org v: 21.1.6 compositor: kwin_x11 driver: X:
    loaded: amdgpu unloaded: modesetting alternate: fbdev,vesa dri: radeonsi
    gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 mapped: eDP model: ChiMei InnoLux 0x15e8 built: 2018
    res: 1920x1080 hz: 60 dpi: 142 gamma: 1.2 size: 344x193mm (13.54x7.6")
    diag: 394mm (15.5") ratio: 16:9 modes: max: 1920x1080 min: 640x480
  API: OpenGL v: 4.6 Mesa 22.3.3 renderer: AMD Radeon Graphics (renoir LLVM
    15.0.7 DRM 3.42 5.15.89-1-MANJARO) direct render: Yes
  Device-1: AMD Renoir Radeon High Definition Audio vendor: CLEVO/KAPOK
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 05:00.1 chip-ID: 1002:1637 class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: CLEVO/KAPOK
    driver: N/A alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x pcie:
    gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 05:00.5 chip-ID: 1022:15e2
    class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: CLEVO/KAPOK
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 05:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Sound API: ALSA v: k5.15.89-1-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.21 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.64 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: CLEVO/KAPOK driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: 2000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp2s0 state: down mac: <filter>
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
    speed: 5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 8086:2723 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A
  IP v4: <filter> type: noprefixroute scope: global broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: global
  IP v6: <filter> virtual: stable-privacy scope: link
  WAN IP: <filter>
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 3-3:2
    chip-ID: 8087:0029 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Message: No logical block device data found.
  Device-1: luks-9ff12768-bfcb-480a-bb14-9b1232b8c160 maj-min: 254:0
    type: LUKS dm: dm-0 size: 850 GiB
  p-1: nvme0n1p3 maj-min: 259:3 size: 850 GiB
  Message: No RAID data found.
  Local Storage: total: 931.51 GiB used: 505.59 GiB (54.3%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: SSD 970 EVO Plus 1TB size: 931.51 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 2B2QEXM7 temp: 36.9 C scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 50 GiB size: 48.91 GiB (97.83%) used: 23.63 GiB (48.3%)
    fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2 label: ROOT
    uuid: c4ba3ad5-ce95-4bdb-aba6-846a5d7ea3f0
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 312 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 label: BOOT
    uuid: DDA8-94B1
  ID-3: /home raw-size: 850 GiB size: 835.58 GiB (98.30%)
    used: 481.96 GiB (57.7%) fs: ext4 dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-9ff12768-bfcb-480a-bb14-9b1232b8c160 label: HOME
    uuid: b1b8ba03-f566-45e1-82bc-ed1342d759d1
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 31.22 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p4 maj-min: 259:4 label: SWAP
    uuid: f265748a-60cc-49be-92f2-675fc6003862
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-1:2 info: Logitech Mouse type: Mouse driver: hid-generic,usbhid
    interfaces: 1 rev: 2.0 speed: 1.5 Mb/s power: 100mA chip-ID: 046d:c077
    class-ID: 0301
  Device-2: 1-2:3 info: Elan Micro ELAN:Fingerprint type: <vendor specific>
    driver: N/A interfaces: 1 rev: 2.0 speed: 12 Mb/s power: 100mA
    chip-ID: 04f3:0c63 class-ID: 0000
  Hub-2: 2-0:1 info: Super-speed hub ports: 2 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-3:2 info: Intel AX200 Bluetooth type: Bluetooth driver: btusb
    interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0029
    class-ID: e001
  Hub-4: 4-0:1 info: Super-speed hub ports: 2 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 50.1 C mobo: N/A gpu: amdgpu temp: 41.0 C
  Fan Speeds (RPM): N/A
  Processes: 281 Uptime: 2h 8m wakeups: 1 Init: systemd v: 252
  default: graphical tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7
  Packages: pm: pacman pkgs: 1953 libs: 426 tools: pamac,yay pm: flatpak
  pkgs: 0 Shell: Bash v: 5.1.16 running-in: konsole inxi: 3.3.24

A solution is very much appreciated.
Thank you for taking your time.

But you do have this packages installed: mlt sox movit rtaudio from official repositories?

This can cause issues sometimes, so you might want to address it and make it run just one of the sound servers, not both simultaneously. There are many topics about it on the forum.
For PulseAudio install manjaro-pulse
For PipeWire install manjaro-pipewire

Thank you for making me aware about that a possible conflict.
Pulseaudio comes from the original Manjaro KDE installation (of course), but I did not install Pipewire 1.03 (official repositories) consciously, but now I see were it came from:


OBS Studio and Telegram-Desktop rely on Pipewire!

Flowblade, OBS Studio and Telegram-Desktop are all in the official repositories and so are my installations!
Why isn’t the Manjaro Team aware about the that?
However, manjaro-pulse is installed from from the official repositories, while manjaro-pipewire is not installed on my system.

Neither systemctl --user stop pipewire.socket nor systemctl --user stop pipewire does solve the problem with Flowblade!

Majaro KDE is such a great distro,
but how do I handle those dependencies and a possible conflict with Flowblade?

sox movit rtaudio are not installed at all, while mlt is installed from the official repositories (not by myself, but as a dependency of a Software package).

Do I need to install manjaro-pipewire or one of those (sox movit rtaudio) ?

As a remark,
after a fresh installation of Manjaro KDE, only Software packages from the official repository were installed (and a few AUR packages, only in case those don’t exist in the official repository). Nothing extra, no extra drivers whatsoever, that’s why I mentioned and expressed “my system is not crippled at all”.

In addition, I check the source of all 12 dependencies which Flowblade relies on and all of those are from the official repository as Flowblade itself.

Please let me know, if any other log files are required to solve the issue.

Thank’s for taking your time.

While all other video related software work fine on my system (actually all Software I installed work fine), but Flowblade is a nightmare!
Most of the time Flowblade does not even start, but if the window appears it freezes as soon I make it full-screen!

If I recall it right, it stopped working around that time (about 8 month ago), when those AMD Graphic drivers related to my hardware were shifted into the kernel, but I’m not sure about that?
However, what I’m sure about is that I installed Flowblade on a fresh/virgin Manjaro KDE and it never worked. That’s why my guess is its hardware/driver related.

BTW, I’ve tried the old version 2.4 from AUR as well, on the Cinnamon Edition before I changed to KDE. with the same result (frozen Window)!

Generally speaking, Manjaro KDE runs smoothly on my system and the only exception so far is Flowblade.

Any idea for a solution?

Just a friendly request - please do not ping the team - just because your topic remains unsolved - it is bad behavior and therefore considered rude.

If an application doesn’t work as expected - you take it to the developer(s) - in this case

Try deleting the folder ~/.config/flowblade and restart the app

If your topic remains - there is no one which knows the answer or have any solution.

99% of the packages in Manjaro repo is imported from Arch repo - and their presence is not a sign of endorsement or recommendation nor is it a sign of quality.

Sorry for being unintentionally rude.
The responds from bogdancovaciu was a bit thin.

Well, I tried this at very first before everything else.
In addition, I tried Kernel 5.10 and 6.1 and I installed Manjaro in a VM, but none of all makes Flowblade work.
As it seems I’m quite alone with this problem, so I will simple send Flowblade to the graveyard.

Surprise !!
and maybe that might interest the Manjaro Team!

I gave it a last try, mainly to exclude my hardware and not blame Tuxedo.
So I installed Linux Mint 21.1 Cinnamon in a VM and Flowblade works fine!

Flowblade does not work in a Manjaro Cinnamon VM nor on my Manjaro KDE host, but in a Linux Mint Cinnamon VM.

All that boils down to Manjaro itself, doesn’t it?

Maybe, maybe not. Have you checked upstream issues to see if anyone else has had a similar problem?

Not necessarily. As @linux-aarhus mentioned above, flowblade, like most of the packages in the Manjaro repos is inherited directly from Arch. Did you try it on Arch? Have you tried the Flatpak?

Yes, but I didn’t see any reports there.

Haven’t tried it on Arch and I don’t like Flatpack.

Anyway, I’m tired of testing, will send it to where it belongs to.


Flatpak is a self contained application - created to solve the differences in system libraries across distributions.

When it comes to complex applications - the advise is - use whichever operating system the vendor supports.

While - at least in theory - any Linux applicaitons will work on any Linux - the reality is quite different - especially for rolling releases like Arch and by inheritance Manjaro.

So my advise is - use the distribution recommended by the vendor as this will work with the application(s) in question.

1 Like

Sure, Flatpaks, Snaps and Appimages are workarouds for those who like it as a last resort, but as long I have a choice I prefer the native ones.

Don’t you shoot yourself in the (Linux-) foot?
For Qubes OS your statement is very valid, but generally I would rather point it to the philosophie LTS vs Rolling Releases and their trade offs, than to the vendors as many vendors do not recommend neither support Linux, even so Linux works fine on many of those, at least in my experience.
Tuxedo supports Linux very well and is also one of your sponsors.

Since the Manjaro Update (2023-07-17) Flowblade 2.8 surprisingly works again (after a whole year), but the window scaling is awfully buggy in the latest Flowblade version 2.10!
It shoots a bit of the screen (left and right side) and cannot be adjusted (fixed minimum horizontal size).
Seems like it cannot handle my screen resolution 1920x1080 with 125% enlargement, while all other apps don’t have a problem with that.