Flatpaks very slow to start

Since Manjaro update 2022-02-05 (I think!) all my Flatpaks are very slow to start. They take about 30 seconds. Only Flatpaks are affected. Appimages and other apps start up very quickly. I re-installed Manjaro Gnome and still the same issue (I had to re-install the Flatpaks as they were deleted during the re-installation. My Home directory is on a separate partition and so was not deleted.)

I created a new User with admin privileges and installed some Flatpaks on that account and they start up just fine.

Any ideas on what is going on?

Hi @iason,

If it works fine for another user, it’s obviously a configuration problem. Start the Flatak from a terminal:

$ flatpak run <package.name>

Where, <package.name> is the Application Id of the Flatpak you wish to run.

And provide the output.

Also, see [HowTo] Provide System Information

Hi @Mirdarthos , thanks for the reply!

This is my inxi output:

  Kernel: 5.15.25-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=bd2a9365-128c-4471-b1c5-99744c8c65aa rw quiet splash apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: GNOME 41.4 tk: GTK 3.24.31 wm: gnome-shell dm: GDM 41.3
    Distro: Manjaro Linux base: Arch Linux
  Type: Mini-pc System: Intel Client Systems product: NUC8i7BEH v: J72992-306
    serial: <superuser required> Chassis: Intel Corporation type: 35 v: 2.0
    serial: <superuser required>
  Mobo: Intel model: NUC8BEB v: J72688-306 serial: <superuser required>
    UEFI: Intel v: BECFL357.86A.0085.2020.1007.1917 date: 10/07/2020
  Message: No system battery data found. Is one present?
  RAM: total: 15.49 GiB used: 4.14 GiB (26.7%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Core i7-8559U bits: 64 type: MT MCP arch: Coffee Lake
    family: 6 model-id: 0x8E (142) stepping: 0xA (10) microcode: 0xEC
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 901 high: 911 min/max: 400/4500 scaling:
    driver: intel_pstate governor: powersave cores: 1: 900 2: 900 3: 900 4: 900
    5: 900 6: 901 7: 900 8: 911 bogomips: 43214
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush clflushopt
    cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts
    epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu fsgsbase fxsr
    ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid
    invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr mtrr
    nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln
    pni popcnt pse pse36 pti pts rdrand rdseed rdtscp rep_good sdbg sep smap
    smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow
    tsc tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave
    xsavec xsaveopt xsaves xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
    IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel CoffeeLake-U GT3e [Iris Plus Graphics 655] driver: i915
    v: kernel ports: active: DP-1 empty: DP-2,HDMI-A-1 bus-ID: 00:02.0
    chip-ID: 8086:3ea5 class-ID: 0300
  Device-2: Focusrite-Novation Scarlett 2i2 Camera type: USB
    driver: snd-usb-audio bus-ID: 1-3.4:10 chip-ID: 1235:8210 class-ID: 0102
    serial: <filter>
  Display: wayland server: X.org v: with: Xwayland v: 22.1.0
    compositor: gnome-shell driver: X: loaded: intel gpu: i915 display-ID: 0
  Monitor-1: DP-1 model: Dell U2412M serial: <filter> built: 2013
    res: 1920x1200 dpi: 94 gamma: 1.2 size: 518x324mm (20.4x12.8")
    diag: 611mm (24.1") ratio: 16:10 modes: max: 1920x1200 min: 720x400
  Message: Wayland GBM/EGL data currently not available.
  Device-1: Intel Cannon Point-LP High Definition Audio driver: snd_hda_intel
    v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
    chip-ID: 8086:9dc8 class-ID: 0403
  Device-2: Focusrite-Novation Scarlett 2i2 Camera type: USB
    driver: snd-usb-audio bus-ID: 1-3.4:10 chip-ID: 1235:8210 class-ID: 0102
    serial: <filter>
  Sound Server-1: ALSA v: k5.15.25-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.47 running: yes
  Device-1: Intel Ethernet I219-V driver: e1000e v: kernel port: N/A
    bus-ID: 00:1f.6 chip-ID: 8086:15be class-ID: 0200
  IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A
  IP v4: <filter> scope: global
  WAN IP: <filter>
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
    driver: btusb v: 0.8 bus-ID: 1-10:6 chip-ID: 8087:0aaa class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 698.65 GiB used: 517.25 GiB (74.0%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: SSD 970 EVO Plus 250GB size: 232.89 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 2B2QEXM7 temp: 35.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 860 EVO 500GB
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 3B6Q scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 39.06 GiB size: 38.15 GiB (97.67%) used: 12.86 GiB (33.7%)
    fs: ext4 dev: /dev/nvme0n1p1 maj-min: 259:1 label: root
    uuid: bd2a9365-128c-4471-b1c5-99744c8c65aa
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
    used: 288 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p3 maj-min: 259:3 label: BOOT
    uuid: F311-5BDC
  ID-3: /home raw-size: 189.42 GiB size: 185.94 GiB (98.17%)
    used: 119.54 GiB (64.3%) fs: ext4 dev: /dev/nvme0n1p4 maj-min: 259:4
    label: home uuid: aefb6540-806f-441a-92b7-63241646e0e2
  ID-4: /run/media/iason/Samsung EVO 860 raw-size: 465.76 GiB
    size: 457.45 GiB (98.22%) used: 384.84 GiB (84.1%) fs: ext4 dev: /dev/sda1
    maj-min: 8:1 label: Samsung EVO 860
    uuid: 2aa20fde-9696-43c4-a5f8-4c494d432ce5
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 3.91 GiB used: 2.2 MiB (0.1%)
    priority: -2 dev: /dev/nvme0n1p2 maj-min: 259:2 label: swap
    uuid: f9d1ecc4-dca7-4fad-9741-8e413abfad87
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-3:7 info: Microchip (formerly SMSC) USB 2.0 Hub ports: 4 rev: 2.0
    speed: 480 Mb/s power: 2mA chip-ID: 0424:2514 class-ID: 0900
  Device-1: 1-3.1:8 info: Logitech Keyboard K120 type: Keyboard,HID
    driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 1.5 Mb/s
    power: 90mA chip-ID: 046d:c31c class-ID: 0300
  Device-2: 1-3.2:9 info: Logitech Unifying Receiver type: Keyboard,Mouse
    driver: logitech-djreceiver,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s
    power: 98mA chip-ID: 046d:c534 class-ID: 0301
  Device-3: 1-3.4:10 info: Focusrite-Novation Scarlett 2i2 Camera
    type: Audio driver: snd-usb-audio interfaces: 4 rev: 2.0 speed: 480 Mb/s
    power: 500mA chip-ID: 1235:8210 class-ID: 0102 serial: <filter>
  Device-4: 1-10:6 info: Intel Bluetooth 9460/9560 Jefferson Peak (JfP)
    type: Bluetooth driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s
    power: 100mA chip-ID: 8087:0aaa class-ID: e001
  Hub-3: 2-0:1 info: Super-speed hub ports: 6 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 33.0 C pch: 31.0 C mobo: 27.8 C
  Fan Speeds (RPM): N/A
  Processes: 296 Uptime: 5h 17m wakeups: 9 Init: systemd v: 250
  tool: systemctl Compilers: gcc: 11.2.0 Packages: 1213 pacman: 1195 lib: 312
  flatpak: 18 Shell: Zsh v: 5.8.1 running-in: gnome-terminal inxi: 3.3.13

I ran 4 Flatpak apps using the “faltpak run” command: Zoom, VLC, Handbrake and AbiWord.

With Zoom and AbiWord, I got no output in the terminal.

With Hanbrake, I got the following output:

(ghb:2): Gtk-WARNING **: 16:48:33.392: Theme parsing error: gtk.css:2:108: Failed to import: Error opening file /usr/share/gnome-shell/extensions/unite@hardpixel.eu/styles/gtk3/buttons-right/maximized.css: No such file or directory

With VLC I got the following:

VLC media player 3.0.16 Vetinari (revision 3.0.13-8-g41878ff4f2)
[000056107cbc70e0] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
Gtk-Message: 17:01:01.263: Failed to load module "canberra-gtk-module"
Gtk-Message: 17:01:01.263: Failed to load module "canberra-gtk-module"
Qt: Session management error: None of the authentication protocols specified are supported
[000056107cc5bc50] main playlist: playlist is empty
QObject::~QObject: Timers cannot be stopped from another thread

I hope this sheds some light on my issue!

OK, I have searched, but couldn’t find a reason for this.

So I’m recommending you do:

sudo flatpak repair

And see if that repairs it.

Or see if there is something in the logs:

journalctl --unit=<flatpak.unit>

Where <flatpak.unit> is the uit for flatpak which can theoretically be obtained using:

journalctl --field _SYSTEMD_UNIT | grep --ignore-case flat

Note: I say theoretically because I don’t use, or even have, Flatpak(s), so can not give you tried and tested information. Instead, it’s all educated guessing.

1 Like

The command

sudo flatpak repair

did not ameliorate the issue.

The command

journalctl --field _SYSTEMD_UNIT | grep --ignore-case flat



so I ran

journalctl --unit=flatpak-system-helper.service

and got

Mar 06 19:12:57 iason-manjaro systemd[1]: Starting flatpak system helper...
Mar 06 19:12:57 iason-manjaro systemd[1]: Started flatpak system helper.
Mar 06 19:12:57 iason-manjaro flatpak-system-helper[2402]: system: Pulled appstream2/x86_64 from /var/tmp/flatpak-cache-5U3ZI1/repo-dC9LjR
Mar 06 19:22:58 iason-manjaro systemd[1]: flatpak-system-helper.service: Deactivated successfully.

and I have no idea what all that means!

I have the feeling that it may be easier to create a new user, move all my personal files there and reinstall the flatpaks I use… That way I will hopefully not transfer the problem over to the new user account.

1 Like

Me neither. So I also suspect that’s probably the best option, yes.

Thanks for your help… Much appreciated!

1 Like

It looks like Flatpaks are working normally now. This is what I did:
I removed all Flatpaks through Pamac and them disabled Flatpaks in the Pamac settings.
I then ran the command

flatpak uninstall --unused

and then ran

flatpak repair

Finally, I deleted the ~/.local/share/flatpak folder with

rm -r ~/.local/share/flatpak

Note that I did not remove the /var/lib/flatpak folder. I first wanted to see if flatpaks were working and they were. I did, however, make sure that the folder /var/lib/flatpak/app was empty (which it was).

This post helped:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.