Flatpak apps wouldn't start

I recently decided to move from AUR to flatpack.
Yesterday I uninstalled a few apps and installed from flatpack, including SynologyDrive, Joplin, Discord on one computer. All the apps were working and I was surprised, flatpack apps didn’t require any config, they were just working with the previous settings. On another fresh Manjaro KDE install, I installed the same apps from flatpack from the beginning.
Today was able to start SynologyDrive and Discord. Joplin didn’t start. After reboot, none of the flatpack apps starts on both computers.
When I click on the icon, it spins a few seconds and just disappears from the dock.
When I run flatpak run net.cozic.joplin_desktop no errors in the terminal, no icon, it just hang. I tried to run flatpak repair, no errors.

Is anybody have the same problem? Is there any logs I can look at? What can I do to troubleshoot?

That’s exactly what happened to me with several other Flatpak apps (veloren, vorta, fooyin and something else I’ve forgotten because it’s not important). I just didn’t pursue it any further because there’s still other sources.

Sorry, it’s certainly no help :upside_down_face:

1 Like

I have same issues with some of these flatpak after a fresh installation.
May I know what is your locale setting?

1 Like
locale
                                                                                                                                                                                                         
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC=en_US.UTF-8
LC_TIME=en_US.UTF-8
LC_COLLATE="en_US.UTF-8"
LC_MONETARY=en_US.UTF-8
LC_MESSAGES="en_US.UTF-8"
LC_PAPER=en_US.UTF-8
LC_NAME=en_US.UTF-8
LC_ADDRESS=en_US.UTF-8
LC_TELEPHONE=en_US.UTF-8
LC_MEASUREMENT=en_US.UTF-8
LC_IDENTIFICATION=en_US.UTF-8
LC_ALL=

I don’t know what happens today. After update (it was a browser and thunderbird update only) and a reboot, all flatpacks work now.
I still would appreciate guidance regarding logs and flatpack troubleshooting tips.

That’s good to know.

My flatpak apps - Thunderbird, Krename, mkvtoolnix GUI, mediainfo, etc, still having issues.
And all the issues seem to be related to path / file name containing unicode characters, eg. , , , etc.
So it seems like a locale issue.
The worse thing is that: all these issues, were no issue before KDE Plasma 6.0.
The gurus in the forum have not been able to identify the cause.

Getting very frustrated that every major release of KDE, seems to break more things than making my life better.

Considering to switch to Gnome now.

Ah, the magic cure!

1 Like

and reboot

I did reboot multiple times before. There is something else.

fooyin is now working again, but veloren shows no sign of life after starting. I haven’t tried other flatpaks again because they don’t matter to me.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.