Flashing iso to usb

Hi im totaly new on manjaro. I’ve used just mint before so please forgive my mistakes…

I cant write manjaro kde iso onto my usb. It just writes a file named “efi” and thats it. When i get to the boot menu it shows up 2 boot device as usb. The both of them are gives the same error that says “Secure boot violation, invalid signature detected. Check secure boot policy in setup”. Im on Windows 10 and i tried to write with “Rufus” and “Balena Etcher” the both of them are not working correctly. I tried the minimal version of Manjaro kde but it still isn’t working could anyone help me ?

Follow this…

Looks like “Secure boot” is preventing this from the BIOS. I would recommend disabling fast boot as well. I am sure that someone more experienced will remember more of BIOS parameters to check.

You could also try to use Ventoy, I have had very good experience with that.


Manjaro doesn’t support Secure Boot out of the box, disable it in BIOS.

They usually do - but users are often confused by the seeming lack of files - except for a small 4MB EFI partition.

Manjaro ISO is build using ext4 - which is unreadable by Windows (unless you are using WSL - which very few installing Manjaro does).

1 Like

That’s worked sorry for that im totally a newbie :slight_smile:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.