Flare-RPG mods issue

EDIT: If anyone knows where Flare-RPG stores the save files (neither version – flatpak and snap – create a saves folder or userdata folder), I’d appreciate it greatly if you could help me. Thanks. Planning to get rid of Snap, but would appreciate the save file first.

I’m playing Flare-RPG on Manjaro KDE and would like to add the Demonic-UI mod as I think it is an easier to read HUD/UI versus the standard one. However, trying to add it via terminal as per the instructions does not work (read only file system issue), and trying to just copy/paste the folder in through Dolphin doesn’t work either. I also tried using su with the root password to elevate permissions in terminal, and still would not work.

Anyone know what my issue is? Added the game via snap.

Why dont you share the actual commands and/or output ?

Oh. That would be it then … thats kinda how SNAP works… see this thread:

Thanks for the link. Maybe I should change the settings so that snap results no longer show up. What a pain. I’m probably about half way through the game, so starting over isn’t exactly an option.

There is a sort of brute hammer workaround there too that might work.
(of course it technically is breaking how SNAP should work and all that …)

For something as minor as changing the UI in a game, I’ll just deal with it and keep snap usage to very minimal in the future.

Sure thing … when you are done, if thats how you feel, you might think about ditching it entirely if that is possible. SNAPs have huge libraries and the SNAP service can baloon to take extra resources and system startup time, even if you never launch any of the programs.

( see example: systemd-analyze blame )

I used snap for a couple of things aside from Flare-RPG (sayonara and spotify, I believe). What would you suggest for alternatives? Sayonara could be a different program from a different source, but I pay for Spotify, so I’d like the ability to use the app.

Once I sort that out, how should I go about disabling the Snap service?

Both have versions in the AUR. Thats probably what I would use.
But its all up to you … if you rely on it (but dont over-do it) then it can be a reasonable tradeoff.

The AUR for Spotify seems to (I think) be an older version? (I’m not sure; comparing it to the Snap version numbers, anyways.) There is also Flatpak. Would that version be okay or does it have similar issues with bloating and taking up more system resources as well?

I have zero clue where the save files in Flare-RPG are, nor am I confident I could just take copy and paste it elsewhere, otherwise I would.

Thanks for the help.

I dont really use any of those things…
But the way I understand it flatpak is more desirable as it doesnt weigh down (or rely on) systemd … is more secure with its sandboxing, as well as its repos, etc.
Then again … thats just opinion I suppose.

As to spotify … well … technically ‘Stable’ version hasnt seen many updates in a while.
Thats what spotify in the AUR is tracking. The ones in SNAP and Flatpak (yes its there too) track ‘Current’. I am not entirely sure whether spotify-dev in the AUR is comparable.

Replaced Sayonara and Spotify. Need to see if I can copy and paste the save file in Flare-RPG elsewhere so I can reinstall that.

How would I go about ditching Snap after I’ve figured that out?

Just uninstall snapd (and anything associated) … that should disable the service as well but you can do it yourself too (depending on if you have apparmor)

systemctl disable snapd.service --now


systemctl disable snapd.apparmor.service --now

Trying to remove Spotify snap via Pamac, and it is taking quite awhile. Seems to get stuck at “Save data of snap “spotify” in automatic snapshot set #4.” Once I get that dealt with and finding out how to extract the save file from Flare-RPG, I’m going to get rid of snapd.

Edited to add this to the first post, but posting it as it’s own reply as well: If anyone knows where Flare-RPG stores the save files (flatpak and snap versions do not create “saves” or “userdata” folders like the developer claims it does), I’d appreciate it greatly if you could help me. Thanks. Planning to get rid of Snap, but would appreciate the save file first.

Yeah sorry no idea there. It doesnt seem to have cool features like pacman -Ql packagename to list all the files and paths associated with a given package.

As to slow remove … not sure about that either. I thought snap remove packagename worked usually.

The snap package Spotify seems to be gone. Now if I could just find where the dang save files are for this game, which apparently is no where to be found. Even someone who I think manages the GitHub package can’t seem to figure it out. None of the locations seem to even exist on my laptop.

Maybe the issue is how/where SNAPS work - it mounts little filesystems (as read-only, as per the ‘original issue’) for each of the programs (this is what is supposed to make SNAPS ‘self-contained’ and ‘work everywhere’ … but also why they are fat).
So you might need to make sure SNAP is running and the application is mounted(/started maybe?) in order to access the files at all.
(again this is off the top of my head … maybe when I will make some time to look deeper…)

Well they gave me a path where the Flatpak saves should be and… that doesn’t exist either. Really frustrating.

Well if the developer of the SNAP cant tell you … I cant either.
(and its not like it is a manjaro problem … by the nature of SNAPS … this is how it is everywhere)

…which only goes to further ‘salt’ how I feel about SNAPs …

I guess the same goes for flatpak. Though I thought it was much more approachable.

(ex: /var/lib/flatpak/exports/share/applications or similar?)

Finally freaking figured it out. Holy moly, what a pain. Now to uninstall snapd.