Flameshot icon invisible using XFCE

Hi,
my XFCE Manjaro has a problem with Flameshot. The icon in the systray is invisible (see screenshot).

Selection_001

I search on the web and I try various proposed solutions without resolving this problem. Can you please help me?

Post Script: notice that the icon works perfectly and compare the suggestion under the “hidden” icon.

Best Regards

Have you tried with a different icon set and or a different theme?

1 Like

Yes. Perhaps in the past, I resolved this issue using this solution. I also tried to change the KDE icon set (I use XFCE). When logging into KDE, the icon is white.

I try do delete all KDE configuration (by eliminating files and directory)

rm -Rf ~/.kde
rm -Rf ~/.config/kde

Where did XFCE pick up the icon to show in the systray?

In XFCE, those icons are/were usually a part of a specific app-indicator type package. It has been a while since using XFCE, so the exact name escapes me. I recall the package typically contained popular application icons if needed for the tray, but not all.

In KDE (Plasma 6), these icons have been largely delegated to the individual themes, as I understand it. Likewise, these themes may (or may not) have every expected icon.

As previously mentioned, a different theme might resolve it. Perhaps something better known, that’s regularly updated; a global theme for XFCE might be worth looking at, for example.

That’s all I have. Cheers.

Dear @soundofthunder,
Thank you for your answer. I have a second laptop with the same problem. It uses a different theme.

I think it is a Manjaro bug; other EndevourOS computers do not have this problem.

I hope to resolve it, otherwise I have to spend some time migrating my computers.

Best MR

If the system tray icon, or rather, the application itself, has it’s own .desktop file for the tray, maybe you can find and edit that, and enter a path to a known existing icon.

Good luck.

Thank you for your suggestion.
I tried a lot of themes… Papirus-Dark-Maia does not have this problem. I would like to understand the mechanism to get a standard icon when there is no specific one.

@soundofthunder, thank you very much for your suggestions, which helped me explore the problem.

Best MR

There’s a flameshot dir in your .config with a flameshot.ini
Set you’re startuplaunch to true

startupLaunch=true

as for theming i use matcha dark azul and i see flameshot in lots of virtual machines.

I have

[General]
contrastOpacity=188
saveAsFileExtension=png
savePath=/media/data/users/home/marco/Downloads
startupLaunch=true

and does not work.

neofetch simplified output:

OS: Manjaro Linux x86_64 
Host: HP ENVY m6 Notebook PC 
Kernel: 6.6.32-1-MANJARO 
Uptime: 11 mins 
Packages: 3027 (pacman) 
Shell: bash 5.2.26 
Resolution: 1366x768 
DE: KDE 
WM: Xfwm4 
WM Theme: Greybird-dark 
Theme: [KDE], Breeze [GTK2/3] 
Icons: [KDE], breeze [GTK2/3] 
Terminal: xfce4-terminal 
Terminal Font: Monospace 9 

so your DE is KDE and not xfce and what is /media etc.
that is standard manjaro ?
How about making a fresh Wynsdey xfce install and see if the defaults have the same problem ?

Hi,
this is a standard Manjaro (an old installation). I used only xfce.

The capital is out of place in your commands. I believe the example you based those on was a simple typo. This is all that’s needed (example):

rm -rf ~/.xxxx

Cheers.

OPTIONS
       Remove (unlink) the FILE(s).
...
...
 -r, -R, --recursive
              remove directories and their contents recursively

going by man rm (but on Mint, not Manjaro)
it should not matter :man_shrugging:

And it shouldn’t matter; a capital has no emphasis whatsoever, and isn’t needed. I’m often amused by (mainly in the World of Windows) by people issuing commands such as ChkDsk C: /f - usage derived directly from documentation, yet not intended to be verbatim. :man_shrugging:

I am on xfce, I just installed Flameshot and the icon appears without any problem, both in Whisper and in taskbar or systray. Using Adwaita-dark.