Fix annoying fsck messages at boot and shutdown

How to remove these annoying messages that appear at boot and shutdown

Operating System: Manjaro Linux
KDE Plasma Version: 5.21.4
KDE Frameworks Version: 5.81.0
Qt Version: 5.15.2
Kernel Version: 5.4.112-1-MANJARO
OS Type: 64-bit
Graphics Platform: X11

1 Like

Hi @medmedin ,
Manjaro, as any other Linux distro, perfoms a file system check on your partitions on the hard drive before they are mounted. This utility is helpful in order to clean and repair orphaned nodes, because of unusual shutdown or hard drive failures.

Hope this help, regards

Thanks for you reply, it’s good to have this check, how can I suppress it and avoid its appearance ? because in the grub it’s already configured as quiet boot.

Yep I noticed on a recent installation I made on a laptop, I have these messages regarding /dev/bla: clean, xxx/xxx files, xxx/xxx blocks, despite grub having quiet and splash added to boot parameters. kinda annoying I don’t think it is normal to see them in this case. I never seens these messages in ALL the other installation I made, they were ALL SSD installation, and not HDD like this laptop having these messages.

At the end of ‘grub cmdline linux default’ add ‘console=tty3’ and update grub

1 Like

Wouldn’t that block legit boot error messages though?

Yes…that is true
Output will be sent to tty3

I found loglevel grub parameter, I’ll try but it seems loglevel=3 may do the trick, I’ll try to test when I’ll get a chance on the laptop (not mine).

1 Like

Thanks that worked perfectly :slight_smile: :+1:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.