First preview of Manjaro Ellada released

preview
release

#21

Same, going to direct sourceforge page gives same warning.
It’s also not the only time I’ve encountered this at sourceforge.
I’ve downloaded and installed Manjaro versions before and same warning had occurred.
And I thought it (the sourceforge security issue) had been fixed since [1]
It obviously wasn’t.

Oh, BTW, downloaded kde pre 1 (despite warning, as before), installed and works well (as before).

[1] - some links on sourceforge security issues
o wikipedia page.

On July 1, 2013, SourceForge began a beta test of a program they call DevShare, which offers projects a way to monetize their downloads by having an optional download that includes prompts for the user to download additional software that is not part of the project. Due to community reactions to the partnership program, it was revisited a few months later, but the program was ultimately opened up to all SourceForge projects on February 7, 2014.[9][10] The program was cancelled by new owners BIZX in February 2016.[11]

o Another link

It appears as if the new owners at SourceForge are serious about fixing the mistakes made by the site’s previous owners. FOSS Force has learned that as of today, the software repository used by many free and open source projects is scanning all hosted projects for malware. Projects that don’t make the grade will be noticeably flagged with a red warning badge located beside the project’s download button.

‘bold’ lettering - my emphasis.


#22

is this preview can be synced on an already installed manjaro 16.06?


#23

Just do regular updates. No need for iso unless to make fresh install.

EDIT. This preview is build from testing branch, so if you want to get the same on your system, you can just switch to testing in /etc/pacman-mirrors.conf


#24

Are you mean this is preview is not for stable brunch ?:confused:


#25

Not Yet(it is not even on the testing branch) wait for next update


#26

think you @master_andreas
so we still waiting for stable update :pensive:


#27

Indeed. Stable branch hasn’t had an update in a month, so it kinda stops feeling like a rolling distro. I guess there must be some serious issues.

Would it be possible to make a difference between system packages and user packages so that stable branch would get updates for user packages (like darktable or doublecmd in this case) sooner?


#28

The issues are mostly cosmetic, but user reaction would be serious. These cosmetic issues will not occur if you install this new Ellada -dev version.


#29

[quote=“elman, post:27, topic:6254”]
Indeed. Stable branch hasn’t had an update in a month, so it kinda stops feeling like a rolling distro. I guess there must be some serious issues. soon
[/quote]A update should be coming[quote=“elman, post:27, topic:6254”]
Would it be possible to make a difference between system packages and user packages so that stable branch would get updates for user packages (like darktable or doublecmd in this case) sooner?
[/quote]You could change TEMP on the Unstable branch then download the PROGRAMS that you want then go bast to stable and block those PACKAGES from being update

Or could just USE the Arch User Repository

Or you could Switch in the Testing branch if you exclude some cosmetic issues and very rare application misbehaving it is fine

Hope that Usefull


#30

SourceForge lost its previous reputation some time ago (source) so it’s better not to browse their pages or download files from them (without checking signatures/checksums at least). My adblock blocks whole sourceforge domain by default.


#31

Mostly, but not all :slight_smile: see nvidia black screen issue.


#32

Hence my question: how do we download Manjaro without going to sourceforge? Or at least without this ‘warning’ ?
The links I provided promised an improvement. And I think sourceforge deserves a second chance if it truly make amends, considering its past contributions. Cheers.


#33

I am running Ellada in VM VirtualBox, with Deepin DE installed and selected. There are no options under Control Center / Mouse and Touchpad. I noticed the same thing when running testing branch under VM, so I don’t know whether this is a VM problem or an upgrade problem.

I like to turn off “Tap to click” when I type, otherwise barely brushing the touchpad can send my cursor to random places that no cursor should go! Running Ellada under VM, the option is to turn off “Tap to click” is no longer available.


#34

[quote=“master_andreas, post:29, topic:6254, full:true”]
You could change TEMP on the Unstable branch then download the PROGRAMS that you want then go bast to stable and block those PACKAGES from being update[/quote]
This sounds very helpful. Going to try it now. Thanks for the tip. :wink:


#35

Sourceforge has come under ownership I believe I read. The current owner is very displeased with the adware bundled downloads and seeks to remove every bit of it.

There’s a blog post somewhere on their website.

@philm, thank you for the update!


#36

I downloaded the net install preview and after a couple of tries I was able to get it working with the enlightenment de. It was my fault with getting it installed because I didn’t read anything and just started installing. Once I went back and did some reading it turned out well. I do have one issue though; it seems like pamac will not work. I can install via pacman and i installed octopi but pamac will not work. I can’t change preferences and when I try to use it to install software i get authentication failed. Not sure though.


#37

On a fresh Boot in a Virtual Box


#38

I think power manager icon dont fit with maia icons


#39

This is still a issue Resolving timed out


#40

USB auto-mounting doesn’t work
Plasma5