Firewall keeps de-activating

In spite of repeatedly enabling my firewall using “sudo ufw enable” I keep finding its disabled when the computer is turned on and booted up.

Any suggestions?

Hi,

Try sudo systemctl enable --now ufw

2 Likes

Thanks I’ll try that and see how it tracks. What does this command do?

It starts and enables the ufw service, it should persist after restarting.

1 Like

Many thanks for the explanation.

With the disclaimer that I have no experience with ufw, one thing to keep in mind is that in GNU/Linux, a firewall application does not need to keep on running, as in Microsoft Windows.

In GNU/linux, firewalling is implemented at the kernel level by way of a set of rules. Usually, a firewall application does nothing other than set those rules at boot time ─ or whenever the firewall is started ─ but once the firewalling rules are set up, there is nothing more for the application to do, and so it gets out of the way, because it is then up to the kernel itself to keep on filtering, rerouting and blocking network traffic, based upon those rules.

4 Likes

That has remedied the issue. Thanks.

the manjaro wiki says to do the following"

pamac install ufw
sudo systemctl enable ufw.service
sudo ufw enable

and you also need to add

sudo systemctl start ufw.service

idk why it’s not mentioned there.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.