Firefox62:Unable to delete amazon & ebay search-engine [Solved]

Hi.
Since Firefox 62 after erasing Amazon & Ebay from Search Engine menu, it comme back and are re-activated on restart Firefox.
No way to disable this behaviour.

1 Like

Not for me… no such problem here:

20180912_002

I deleted those crappy ones weeks ago, & they’ve not bounced back since.

Maybe you should try a fresh FF profile?

Hello.
Thanks for your answer. I did try with a brand new profile before posting and those search engine are back on restart FF also in private session.
I’m not alone with this issue reported on the french forum.
It seem it’s a bug maybe with some java scripts…
https://bugzilla.mozilla.org/show_bug.cgi?id=1489820

I found something: It’s comes from de french language pack or maybe other langage pack. After disabling it, search engines don’t be back.

1 Like

Same problem with firefox-developer-edition and firefox-developer-edition-i18n-fr which is based on FF-63. The latter redefines the default search engines each time Firefox reopens.
I’m not sure they really want to fix this bug.
Do you know where the default list of search engines is in the FF source code or somewhere where we can act locally ?

Again, not for me.

Don’t know if my arrangement causes my FF-Dev to behave ok, when for you & @Dickens1412 & @poppycock it does not, but fyi:

20180916_001

…and…

Same Problem here. I have delete “Amazon” “Ecosia” “Wikipedia” and “Leo Eng-Deu”. The next time I started FF, they were back. I use the german language pack.

Using the en-gb pack, and Amazon returns for me after deletion (Ebay stays deleted). Not really a problem for me as I use DuckDuckGo and it’s !bangs, if I wanted to ever search Amazon I would use !a.

Thank you to all of you. It confirms two things

  1. Firefox generates by default a list of search engines and it is difficult to know where this list is located. If you use the En-us version without language pack, you can remove some unwanted engines until they are reset.
  2. The language packs linked to the version >=62 generate a list of search engines specific to geolocation and reset the default behavior each time the browser is launched, which is contrary to our principles.
    So either it’s a simple bug in a script.js or it’s intentional.
    I hope I’m wrong about the second option…

Translated with www.DeepL.com/Translator

This bug was patched on Ubuntu: https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/1791789

Any idea if the patch might come to Arch/Manjaro?

Btw, it’s also the case for the firefox-kde-opensuse package.

1 Like

Hello,

I confirm I have this too (french language pack) but can’t find a way to remove this even temporarily (until the next update ?). It’s really frustrating to send a search to amazon instead of our favorite engine.
Does anyone succeeded in fix it manually ?

Hi.
I did post on Arch too. Th answer of the packager said:

The list of plugins is embedded in a huge compiled binary blob, no idea what you want us to do about that.

But today, I got a Good News :blush:
This unpleasant behavior seems to no longer appear with the firefox-62.0.2-1 and firefox-i18n-fr-62.0.2-1 versions.
Done on Arch, and two machines under Manjaro by pointing directly to the Arch package locally because at the time of writing this message, these packages are not yet available in Manjaro’s repositories.
This means that unwanted search engines can be removed from the default list without returning to the next time the red panda is opened.
To watch out the future versions. :sunglasses:

Translated with www.DeepL.com/Translator
Edit: I’m waiting for confirmations before marking as resolved

1 Like

I can confirm that as well. With the current FF version (62.0.2) the search engines can be deleted. They don’t appear when restarting. I use the german-language-pack.

Yep! firefox-62.0.2-1 and firefox-i18n-XX-62.0.2-1 are now on repositories and those crapy search-engines stay out.
I think it’s solved

1 Like

Mmh, I guess I’ll have to wait mirrors to get updated, because I’m still at firefox-62.0.2-0 :confused:

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark