Firefox window size mismatch on startup


I am having a weird issue with Firefox and Firefox Developer Edition.

When Firefox is started, somehow the actual window that is drawn on the is smaller than what Gnome Shell detects.

This will cause the window to not respond to clicks the way you would expect it, because even though you only see a small window, somehow you still have to click as if the window would be as big as Gnome Shell thinks it is.

So just an example:

If I want to click on the minimize button of the window, I actually have to click on the empty space where the minimize button would have been.

I have screenshots but for some reason I get an error if I’m trying to submit my post with them included.

I get this issue consistently and then I have to kill Firefox a few times until it starts up with the correct window size.

This is a fresh install of Manjaro via the Architect. I am using the default Gnome installation and the issue was present before I installed anything else. I just needed to resize the Firefox window and then close it.

$ inxi -F
System:    Host: Workstation Kernel: 5.10.15-1-MANJARO x86_64 bits: 64 Desktop: GNOME 3.38.3 Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: ROG CROSSHAIR VIII HERO (WI-FI) v: Rev X.0x serial: <superuser required> 
           UEFI: American Megatrends v: 2206 date: 08/13/2020 
CPU:       Info: 12-Core model: AMD Ryzen 9 3900X bits: 64 type: MT MCP L2 cache: 6 MiB 
           Speed: 2108 MHz min/max: 2200/3800 MHz Core speeds (MHz): 1: 2108 2: 3381 3: 2196 4: 2196 5: 2065 6: 3280 7: 1928 
           8: 4068 9: 3903 10: 2106 11: 3432 12: 2090 13: 2045 14: 2055 15: 2196 16: 2196 17: 2196 18: 4324 19: 4252 20: 2056 
           21: 3427 22: 2107 23: 2046 24: 2196 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT] driver: amdgpu 
           v: kernel 
           Display: x11 server: 1.20.10 driver: loaded: amdgpu,ati unloaded: modesetting,radeon 
           resolution: <missing: xdpyinfo> 
           OpenGL: renderer: AMD Radeon RX 5700 XT (NAVI10 DRM 3.40.0 5.10.15-1-MANJARO LLVM 11.0.1) v: 4.6 Mesa 20.3.4 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] Navi 10 HDMI Audio driver: snd_hda_intel 
           Device-2: Advanced Micro Devices [AMD] Starship/Matisse HD Audio driver: snd_hda_intel 
           Device-3: Trust USB Camera type: USB driver: snd-usb-audio,uvcvideo 
           Device-4: Sennheiser Sennheiser GSA 70 type: USB driver: hid-generic,snd-usb-audio,usbhid 
           Device-5: Focusrite-Novation Focusrite Scarlett 2i2 2nd Gen type: USB driver: snd-usb-audio 
           Sound Server: ALSA v: k5.10.15-1-MANJARO 
Network:   Device-1: Realtek RTL8125 2.5GbE driver: r8169 
           IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: 04:d9:f5:cb:a7:19 
           Device-2: Intel I211 Gigabit Network driver: igb 
           IF: enp6s0 state: down mac: 04:d9:f5:cb:a7:18 
           Device-3: Intel Wi-Fi 6 AX200 driver: iwlwifi 
           IF: wlp7s0 state: down mac: 6e:8d:01:33:96:f2 
           IF-ID-1: docker0 state: down mac: 02:42:14:7a:38:8a 
Bluetooth: Device-1: Intel AX200 Bluetooth type: USB driver: btusb 
           Message: Required tool hciconfig not installed. Check --recommends 
Drives:    Local Storage: total: 1.82 TiB used: 42.47 GiB (2.3%) 
           ID-1: /dev/nvme0n1 vendor: Corsair model: Force MP600 size: 465.76 GiB 
           ID-2: /dev/nvme1n1 vendor: Samsung model: SSD 970 EVO Plus 500GB size: 465.76 GiB 
           ID-3: /dev/sda vendor: Samsung model: SSD 860 EVO 1TB size: 931.51 GiB 
Partition: ID-1: / size: 464.76 GiB used: 42.44 GiB (9.1%) fs: btrfs dev: /dev/dm-0 
           ID-2: /boot/efi size: 1022 MiB used: 26.1 MiB (2.5%) fs: vfat dev: /dev/nvme1n1p1 
           ID-3: /home size: 464.76 GiB used: 42.44 GiB (9.1%) fs: btrfs dev: /dev/dm-0 
Swap:      Alert: No Swap data was found. 
Sensors:   System Temperatures: cpu: 51.6 C mobo: N/A gpu: amdgpu temp: 59.0 C 
           Fan Speeds (RPM): N/A gpu: amdgpu fan: 0 
Info:      Processes: 585 Uptime: 2h 55m Memory: 125.79 GiB used: 8.97 GiB (7.1%) Shell: Zsh inxi: 3.3.01 

Anyone knows what could be going on?

1 Like

I experience this as well, on KDE. The window starts out as technically maximised but the contents don’t fit. Intel, modesetting driver.

The way I work around it is to double-click the top of the screen where the titlebar would have been if it were maximised, and un-maximize it that way. Alternatively right-click the entry in the task manager and untick Maximise there. If you maximise it again afterwards it behaves as it should.

Same problem here. I use a similar workaround to @zorael , while having the focus on the windows, I press Super+Down and then Super+Up on gnome shell to maximize and minimize the window. Still, it is an odd behavior, even more now that I know that it also happens in KDE. Does anyone know if this happens in other Linux distros? It’s a problem hard to describe, and I’m not sure how to search it on bugzilla. I will try to take a screenshot the next time it happens.

I found it. Apparently, it was first reported on an Arch distro years ago. It mentions XWayland, but I experience the same in pure X. Check the issue 1489463 in bugzilla.

=EDIT 2=
Example from today. This happened after trying to restore a window split to the left. The screenshot doesn’t represent it, but the white space looked like a glitchy clone of the actual window below.

IMAGE: i[DOT]imgur[DOT]com[SLASH]5xUpWyO.png

1 Like

As you see:

I have met such thing on Arch Plasma this year sometimes. At July I turn to Manjaro Plasma. It still happened sometimes. A temporary way is minimize it then maximize it.

firefox 92.0-1

 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     kearney@xx
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     OS: Manjaro 21.1.3 Pahvo
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     Kernel: x86_64 Linux 5.13.15-1-MANJARO
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     Uptime: 39m
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ            β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     Packages: 1369
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     Shell: bash
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     Resolution: 2560x1600
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     DE: KDE 5.85.0 / Plasma 5.22.5
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     WM: KWin
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     GTK Theme: Breeze [GTK3]
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     Icon Theme: breath2
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     Disk: 77G / 116G (70%)
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     CPU: AMD Ryzen 5 4600U with Radeon Graphics @ 12x 2.1GHz
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     GPU: AMD RENOIR (DRM 3.41.0, 5.13.15-1-MANJARO, LLVM 12.0.1)
                                  RAM: 3291467776-

Are you properly closing Firefox when you shutdown the computer?

To figure out that. I just closed it by clicking the close button on the top-right cornor. And then reboot. Open firefox then it happen again…

Then you close it properly. I know when it restores session when you shutdown the computer without closing Firefox properly this can happen. Do you all have the session restoration enabled?

I would like to weigh in with some of my observations here. I had this same issue every time I started a new session of Firefox, for about 3-4 stable releases. Just as it mysteriously appeared, so did it vanish, and I thought the Linux Gods had spared me.

Unfortunately I learnt the hard way that nothing good (or bad for that matter) is ever lasting. I have been facing another issue with my Manjaro build, for some time now, which forces me to use REIUSB to save my Linux session and restart my PC. And as you might have guessed, the issue came back, but this time was limited to restoring my previous session.

Every time I restored the previous session, the window was resized awkwardly with gnome shell hovering above. I had almost accepted my fate, when just today, I was doing some digging and I went into profile directory of Firefox (go to help>>More Troubleshooting Info>>Open Directory) and poked around until I came across an aptly named file called β€œsessionCheckpoints.json”.

I simply edited it with a Text Editor and changed the line β€œfinal-ui-startup” from true to false. Restarted my session, and it broke it further, but after I managed to close both the text editor and Firefox and restored the session again, it all seems to be finally fixed!!

For anyone else that has been facing this peculiar issue, do give it a shot and let me know if it worked for you. Stay Strong!

I would try it, but I would like to know what does that final-ui-startup Firefox option means, first. It’s 3 AM here, so maybe my head isn’t as sharp as it should, but I can’t find any documentation of that.

1 Like

I totally get that. I’d have reservations too if I didn’t know what else it would affect, but I just checked, even though I changed it from β€œtrue” to β€œfalse”. Right now, it’s back to true again, which leads me to believe that it affects the current session of Firefox.

I just shot my shot, and apparently it worked. I hope it does for you as well.