Firefox will not open local HTML files

I’m using Manjaro Gnome. After the stable updates of Aug 28, Firefox (version 79.0-1 from the Manjaro repository) will no longer open any local HTML files in my home folder. Invariably, after 3 minutes the tab crash reporter screen appears. How can this be fixed?

As a test, on another computer running Manjaro Gnome and before doing these updates, Firefox (same version) has no problem opening local HTML files. Since Firefox is not being updated in this set of updates, it seems the problem is created elsewhere in the updates?

Firefox is opening HTML files without problems using XFCE. I guess you need to look at the logs but I’m not sure where to start with that. This may be of some help: :slightly_smiling_face:

And perhaps start here?:

I don’t see anything in the logs.

Just to be clear, there is no problem with this Firefox opening websites on the internet (like this forum). It’s only local files.

And I should add that it’s not just html files but other types Firefox can handle, like image files or text files that are in my home folder. Those won’t open either.

Can you edit MIME type settings in Gnome? Maybe html has been set to be opened by another application, although really Firefox should also be able to open it. It’s mystifying!

html files is no problem - what you may get issues with is html files which has javascript content - long time ago this was an issue - I don’t know if it is anymore.

Have you tried a simple test?

just create a simple text file named test.html with content yay - save it and open it in your browser.

I am fairly certain it is not a firefox issue.



Yes, I did make a simple HTML to test, but the problem was still present.

I decided to do the upgrade on the other Manjaro Gnome I mentioned whose Firefox was working normally with local files at the time of upgrading. After the upgrade, I found Firefox still worked with local files.

So the problem is only on one computer.

Since I needed a solution, I installed Firefox as a Flatpak on the ‘bad’ machine, and this Firefox is working correctly.

Thanks to all for your suggestions.

Did you try with a fresh profile?

I encountered a similar issue and found (Sorry for the link formatting; I am not allowed to post links here.) Updating to from kernel 4.19 to 5.4 fixed the issue for me.

I would still like an alternative fix that does not require Flatpak though, as kernel 5 introduced some issues on my hardware.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.