Firefox version 100.0.1-1 not launching

I just updated to the latest Firefox version 100.0.1-1 using Pamac and it no longer launches. When launching it from the console, this is the error:

~ > firefox
/usr/lib/firefox/firefox: /usr/lib/ version `GLIBCXX_3.4.30’ not found (required by /usr/lib/firefox/firefox)

Is it broken for everyone else or it’s just me? If it’s everyone I’ll just wait for the next update, otherwise if anyone has a recommendation on how to fix it that would be great.


Nope, just you. Looks like an update from a partily updated mirror. Switch/update the mirrors and upgrade again.

I was wrong :point_down:

Just pulled firefox 100.0.1-1 and got the same GLIBCXX_3.4.30 error.

(Current Firefox Developer Edition 101.0b4-1 was compiled with the right dependencies)

New GLIBC coming in a bit?

Not just you. Just did the update, and to cover my steps did a reinstall as well. No dice. Timeshifted back to yesterday till someone fixes the flat tire

Same issue here. Not just you. For now I just downgraded using

# pacman -U /var/cache/pacman/pkg/firefox-100.0-1-x86_64.pkg.tar.zst /var/cache/pacman/pkg/firefox-i18n-en-us-100.0-1-any.pkg.tar.zst

Note: both firefox and firefox-i18n need to be downgraded. Don’t know about partial mirror update but I have excluded both from updates from the time being.


I believe i have the same problem after a firefox upgrade to 100.0.1-1? I have had to downgrade back to 100.0-1

❰greg❙~/.cache/yay❱✔≻ firefox
/usr/lib/firefox/firefox: /usr/lib/ version `GLIBCXX_3.4.30' not found (required by /usr/lib/firefox/firefox)

Please help :frowning:

I just wanted to say, me too. Just upgraded FireFox 100.0-1 → 100.0.1-1 and now I’m getting the following error:

$ firefox
/usr/lib/firefox/firefox: /usr/lib/ version `GLIBCXX_3.4.30' not found (required by /usr/lib/firefox/firefox)

I guess I’m gonna pile on this here and say it has happened to me as well.

Same problem here…

$ firefox                                     
/usr/lib/firefox/firefox: /usr/lib/ version `GLIBCXX_3.4.30' not found (required by /usr/lib/firefox/firefox)

If, like me, you don’t keep any pacman cache (and, so, can’t use @srahman5317 trick), you can download a downgrade to the version you want with this command :

sudo DOWNGRADE_FROM_ALA=1 downgrade firefox

cf doc here : wiki.manjaro[dot]org/index.php/Downgrading_packages


This I what I did too, though I only had firefox to downgrade. Apparently, the break is caused by the GCC version required by firefox being a version ahead of what’s available for stable.

Thanks, but it didn’t work for me.
How did it even get onto the stable channel when it has missing dependencies?
EDIT: I restored with Timeshift.

warning: downgrading package firefox (100.0.1-1 => 100.0-0.1)
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing firefox (100.0-0.1) breaks dependency 'firefox>=100.0.1' required by firefox-i18n-en-gb
:: installing firefox (100.0-0.1) breaks dependency 'firefox>=100.0.1' required by firefox-i18n-en-us
:: installing firefox (100.0-0.1) breaks dependency 'firefox>=100.0.1' required by firefox-i18n-zh-cn

For some reason, your “downgrade” is showing (100.0.1-1 => 100.0-0.1) , but 100.0-0.1 is incorrect!

sudo pacman -U /var/cache/pacman/pkg/firefox-100.0-1-x86_64.pkg.tar.zst

I have the same issue here. I’ll use Opera in the meantime and wait for a fix.

Downgrade did not work for me - what did I wrong ?

$ sudo pacman -U /var/cache/pacman/pkg/firefox-100.0-1-x86_64.pkg.tar.zst
loading packages…
warning: downgrading package firefox (100.0.1-1 => 100.0-1)
resolving dependencies…
looking for conflicting packages…
error: failed to prepare transaction (could not satisfy dependencies)
:: installing firefox (100.0-1) breaks dependency ‘firefox>=100.0.1’ required by firefox-i18n-de
:: installing firefox (100.0-1) breaks dependency ‘firefox>=100.0.1’ required by firefox-i18n-en-us

Same here, I just updated Firefox today, only to get an identical result.
I followed the downgrade steps and am now able to run the slightly older version of firefox. I’d like to know when the required fix will happen, and am more than a little cheesed off that I had to downgrade in the first place.

you need to downgrade both firefox and firefox-i18n in this case. I had to do so as well but apparently some folks haven’t had to.

Firefox Developer Edition installs and works. It’s a fix for now. Firefox sync, and you’re back up and running.

You are going to need to downgrade all the mentioned packages first, before you downgrade FF as far as i can tell, i did not have any of the language packs installed. You can prob just remove them and then re-install.

I have been using v100 since it’s release - no issues

$ inxi -S
  Host: tiger Kernel: 5.17.7-1-MANJARO arch: x86_64 bits: 64
    Desktop: KDE Plasma v: 5.24.5 Distro: Manjaro Linux

While there is several mention for downgrade - I’d suggest the following course of action

Switch your Plasma theming to the default Breeze and run

sudo pacman-mirrorss -aS unstable && sudo pacman -Syyu

Broken for me also.

I did a sudo pacman -R firefox-i18n-en-ca firefox-i18n-en-us firefox

followed by sudo pacman -U firefox-99.0.1-1-x86_64.pkg.tar.zst in the appropriate folder.