Firefox takes a very long time to start

Hi everyone,
I fresh installed manjaro gnome and firefox takes a very long time to boot up. I can’t figure out why. My pc have an intel core i5, 16 gb ram and an m2 ssd drive.

I tried this in a terminal:
/usr/lib/ unable to generate file identifier

Have you tried with a fresh profile?

Please read this, it may be of some help:

Thanks jrichard but I tried those solutions with no luck.

This morning I turned on my pc and I start firefox a few seconds after the desktop appears and it opened in one second. Then I opened other few apps, do this and do that, I closed/started firefox again but this time it takes approximately 1 minute.

Try disabling hardware acceleration.

Which version? The regular repository? Snap? Flatpak? If Snap or Flatpak, those versions have been known to be slow on initial start. I have it from Manjaro’s repository and starts up fine. Hope this helps you.

firefox --profile "$(mktemp -d)" --no-remote --new-instance
Fresh and leaving no trace :wink:
Add an alias ‘freshfirefox’ for this one for troubleshooting.

I tried with no luck

Last version from official repos, no snap or flatpak.

Ben, with your solution boot time was 30 seconds but without all my customization, bookamarks, etc.

Anyway, thanks to all for your help

One of the troubleshooting suggestions from the other OS is out of date
Firefox Safe mode has been renamed to Troubleshooting Mode

Firefox has a Troubleshooting Information page – about:support – showing detailed information about Firefox configuration
This page has 3 tools available:

There are also links to additional troubleshooting pages

I just tried both with no luck

The only other thing I can think of, beyond what has already been suggested, is to start firefox from a terminal command and check for any error messages during startup

I launched firefox from a terminal and the only message is:

###!!! [Child][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost

I reinstalled manjaro and the problem with firefox is gone. I don’t know how but something gone wrong with the previous installation. Anyway, thanks to all for your help.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.