Firefox starts very slow

I have a problem with firefox.

The program starts very slow.

I have tried to reinstall firefox, but this does not solve the problem.

Are you encountering any error while opening Firefox?
Have you checked if any other application is creating a roadblock for Firefox?

Please elaborate your problem and do check out this thread:

I I have also done: I have written the backup of .mozilla to my home folder.

Firefox start time normally 1-2 seconds.
Now: > 10 seconds.

What is “slow” here? How did you measure it? Against what do you compare it?

Is it still “slow” with a clean profile? To test, run:

mv ~/.mozilla ~/.mozilla.backup

And then start firefox again.


This will remove all customizations and saved passwords from Firefox.

The problem is solved.
I have restarted the computer.

For information:
inxi -Fza

  Kernel: 5.15.28-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/vmlinuz-5.15-x86_64
    root=UUID=efdcc96e-b0e3-46a5-8097-dfbe37313d5b rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: KDE Plasma v: 5.24.3 tk: Qt v: 5.15.3 wm: kwin_x11 vt: 1
    dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Server System: Supermicro product: X10SRA v: 0123456789
    serial: <superuser required> Chassis: type: 17 v: 0123456789
    serial: <superuser required>
  Mobo: Supermicro model: X10SRA v: 1.01 serial: <superuser required>
    UEFI: American Megatrends v: 2.1a date: 10/24/2018
  Info: model: Intel Core i7-6800K bits: 64 type: MT MCP arch: Broadwell
    family: 6 model-id: 0x4F (79) stepping: 1 microcode: 0xB000040
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
    L3: 15 MiB desc: 1x15 MiB
  Speed (MHz): avg: 1315 high: 1827 min/max: 1200/3800 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 1827 2: 1205 3: 1200
    4: 1200 5: 1365 6: 1200 7: 1400 8: 1200 9: 1200 10: 1491 11: 1299
    12: 1202 bogomips: 81624
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort mitigation: Clear CPU buffers; SMT vulnerable
  Device-1: NVIDIA GM204 [GeForce GTX 970] vendor: CardExpert driver: nvidia
    v: 510.54 alternate: nouveau,nvidia_drm pcie: gen: 3 speed: 8 GT/s
    lanes: 16 bus-ID: 03:00.0 chip-ID: 10de:13c2 class-ID: 0300
  Display: x11 server: X.Org v: compositor: kwin_x11 driver: X:
    loaded: nvidia gpu: nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2560x1440 s-dpi: 108 s-size: 602x342mm (23.70x13.46")
    s-diag: 692mm (27.26")
  Monitor-1: DP-4 res: 2560x1440 hz: 60 dpi: 109
    size: 597x336mm (23.5x13.23") diag: 685mm (26.97") modes: N/A
  OpenGL: renderer: NVIDIA GeForce GTX 970/PCIe/SSE2 v: 4.6.0 NVIDIA 510.54
    direct render: Yes
  Device-1: Intel C610/X99 series HD Audio vendor: Super Micro
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:8d20
    class-ID: 0403
  Device-2: NVIDIA GM204 High Definition Audio vendor: CardExpert
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 03:00.1 chip-ID: 10de:0fbb class-ID: 0403
  Sound Server-1: ALSA v: k5.15.28-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.48 running: yes
  Device-1: Intel I210 Gigabit Network vendor: Super Micro driver: igb
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 05:00.0
    chip-ID: 8086:1533 class-ID: 0200
  IF: eno1 state: down mac: <filter>
  Device-2: Intel I210 Gigabit Network vendor: Super Micro driver: igb
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: c000 bus-ID: 06:00.0
    chip-ID: 8086:1533 class-ID: 0200
  IF: eno2 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Local Storage: total: 1.38 TiB used: 219.94 GiB (15.6%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 980 PRO 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B
    speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter> rev: 5B2QGXA7
    temp: 23.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 850 PRO 512GB
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 4B6Q scheme: GPT
  ID-1: / raw-size: 100 GiB size: 97.87 GiB (97.87%) used: 9.42 GiB (9.6%)
    fs: ext4 dev: /dev/nvme0n1p8 maj-min: 259:8
  ID-2: /boot raw-size: 1024 MiB size: 973.4 MiB (95.06%)
    used: 113 MiB (11.6%) fs: ext4 dev: /dev/nvme0n1p6 maj-min: 259:6
  ID-3: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 288 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-4: /home raw-size: 300 GiB size: 294.23 GiB (98.08%)
    used: 11.94 GiB (4.1%) fs: ext4 dev: /dev/nvme0n1p9 maj-min: 259:9
  ID-5: /var raw-size: 32.46 GiB size: 31.66 GiB (97.51%)
    used: 8.94 GiB (28.2%) fs: ext4 dev: /dev/nvme0n1p10 maj-min: 259:10
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 32 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p7 maj-min: 259:7
  System Temperatures: cpu: 18.0 C mobo: N/A gpu: nvidia temp: 32 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 30%
  Processes: 325 Uptime: 2m wakeups: 0 Memory: 31.23 GiB
  used: 2.24 GiB (7.2%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 1267 lib: 362 flatpak: 0
  Shell: Zsh v: 5.8.1 default: Bash v: 5.1.16 running-in: konsole
  inxi: 3.3.14

I have tried to start Firefox on console: no errors displayed.
Starting Firefox ´normally`: no message displayed.

I have watched a video on Youtube and the playback was interrupted with a white bar.

Start time of Firefox normally: 1-2 seconds, then > 10 seconds.

I have no extensions installed.

Restarting the computer solved the problem.

There was ´something´ in the RAM.

If you type about:about, there are a number of about pages that might help pinpoint the culprit. For example about:performance.

When there is a problem like this, it is best to start with a clean environment and slowly add something back into the mix. By clean, I mean no tabs in FF, no extensions --(safe-mode), clear cookies/cache, perhaps a new profile (–ProfileManager), and run FF from the command line so you can see messages.

Something to consider, FF could be a casualty of something else going on in the system. So then a review of the journal, htop, network, etc, might be in order.

What I have done:

  1. Backup of .mozilla written to my home folder.
  2. Reinstallation of Firefox.
  3. top on console: nothing special.
  4. I was thinking about reinstalling Manjaro.
  5. I have two other computers running Windows 10 and Manjaro. Both running ´normal`.
  6. Then I have restarted the computer. After that Firefox was running ´normal` again.

There must be something uploaded into the RAM, which was deleted with restart.

What should I do next time, when this happens ?

:person_shrugging: :slight_smile:

Not necessarily.

I’ve never in all my years had to reinstall a package, and especially an entire distribution due to software.

Keep things simple.

Things are working now. I believe, even if you reinstall FF, cache remains. I would do the good old ctrl+shift+del and just get rid of everything, and restart FF. Uninstall addon’s that you don’t need.

Check the mozilla support forum there are a number of entries about FF startup slow. It’s seems a number of issues are antivirus (windows) and addons.

Sometimes it helps to search FF bugzilla to find out what other folks have done to address issues or debug issues.

I have a similar problem with internet radio:

link SWR3, hear to the music and wait a little.

Then Firefox does behave strange.

Then I have to restore the folder .mozilla from backup.

I have a firewall with IPS (self build small computer).

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.