Firefox + Spotify both break often after updates

update
#1

I’ve been encountering this issue both on my desktop and laptop. The first time I saw it, Firefox had stopped working properly after an update through pacman -Syu.

The issue was minor, as clicking on the menu icon or other buttons which open menus would not work. I solved this by refreshing Firefox. I assume Spotify’s issue is related because AFAIK, Spotify is built on a browser?

In any case, while I can recover my browser easily, Spotify currently cannot play any sound, but does not report any errors running in a terminal. Reinstalling the package also did not help.

I’d like to either figure out what is causing this, or a way of recovering Spotify.

Edit for anyone coming across this in the future: My issue turns out to have had nothing to do with the issue I was encountering with Firefox, it looks to have just been a simple pulseaudio issue I could fix as according to the solution

#2

Do you mean you did a big update and did not restart ? Or this is ongoing?

Which packages exactly? There are multiple ff and spotify packages.

As for FF if ‘refreshing’ it works then it means something was amiss with your profile. Settings. Cache. Themes or extensions. I havent experienced any ff bugs due to ‘update frazzle’ or anything. I once did have this happen due to a change to FF and profile-sync-daemon at the same time … in which case my profile got garbled - but that was because of that secondary tool.

1 Like
#3

I usually leave updates until a number of packages need to change, the most recent one was ~120 packages. I did restart (forgot to mention it), but the problem still persisted. For packages, for Firefox I used the firefox package in the official repos, and for Spotify I used yaourt, finding this aur package.

What confuses me is how I’ve only seen the problem occur after an update, there’s never any errors which I’d imagine would appear if there was some dependency issue

#4

Just got the issue again after a few restarts of my computer without an update. It might have been coincidental timing with the updates up until now, but that leaves me with more questions :frowning:.

#5

It makes me still think it is a config issue.

Whats your setup?

inxi -Fxxz

For the heck of it what is

sudo pacman-mirrors -f && sudo pacman -Syyu
[no errors, nothing to do, etc, is fine … I dont need to see that]

#6

For inxi -Fxxz, the output on my laptop (all I really have available right now) is:

System:    Host: tapir-manjaro Kernel: 4.19.23-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 Desktop: i3 4.16.1 dm: LightDM 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: LENOVO product: 20CLS5KN00 v: ThinkPad X250 serial: <filter> Chassis: type: 10 
           serial: <filter> 
           Mobo: LENOVO model: 20CLS5KN00 v: SDK0E50510 WIN serial: <filter> UEFI: LENOVO v: N10ET36W (1.15 ) date: 06/19/2015 
Battery:   ID-1: BAT0 charge: 17.0 Wh condition: 21.4/23.2 Wh (92%) volts: 11.9/11.1 model: SONY 45N1111 serial: <filter> 
           status: Unknown 
           ID-2: BAT1 charge: 18.6 Wh condition: 20.0/23.5 Wh (85%) volts: 12.1/11.4 model: LGC 45N1127 serial: <filter> 
           status: Discharging 
CPU:       Topology: Dual Core model: Intel Core i7-5600U bits: 64 type: MT MCP arch: Broadwell rev: 4 L2 cache: 4096 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 20758 
           Speed: 2297 MHz min/max: 500/3200 MHz Core speeds (MHz): 1: 2297 2: 2295 3: 2295 4: 2294 
Graphics:  Device-1: Intel HD Graphics 5500 vendor: Lenovo driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:1616 
           Display: x11 server: X.Org 1.20.3 driver: intel unloaded: modesetting alternate: fbdev,vesa compositor: compton 
           resolution: 1366x768~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 5500 (Broadwell GT2) v: 4.5 Mesa 18.3.3 compat-v: 3.0 
           direct render: Yes 
Audio:     Device-1: Intel Broadwell-U Audio vendor: Lenovo driver: snd_hda_intel v: kernel bus ID: 00:03.0 chip ID: 8086:160c 
           Device-2: Intel Wildcat Point-LP High Definition Audio vendor: Lenovo driver: snd_hda_intel v: kernel 
           bus ID: 00:1b.0 chip ID: 8086:9ca0 
           Sound Server: ALSA v: k4.19.23-1-MANJARO 
Network:   Device-1: Intel Ethernet I218-LM vendor: Lenovo driver: e1000e v: 3.2.6-k port: 3080 bus ID: 00:19.0 
           chip ID: 8086:15a2 
           IF: enp0s25 state: down mac: <filter> 
           Device-2: Intel Wireless 7265 driver: iwlwifi v: kernel port: efa0 bus ID: 03:00.0 chip ID: 8086:095b 
           IF: wlp3s0 state: up mac: <filter> 
Drives:    Local Storage: total: 167.68 GiB used: 39.20 GiB (23.4%) 
           ID-1: /dev/sda vendor: Intel model: SSDSC2BF180A5L size: 167.68 GiB speed: 6.0 Gb/s serial: <filter> 
Partition: ID-1: / size: 161.90 GiB used: 39.20 GiB (24.2%) fs: ext4 dev: /dev/sda2 
           ID-2: swap-1 size: 1.68 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 39.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 2557 
Info:      Processes: 164 Uptime: 3m Memory: 7.67 GiB used: 1.13 GiB (14.8%) Init: systemd v: 241 Compilers: gcc: 8.2.1 
           Shell: zsh v: 5.7.1 running in: urxvtd inxi: 3.0.30

sudo pacman-mirrors -f && sudo pacman -Syyu ran without any issues

But I think the problem is much simpler than I first thought. I managed to reproduce the issue simply by killing Firefox while it was open, so it looks like the restarts probably caused the issue in the first place. Thinking back, I had left Spotify open, and I assume Firefox still had some background process running when I restarted, but at least I can prevent it from happening again now.

I also tried deleting the folders in ~/.cache to regenerate them, but that didn’t help.

#7

Delete or rename ~/.config/spotify/ then launch Spotify again, log in and see if the problem exists. If not, delete the old config and use the new one that just auto-generated.

#8

So I thought deleting the config fixed it because I tried my laptop’s speakers, and they played sound. Plugging in earphones to double check everything was fine, and I found they outputted nothing (tested them on another device - working fine). Hadn’t tried speakers before (bad quality, used to not using them), so they may have been working from the start :P.

An odd behavior I haven’t seen before is my audio muting after Spotify opens, which like I said didn’t affect anything with the speakers but no audio is coming out of the headphone jack.

Looks like multiple issues combining together from the same cause? In any case, this no longer applies as an issue with Spotify since it’s getting and playing sound. I assume it’s with alsa or pulseaudio outputting to the jack instead?

#9

delete .config/pulse then restart if you have audio playing problems

1 Like
#10

That worked, thanks!

closed #11

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.