Firefox slows to a halt after a while

firefox

#1

I’m running Firefox 65.0.1 64 bit, and after a short while of browsing (usually about 20mins) it starts getting really slow to load pages, to the point where nothing happens.

I note that most of the threads on this sort of thing suggest starting Firefox in safe mode first, so I did that, and it seems faster, but now I don’t know what to do?
(I’ve also carried out all the tweaks to about:config advised in another thread about slow Firefox, but these have not helped)

I’ve got the exactly the same addons on my Windows machine and cause no problems, so I presume, if it’s the addons, it’s some compatibility option, but I would really like to have ads blocked somehow, and the only addon I have is uBlock Origin.

Also, the slow-down is kind of random, so I still can’t be absolutely sure it’s caused by the addon.

So;

  1. Does anyone know if this problem is common and if there’s any solution to it?

  2. If it’s caused by uBlock Origin, does anyone know of an ad blocker which doesn’t cause this problem?


#2

How many open tabs do you usually have in FF and how much RAM does your computer have?

How many filter lists do you have in uBlock? I’m quite sure that uBlock isn’t the issue though, it’s pretty light on resources.

Does it help setting performance settings manually in FF settings (Settings -> General -> Performance), ideally by decreasing the number of threads from 4 to 3 or 2?


#3

Also, pretty basic, but make sure you empty your cache. Sometimes a profile can become corrupt. You can search for ways to start a fresh profile, or at least switch to another to see if the issue is resolved.


#4

Just one mostly.

None. At least none that I’ve set.

I will give it a try. With it being an intermittent problem, it’s really hard to sort out by experiment, which is why I asked particularly if this was a known problem. When I first made the tweaks suggested in the first thread I read it all seemed to work perfectly and I thought I’d cracked it, but half an hour later it had all jammed up again.

As a side note, I’m forever curious as to how these things happen. This is an almost completely clean install (only been running a few days). I have no data on the computer yet, no custom settings and hardly any other software. Yet the default browser that comes with the distribution is not working properly. I expect to have to do a bit of tinkering to get Linux working as it’s not the native system for most applications, but I do find it odd that this isn’t just a standard problem that everyone knows the solution to. I can only presume that thousands of Manjaro users out there are using Firefox without any problems straight out of the box (otherwise it would be a more well-known problem). So, in addition to the steps I need to take to get it working again, I’d be really grateful if anyone could also tell me what I might have done wrong to have it end up this way in the first place. I think I followed all the installation instructions accurately, but I must have messed up somewhere.


#5

I tried it but I’ll have to give it a while to see if it works. As mentioned above, this is only a few days old installation so it seems unlikely (to my novice understanding) that my profile might be corrupted, but there’s nothing to lose trying it as I don’t have anything saved on it yet.


#6

It is really odd. I have used Firefox for a long time, same profile, and I have not witnessed/felt any slowdown. Other areas that could affect it is your video card driver… and check that hardware acceleration is turned on and that your graphics drivers are up-to-date.


#7

If you think you messed up, you probably messed up. What exactly are you unsure about? Did you change some default install options? Does this happen with a live USB?


#8

Nothing stands out as some aspect I’m unsure about, I was just deducing logically.

It’s a fresh install with very little additional software (all from the repository), no data and no customisation, so if Firefox doesn’t work properly and it’s not a well-known problem, the only logical possibility left is that I messed something up.

I mean, there’s only so many variables on a fresh install, and thousands of Manjaro/Firefox users who must, in the vast majority, be experiencing very little trouble, so it stands to reason that whatever the cause of this problem it must be something the developers were not expecting to happen - ie a mistake. I just don’t know what it is yet.


#9

OK. Possibly very important new bit of information. When this first happened I tried other internet services (Steam, Octopi, NextCloud) and they all worked fine, but just now it happened again and I though I’d give those services another try - none of them would connect to the internet either. So the problem must be with my internet connection, not Firefox. The trouble is, it seems to randomly drop out and then come back again and I obviously wasn’t quick enough the first time so I dismissed it as an option.

It’s not my internet connection in general, because my other devices (tablets, phone, Windows computer) are all still connected fine.

Do I need to start a new thread, now I know it’s not Firefox?


#10

Yes, and supply all your hardware information (inxi).


#11

I found a thread which suggested making the network connection available to all users which I did, and so far it’s solved the problem so there may be no need for a new thread afterall. We’ll see.