Firefox runs without interface

New update today, reboot, and no FF window when clicking on the icon. Still 4 processes in Task Manager. No error shown when running FF in Terminal. :face_with_raised_eyebrow:

Start Thunderbird, find a mail with a link, click on it. New processes appear on top of the previous ones. Kill the previous ones, FF window appears, with all the tabs ! :slight_smile:
Magic :smiley:

When killing the processes, something appeared :

FF no window kill processes

When FF runs properly, the first process shows an icon. Something I did not see if no window appears :

But what about the first start of Firefox?

Kill all Firefox processes and run from terminal.

Kill FF processes, then run FF from Terminal : no error, but no window.
Kill FF processes, then run from icon : same
Kill FF processes, click on the link I used last time : same …
Kill FF processes, click on another link : FF opens a window with all the tabs !!!

Cache problem ?

“right-click” firefox icon - “action” - “new window”.
firefox comes up.
This worked for me.

I would rescue some file from .mozilla:

key4.db= has to do with passwords, I don’t remember exactly, but worth backing up
logins.json = saved passwords
prefs.js- self explanatory
search.json.mozlz4= Search engines, including custom

Then stop Firefox processes.
Now move .mozilla to .mozillabackup.
Start Firefox - this creates a new settings folder .mozilla.
Stop Firefox.
Copy the files mentioned above to .mozilla.
Start Firefox.

Try this to open a Firefox widow showing Troubleshooting Information page

firefox --new-window about:support

and click on Clear startup cache…

[answer to nikgnomic]
Done . After “Restart” both FF windows reopened properly.
Close both windows, click on FF icon : both windows reopen again.
It seems to be corrected. I will see tomorrow after Reboot.
Thanks for your help and regards
[Edit : next morning, Reboot, and FF started without problem :smiley: ]

Hi Fafnir,
I will try this next time I have the problem (I saw your post after ikgnomic’s one). In that case, I will loose the tabs, but it’s usually not important.

Based on experience till today… Firefox processes lock each other out.

So first Task Manager icon is shown and mouse icon changes - indicating Firefox being run (loading), but then no GUI window is spawn and Firefox processes silently lock each other out without any error reported in console.

I kill the last processing identity spawned and like dominoes everything “unlocks” and finishes initialization - thus spawning GUI window frames. At least that is now consistent behaviour even after multiple reboots.

But with this we are still in the same situation that we have to sometimes repeat this “kill-the-last-Firefox-process” for Firefox to run. And relation to [2022-11-02] updates still unknown. I am reluctant to call this a solution, but at least we can use Firefox.

Try this to check Firefox running processes

firefox --new-window about:processes

I’m having this exact same issue. It started a few weeks ago after the last big patch bundle release. To get Firefox working I have to click the icon, wait for it a few seconds and see if the browser window comes up. If it doesn’t then I have to kill all the Firefox processes through terminal and try again. Usually it works on the second try but sometimes it won’t work until Firefox asks me if I want to start in safe mode. If I do that then it will work again until I reboot.

since safe-mode starts the browser with all add-ons disabled
it is essentially the same as temporarily creating a new profile
removing your old profile and starting with a fresh one
is probably something you have tried?

mv ~/.mozilla ~/.mozilla.old
while there is no browser process running

If that (safe mode) helps, it is indicative of a problem with your add-ons or extensions.

I don’t think it’s the extensions because I completely uninstalled Firefox and deleted the profiles folder and I still had the problem when I installed it again but before I installed any extensions.

Run pacman -Rsn Firefox to remove both Firefox along with all of it’s dependencies and configuration files. The files are not removed in the standard removal process.

These files are the cause of your problems because they remain behind after a removal, reinstall, or update.

The configuration files that you added after installation will have to be deleted manually.

While this seems a bit inconsistent - safe-mode and fresh profile works, but only sometimes - and I can’t make heads or tails of it

makes no sense and is not correct either
It’s a bit like trying magic - hoping that doing something will achieve something, when it objectively can’t.

When I proceed to remove firefox with:
sudo pacman -Rsn firefox

all that gets removed is … firefox
nothing else

There are no configuration files to be left behind - except for the profile in ~/.mozilla
and perhaps the cache ~/.cache/mozilla
which will of course not be touched by removal of the program - nothing in the $HOME directory will be.

When I uninstalled Firefox I purposely made sure to delete the firefox folder under ~/.mozilla so everything would be removed, but the problem remains. The strange thing is that this is an intermittent problem. Sometimes it works on the first try (although that’s rare), usually it works on the second try (after killing the first process), but sometimes it won’t work until Firefox prompts me about safe mode. It’s weird!

Then the problem is in your installed system.
You may need to reinstall.

Can you post inxi -Fza ?

in my desperation, I have installed firefox-esr 102.5.0esr from mozilla in /opt (outside the box). Start from terminal and firefox runs.
The same im all my other user accounts.
Then I try it with firefox 107 … the same issues before.
it seems to be a firefox problem.

As I added: