Firefox opens manjaro.org every time I start it

It looks like:
you change the wrong setting,
you don’t save after doing the change,
do you have an add-on which plays tricks,
or there really is something wrong with how Firefox is installed on your system.

When you get the wrong homepage what does the setting tell you? Is that also the wrong one or is it correct?

The correct setting is shown after restarting firefox

Still the wrong homepage is shown?

Yep. Same

That means something else in Firefox is overruling the setting for your start page.
Which extensions (add-ons) to you use?

Before:


After:

Also no add-ons

Does changing it to a custom page work?

?

2 Likes

Does changing it to a custom page work? I’m not using Firefox but I suppose there’s something wrong with that Firefox Home (default)

Yes it works.

Thanks. I fixed it with the image.

So this is what I did:

  1. Go to about:config
  2. Search for “browser.startup.homepage” (without quotes)
  3. Change “browser.startup.homepage” to “about:home” (without quotes)
  4. Right click on “browser.startup.homepage_override.buildID” and “browser.startup.homepage_override.mstone” and click reset (without quotes)
  5. There you have it.
5 Likes

Moved to Technical Issues and Assistance - Applications since it was asking for help.

This procedure also works.

Open this file in a text editor as sudo:

/usr/lib/firefox/distribution/distribution.ini

Delete these lines:

[LocalizablePreferences]
browser.startup.homepage="https://manjaro.org/"

Save the file. Then restart Firefox.

7 Likes

That worked as well. Thanks for the help.

Should manjaro change homepage that let the preferences “Homepage and new windows” void?

Oh, I just realized that this was made because of manjaro-browser-settings package. I think I remove it because after update the start page was modified again.

Switched my homepage from a music service I’ve used forever and found myself stuck here as well today.

This fixed it up and I’ve created an alias for quick home page reset. Which I imagine will need to be done when ever certain packages are updated from time to time.

$ sudo sed -i "s|https://manjaro.org/|about:home|1" /usr/lib/firefox/distribution/distribution.ini
  • “about:home” can be replaced with any desired page
  • use pipe | instead of foward slash / as delimiter, allows url to be passed w/o escaping
2 Likes

:heart:

Quit necrobumping…

Forum kindly sponsored by