FireFox langage switches to English after update

Hello, I have a relatively fresh Manjaro KDE minimal install.
I am using German i.e. “Deutsch (Deutschland)” as my main system language, with “English (United States)” as secondary language, specified in the Manjaro Settings-manager, as well as in the KDE settings(there I only have “Deutsch” as language).
Firefox was set to German as menu language as well as for “displaying [web]pages”, however after the update to 126.0-0.1 the menu language was switched to “English (US)”. Fortunately the “displaying [web]pages” languages seems to have stayed the same (a combination of German and English).

So in short:

  1. Have Firefox setup, with the menu language being not English (i.e. German)
    I am using the native firefox package i.e. not the Flatpak.
  2. Update Firefox
  3. The menu is set to “English (US)”

This is a very annoying bug that has existed for a long time on Manjaro (wayback since at least one or two years ago, but I couldnt find my old issue).

I doubt that my system setup should have anything to do with this, since it is a fresh install and I’ve had this issue before. However if I can provide any additional details please tell me.
Otherwise if this issue was reported(upstream/to the Manjaro packagers) I did like to know since it appears to be a persistent issue, it might be a small one indeed however if every application would behave like that using any other language but English would prove to be a chore.

1 Like

Did you also install firefox-i18n-de?

(I don’t have this issue, so it must be specific to your setup.)

Yes I have/had the firefox-i18n-de and firefox-i18n-en-us(and hunspell-en_US, hunspell-de) package installed.
Also I am planing on installing more language packages in the future, however since I had have this issue before iirc I did not install any new Firefox specific language packages(except for those packages the Manjaro Settings-manager recommends).

The same happens to me. Each update Firefox returns from Spanish to English. Tested with or without firefox-i18n-es installed and the behaviour is the same. Happens since the first day installed Manjaro in my machine (two years ago).

Thunderbird also from Mozilla, does not the same and works fine.

2 Likes

And when is it fixed?

Could it be that the firefox package is updated while the language pack firefox-i18n-de is still the old version because the mirror was not fully synchronized or was it not yet built?

Both packages are on 126 and I just updated them simultaneously via the CLI with pacman -Syu.
And well it is when I manually switch the language in the Firefox settings until the next update(I assume that will reset the language once again).

After the 127 testing branch Firefox update the language again switched back to English(US).
I uninstalled the firefox-i18n-en-us package and will see how it goes with that.