Firefox issues after update to v88

Yup - no issue other than browser takes longer to open

88.0-1 in unstable is directly from Arch. 88.0-0.1 in testing and stable was built by @nightmare-2021, FYI. That shouldn’t make a difference, but just to be clear there are two separate builds.

Oh boy! Nvidia user here, while Firefox “works” regardless of toggling the Hardware Acceleration option, per @omano’s post, the tests simply crawled compared to Chromium or Vivaldi.

Nvidia drivers 460.67, latest KDE. (Not including separate package/kernel information since it will be redundant, but they reflect OP’s.)

UPDATE: Same exact results when using the binaries provided from on a fresh profile, without any extensions. Toggling Hardware Acceleration doesn’t effect the visibility/rendering of web pages, nor does it change that the benchmarks run atrociously slow.

Most likely Nvidia didn’t adopt yet to Firefox changes. Best would be to disable HW acceleration for now if you have issues.

Not sure if this helps others, but I solved the performance issues with the following combination:

Under Preferences:
[ ] Use recommended performance settings
[X] Use hardware acceleration when possible

Under about:config:
gfx.webrender.all, set to true

Restart Firefox, and try out this combination.

Not sure if “all” overrides “enabled”, as mine are like so, and yield the same results:

  • gfx.webrender.all → true
  • gfx.webrender.enabled → false (or true, no difference)

Chalkboard results, HD Intel 5500 i915 issues as reported above.

ff88 gfx.webrender = off -131 seconds
ff88 gfx.webrender = on - 150 seconds
ff87 (new profile) - 131 seconds

So it seems version 88 is no worse than 87 for this and for me that setting made it worse not better.

Brave browser default settings - 18 seconds. (Vast improvement!!)
Vivaldi default settings - 18 seconds (installed after initial post.)

Maybe it’s time I changed browser. Been meaning to check Vivaldi too. Strangely I noticed slugishness on Brave in everyday usage I don’t notice on Firefox (especially when scrolling text heavy pages) which is one of the main reasons I didn’t switch. Last two updates Firefox has changed other things I don’t really like as well though…

i have tested , with this ( 3600XT and Nvidia pci 970 GTX)
same config
-Use hardware acceleration when possible( max 8 by default )

only change

  • gfx.webrender.all → true

score is 6.45s ( before 78s )

i do an another test video
on screen 1080p x 60fps ( htop & stats for 1080p only )

without webrender ,
load cpu between 1.10 to 1.41 , see always Xorg on 33 to 35% ( more in older version high to 50% )

with webrender
load cpu between 0.40 to 0.60 , see always Xorg on 2% , gpu is used , also cpu on start , a little more in memory )

there is an impact on all video web also


Even after setting gfx.webrender.all = true I couldn’t turn on hardware acceleration without the previous issue coming back of no window contents updating.

I removed the solution as it is not a solution at all. To the one who marked it, you marked a solution, from someone who had a solution for not having the issue… he gave a solution for having better performance in the HTML5 test…

If you enable Hardware Acceleration, there is an issue. I already have gfx.webrender.all → true (as I said I had proper hardware acceleration before foolowing the guides to enable it), if I enable the hardware acceleration box then Firefox is broken, if I disable it then I have no hardware acceleration.

//EDIT: Created another new profile, by default after a Firefox restart it is broken. I then enable gfx.webrender.all → true and restart Firefox. Still broken.

//EDIT2: let’s wait for a driver update maybe that will solve the problem.

Nice thread…
Confirms that enabling webrender make FF a quick browser (should be default for now).
I did see nowhere in the thread what plugins are in use (OP or respondents…)

THAT makes the difference.

So please:

grep -oP '},"name":"\K[^"]+' ~/.mozilla/firefox/*.*default*/addons.json

I already explained in different posts that I did my tests with and without extension, tried to wipe everything in home (cache and mozilla folders), tried with the Arch build, and with multiple new profiles so that makes no difference, this is not an extension problem.

Already gave my inxi and the Firefox error log, so at this point I can’t give more.

I have similar hardware, and I’m also using the same kernel, KDE, and nvidia driver. Let me know any combination you want me to try to re-create the issue. I’ve been trying different options in nvidia-settings, X11 settings, Firefox settings, and even KDE/Kwin settings. Each time, even after rebooting, does not yield “blank” or partially rendered pages.

Not sure why it was marked as a solution. I didn’t even know someone else besides the OP could mark a thread as “solved”. :dizzy_face:

Usually FF and Chrome use to be more or less at the same performance level. For this time though, whatever my configuration changes, FF is far below Chrome performance level and noticeably below the 87 performance level. Maybe it is becoming a little monster these days…

Meanwhile, no problems on page rendering here with old AMD hardware and Cinnamon DE.

There was a strange minor glitch though: My system is fully installed on Portugal’s Portuguese (PT-pt) but the update didn’t automatically add the PT-pt locale language and went instead on US English. Weird, but easily solvable on the settings configuration by manually importing the Portuguese language.

Have a nice day!..

Moderators, Admin, or users with Trust Level 3 (Regular badge) can mark solutions.

running on Nvidia Use recommended performance settings unchecked, Use hardware acceleration when possible checked(8 default),gfx.webrender.all → true, everything works fine.
with Intel alone(very poor performance as usual with weird glitches),and since 88 it takes much longer to open(very noticeable).

I hope people who report it as working check different websites, and different restart of Firefox. Because as mentioned in my early post, I had a page or two working magically when all the rest was not showing (I don’t doubt it is working but you may not test thoroughly, with different profiles and multiple tests).

Please also all give your system information properly to maybe find a pattern wether that works or not, if you report here.

inxi -Fazy

On a side note, I tried to install the Nvidia BETA 465 drivers from the AUR for a test (on Kernel 5.10), but I can not boot with them, not sure what is not working, this is what I tried to install from AUR:

  • nvidia-beta-dkms
  • nvidia-settings-beta
  • lib32-nvidia-utils-beta
  • nvidia-utils-beta

and with and without

  • lib32-opencl-nvidia-beta
  • opencl-nvidia-beta

Not sure if I’m missing something, but so far the desktop doesn’t load with that, so back to official Nvidia driver from Manjaro.

Per chance did you try it with the binary provided directly from Then after extracting it into its own directory, from within the directory running:

./firefox -P

and creating a new temp profile?

If it resolves the page rendering issue, it might have something to do with Manjaro/Arch builds or compile options?

So, there is some progress, but more questions.

If I wipe the ~/mozilla folder, and extract and execute official prebuilt Firefox from Mozilla, the newly created profile does not have the issue when hardware acceleration is forced from settings, and enabling gfx.webrender.all makes the HTML 5 test fast as before when I had everything working correctly.

If I restore my ~/.mozilla folder, and use my current profile, the problem on the official Firefox is present again.

If I use the ~/.mozilla folder created by the official Mozilla prebuild, with the Firefox executable provided by Manjaro, the issue is not there.

So it seems to be a ~/.mozilla folder problem, right?

However, why is it working now when I wipe the ~/.mozilla folder, it was definitely not working when I tried before.
Why is it now working if I recreate a new profile, from my old ~/.mozilla folder. This doesn’t make any sense, running the official Firefox could not have modified the system in a way like that.

Some things that change between my tests all day and now, is that I tried to install other Nvidia drivers, but I’m back on same drivers as before… and anyway I still have the problem on my old profile in my old ~/.mozilla folder…

This makes no sense at all why everything that wasn’t working on ALL my previous tests, is now working (fresh profile in old ~/.mozilla folder or fresh ~/.mozilla folder)

This is really weird. For now I will try to wipe the ~/.mozilla folder, use the default profile, and reimport the 4 important files in the profile (will reply when it’s done)

Also I had a friend with similar machine as me update his system (on Stable) tonight, and he could reproduce the same issue in his Firefox.

@omano this article might help you? See the egl.force-enabled switch.


Bingo. :point_up_2:

I can reproduce the issue 100% with this flag. (Page rendering and “non” rendering is occurring just like in @omano’s screenshot.)

@omano, what about you?

UPDATE: The nightmare combination seems to be:

  • Nvidia card + proprietary driver
  • [X] Use hardware acceleration when available (enabled)
  • gfx.x11-egl.force-enabled = true
  • gfx.x11-egl.force-disabled = false
  • gfx.webrender.all = true
  • gfx.webrender.enabled = true