Firefox issues after update to v88

Nice thread…
Confirms that enabling webrender make FF a quick browser (should be default for now).
I did see nowhere in the thread what plugins are in use (OP or respondents…)

THAT makes the difference.

So please:

grep -oP '},"name":"\K[^"]+' ~/.mozilla/firefox/*.*default*/addons.json

I already explained in different posts that I did my tests with and without extension, tried to wipe everything in home (cache and mozilla folders), tried with the Arch build, and with multiple new profiles so that makes no difference, this is not an extension problem.

Already gave my inxi and the Firefox error log, so at this point I can’t give more.

I have similar hardware, and I’m also using the same kernel, KDE, and nvidia driver. Let me know any combination you want me to try to re-create the issue. I’ve been trying different options in nvidia-settings, X11 settings, Firefox settings, and even KDE/Kwin settings. Each time, even after rebooting, does not yield “blank” or partially rendered pages.

Not sure why it was marked as a solution. I didn’t even know someone else besides the OP could mark a thread as “solved”. :dizzy_face:

Usually FF and Chrome use to be more or less at the same performance level. For this time though, whatever my configuration changes, FF is far below Chrome performance level and noticeably below the 87 performance level. Maybe it is becoming a little monster these days…

Meanwhile, no problems on page rendering here with old AMD hardware and Cinnamon DE.

There was a strange minor glitch though: My system is fully installed on Portugal’s Portuguese (PT-pt) but the update didn’t automatically add the PT-pt locale language and went instead on US English. Weird, but easily solvable on the settings configuration by manually importing the Portuguese language.

Have a nice day!..

Moderators, Admin, or users with Trust Level 3 (Regular badge) can mark solutions.

running on Nvidia Use recommended performance settings unchecked, Use hardware acceleration when possible checked(8 default),gfx.webrender.all → true, everything works fine.
with Intel alone(very poor performance as usual with weird glitches),and since 88 it takes much longer to open(very noticeable).

I hope people who report it as working check different websites, and different restart of Firefox. Because as mentioned in my early post, I had a page or two working magically when all the rest was not showing (I don’t doubt it is working but you may not test thoroughly, with different profiles and multiple tests).

Please also all give your system information properly to maybe find a pattern wether that works or not, if you report here.

inxi -Fazy

On a side note, I tried to install the Nvidia BETA 465 drivers from the AUR for a test (on Kernel 5.10), but I can not boot with them, not sure what is not working, this is what I tried to install from AUR:

  • nvidia-beta-dkms
  • nvidia-settings-beta
  • lib32-nvidia-utils-beta
  • nvidia-utils-beta

and with and without

  • lib32-opencl-nvidia-beta
  • opencl-nvidia-beta

Not sure if I’m missing something, but so far the desktop doesn’t load with that, so back to official Nvidia driver from Manjaro.

Per chance did you try it with the binary provided directly from Then after extracting it into its own directory, from within the directory running:

./firefox -P

and creating a new temp profile?

If it resolves the page rendering issue, it might have something to do with Manjaro/Arch builds or compile options?

So, there is some progress, but more questions.

If I wipe the ~/mozilla folder, and extract and execute official prebuilt Firefox from Mozilla, the newly created profile does not have the issue when hardware acceleration is forced from settings, and enabling gfx.webrender.all makes the HTML 5 test fast as before when I had everything working correctly.

If I restore my ~/.mozilla folder, and use my current profile, the problem on the official Firefox is present again.

If I use the ~/.mozilla folder created by the official Mozilla prebuild, with the Firefox executable provided by Manjaro, the issue is not there.

So it seems to be a ~/.mozilla folder problem, right?

However, why is it working now when I wipe the ~/.mozilla folder, it was definitely not working when I tried before.
Why is it now working if I recreate a new profile, from my old ~/.mozilla folder. This doesn’t make any sense, running the official Firefox could not have modified the system in a way like that.

Some things that change between my tests all day and now, is that I tried to install other Nvidia drivers, but I’m back on same drivers as before… and anyway I still have the problem on my old profile in my old ~/.mozilla folder…

This makes no sense at all why everything that wasn’t working on ALL my previous tests, is now working (fresh profile in old ~/.mozilla folder or fresh ~/.mozilla folder)

This is really weird. For now I will try to wipe the ~/.mozilla folder, use the default profile, and reimport the 4 important files in the profile (will reply when it’s done)

Also I had a friend with similar machine as me update his system (on Stable) tonight, and he could reproduce the same issue in his Firefox.

@omano this article might help you? See the egl.force-enabled switch.


Bingo. :point_up_2:

I can reproduce the issue 100% with this flag. (Page rendering and “non” rendering is occurring just like in @omano’s screenshot.)

@omano, what about you?

UPDATE: The nightmare combination seems to be:

  • Nvidia card + proprietary driver
  • [X] Use hardware acceleration when available (enabled)
  • gfx.x11-egl.force-enabled = true
  • gfx.x11-egl.force-disabled = false
  • gfx.webrender.all = true
  • gfx.webrender.enabled = true

Yes enabling egl.force-enabled makes my freshly working new profile (in my new .mozilla folder) bug again. So this may be the culprit here.

To be honest I’m bewildered because of all the various testing I had since this morning, I can find all the copies of my .mozilla folder and my backups of profiles made by Firefox when I ‘repaired’ it from the Firefox button specially made to create brand new fresh profile, I’m not crazy I have done everything I said, yet this makes absolutely no sense now to me (EDIT: could have been my .pam_environment file described earlier, but with the working firefox it doesn’t create an issue now).

I can have a working Firefox with hardware acceleration for now by wiping everything and reimporting the 4 important files (key4.db / logins.json / favicons.sqlite / places.sqlite), but I notice new glitches, where Firefox blinks all around or in some parts and show for a split second the windows behind it when I do some mouse movement over its taskbar icon/preview. Not that big of a deal but this is new.

Hi, is it possible to revert to the Open GL compositor in Firefox 88?
WebRender is disabled in about:config, but still shows up as the compositor in about:support.

Firefox 88 was quite the release huh? :woozy_face:

According to the link provided by @flux,

Turns out we can bring back Open GL with
gfx.webrender.force-disabled → True

My problem system (HD Intel 5500) has both egl flags set to False and still can’t enable hardware acceleration in 88 but can in 87.

gfx.x11-egl.force-disabled false
gfx.x11-egl.force-enabled false

You could try FF 89 beta for FF Nightly 90.
I use Nightly builds for months without any issue

OK I updated my system on the Testing branch, rebooted, and I had the issue again, then I understood, the .pam_environment I eventually restored yesterday when everything was working (and was still working after restoration, because I did not reboot), was the reason why despite all my testing I could not make sense of it in the end when I eventually had results contradicting everything I tested before. I deleted the .pam_environment file and REBOOTED, and it fixed itself. the .pam_environment file seems to need a reboot to clear it all.

Anyway seem we don’t need it at all now to enable all the good features in Firefox.

Huh, yes, why do you want to change default settings?
I have the feeling you created yourself issues nobody has though.