Firefox issues after update to v88

I received a Firefox update (88.0-0.1) and Firefox doesn’t render web pages. Restarting Firefox in safe mode fixes the issue, but I can’t find what is going on on my user profile. Here is how it looks, I can find links under my mouse pointer but the page looks blank: Imgur: The magic of the Internet
Some websites show properly like this imgur link, ProtonDB…

//EDIT: Google wasn’t showing, but going to Google Translate asked me to accept the EULA and connect (I cleared the cache previously before restarting Firefox multiple times). Accepting the Google EULA magically fixed the browser, I then could see and login to non working websites… Weird…
//EDIT2: No, wait, I can’t still view GitHub… and other websites, back to where it was…
//EDIT3: I eventually reset Firefox (using the Repair Firefox function), setup everything back reinstalled all extension, everything works, and then it broke again, back to intial state web pages don’t render. anymore on most website.
//EDIT4: I recreated another clean Firefox profile, for now I will install only Ublock Origin extension, probably an extension is messing with Firefox but at one point I had reinstalled everything and it was working, it just randomly broke… will see if it breaks with only Ublock.
//EDIT5: clean profile, installed Ublock and enabled/updated built-in lists, all works, untill I restart Firefox, I just Repaired Firefox again, will not reinstall anything, I just reorganize the toolbar (removed unused buttons, moved the home and refresh button), will see if it breaks, at which point I would say, current Firefox is broken.
//EDIT6: so with my profile ‘Repaired’ from Firefox (basically a clean profile with my bookmarks and things like that), restarting Firefox just breaks it, I can’t access most website at all after restarting it… WTH is going on?

//EDIT FINAL: Firefox is broken on my side, definitely. I created a fresh profile from scratch, made it default profile, restarted Firefox, I can access the forum, OK.
I restart Firefox, I can’t access the forum anymore.

@nightmare-2021 can you have a look please? Is it only me? I see the update landed in Stable too… hope it is only me… sounds alarming if it is broken.

Firefox 88.0-0.1 is working fine for me.

1 Like

Thanks for the reply.

I uninstalled Firefox, deleted the ~/.cache/mozilla folder, removed the ~/.mozilla folder, reboot the machine, reinstalled Firefox, Started Firefox, accessed forum. I restart Firefox, I can’t see the forum, back to initial issue. I’m lost.

//EDIT: Ah! I went to the completely freshly 100% reset Firefox Settings, and disabled two options:

[ ] Use recommended performance settings
 [ ] Use hardware acceleration when possible

Restarted Firefox, and web pages now properly show after Firefox restarts. It seems there is a problem then with this feature, maybe because of Nvidia. It always worked before.

I have both of those enabled, but I don’t have Nvidia.

I restored my initial profile folder, disabled these option, my initial profile is now working as before without these options so I would say these features are broken on my machine.

[omano@omano-nvme ~]$ inxi -Fazy
  Kernel: 5.10.30-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=6a81f472-9ea9-40f8-85f6-7925c4bbe742 ro quiet splash apparmor=1 
  security=apparmor udev.log_priority=3 nowatchdog 
  Desktop: KDE Plasma 5.21.4 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Desktop System: Gigabyte product: B450M DS3H v: N/A serial: <filter> 
  Mobo: Gigabyte model: B450M DS3H-CF v: x.x serial: <filter> 
  UEFI: American Megatrends LLC. v: F60 date: 02/24/2021 
  Info: 6-Core model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2 
  family: 17 (23) model-id: 71 (113) stepping: 0 microcode: 8701021 cache: 
  L2: 3 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 86235 
  Speed: 2195 MHz min/max: 2200/3600 MHz boost: enabled Core speeds (MHz): 
  1: 2195 2: 2195 3: 2195 4: 2196 5: 2196 6: 2196 7: 2196 8: 2196 9: 2195 
  10: 2195 11: 2196 12: 2195 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] vendor: 
  driver: nvidia v: 460.67 alternate: nouveau,nvidia_drm bus-ID: 07:00.0 
  chip-ID: 10de:1c03 class-ID: 0300 
  Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: 
  loaded: nvidia display-ID: :0 screens: 1 
  Screen-1: 0 s-res: 1680x1050 s-dpi: 87 s-size: 490x321mm (19.3x12.6") 
  s-diag: 586mm (23.1") 
  Monitor-1: DVI-D-0 res: 1680x1050 dpi: 87 size: 490x320mm (19.3x12.6") 
  diag: 585mm (23") 
  OpenGL: renderer: GeForce GTX 1060 6GB/PCIe/SSE2 v: 4.6.0 NVIDIA 460.67 
  direct render: Yes 
  Device-1: NVIDIA GP106 High Definition Audio vendor: 
  driver: snd_hda_intel v: kernel bus-ID: 07:00.1 chip-ID: 10de:10f1 
  class-ID: 0403 
  Device-2: AMD Starship/Matisse HD Audio vendor: Gigabyte 
  driver: snd_hda_intel v: kernel bus-ID: 09:00.4 chip-ID: 1022:1487 
  class-ID: 0403 
  Sound Server-1: ALSA v: k5.10.30-1-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.25 running: yes 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Gigabyte driver: r8168 v: 8.048.03-NAPI modules: r8169 port: f000 
  bus-ID: 05:00.0 chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp5s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
  Local Storage: total: 2.03 TiB used: 1.04 TiB (50.9%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Crucial model: CT1000P1SSD8 
  size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
  lanes: 4 rotation: SSD serial: <filter> rev: P3CR020 temp: 49.9 C 
  scheme: GPT 
  ID-2: /dev/sda maj-min: 8:0 vendor: SanDisk model: SSD PLUS 480GB 
  size: 447.14 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  rotation: SSD serial: <filter> rev: 00RL scheme: MBR 
  ID-3: /dev/sdb maj-min: 8:16 vendor: Western Digital 
  model: WD5001AALS-00E3A0 size: 465.76 GiB block-size: physical: 512 B 
  logical: 512 B speed: 3.0 Gb/s serial: <filter> rev: 1D05 scheme: MBR 
  ID-4: /dev/sdc maj-min: 8:32 vendor: SanDisk model: SDSSDHP256G 
  size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  rotation: SSD serial: <filter> rev: 6RL scheme: GPT 
  ID-1: / raw-size: 931.22 GiB size: 915.6 GiB (98.32%) 
  used: 694.27 GiB (75.8%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2 
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 9.1 MiB (3.0%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 
  Alert: No swap data was found. 
  System Temperatures: cpu: 41.8 C mobo: 16.8 C gpu: nvidia temp: 51 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 8% 
  Processes: 288 Uptime: 20m wakeups: 0 Memory: 15.64 GiB 
  used: 2.55 GiB (16.3%) Init: systemd v: 247 tool: systemctl Compilers: 
  gcc: 10.2.0 clang: 11.1.0 Packages: 1550 pacman: 1544 lib: 427 flatpak: 6 
  Shell: Bash v: 5.1.0 running-in: konsole inxi: 3.3.04
1 Like

Maybe add that to the wiki post for other folks with NV.
Can’t reproduce on my side with AMD, everthing is fine (i’ve forced webrenderer for a while now, so for me there shouldn’t be a change with 88 ^^)

I would if people could confirm the issue. My personnal experience is not solid proof to confirm an issue globally. Wait and See.

Firefox now kinda sucks, this page I use as “benchmark” Chalkboard HTML5 Benchmark now finishes in very long time, it used to render in 6 seconds, now it is 100 seconds. Horrible performance lol.

With the new version, Mozilla enabled WebRender by default for some more configurations on linux it seems.

Probably that is causing issues with NV. (Which would explain why it is working when hw accel is disabled)

But I always had Hardware Acceleration enabled AND WORKING before. My settings were like that before:

[ ] Use recommended performance settings
 [X] Use hardware acceleration when possible

And I had a .pam_environment file in my home (I tried with and without it during my tests, I restored it for now even if it seems to not do anything with the Firefox settings above disabled):


And HTML5 benchmark was then completing in 6 seconds now it is 100+ seconds (because I had to disable hardware acceleration for pages to properly render).

Here is Firefox log when I enable Hardware Acceleration in Settings:

[omano@omano-nvme ~]$ firefox 
[GFX1-]: Failed to create EGLSurface!: 0x3009
[GFX1-]: Failed to create EGLSurface
[GFX1-]: Fallback (SW-)WR to Basic
[GFX1-]: Compositors might be mixed (5,1)
[GFX1-]: Failed to connect WebRenderBridgeChild.
IPDL protocol error: Handler returned error code!

###!!! [Parent][DispatchSyncMessage] Error: PCompositorBridge::Msg_NotifyChildRecreated Processing error: message was deserialized, but the handler returned false (indicating failure)

[GFX1-]: Failed to connect WebRenderBridgeChild.

(firefox:6021): GLib-GIO-WARNING **: 11:54:34.125: /etc/xdg/kde-mimeapps.list contains a [Added Associations] group, but it is not permitted here.  Only the non-desktop-specific mimeapps.list file may add or remove associations.

(/usr/lib/firefox/firefox:6196): GLib-GIO-WARNING **: 11:54:35.234: /etc/xdg/kde-mimeapps.list contains a [Added Associations] group, but it is not permitted here.  Only the non-desktop-specific mimeapps.list file may add or remove associations.

from my side
78,72s for 970 GTX video cards
option perf was ON

on about:config for webrender & hardware

78,43s when Use hardware acceleration when possible ( 8 process default)

Is your Firefox broken if you enable Hardware Acceleration in Firefox Settings?

Not sure what you’re talking about.

Same info in about config here, on a GTX 950 using Nvidia drivers and ~110 seconds for the test.
For comparison Chromium does the test in 7 seconds.
(forgot to mentions this is on stable with 88.0 to give some comparison)

I should probably look into this but so far I haven’t really bothered since the normal usage is not affected at all. One thing I notice is that Chromium uses more cores, Firefox only one core of the 12 I have available

What are you both talking about, in about:config page? Also is your Firefox broken if you enable Hardware Acceleration and restart it too? You both could help the investigation about the issue I reported, yet you both talk gibberish to me and don’t answer the valuable questions. Please make an effort.

I think they were talking about the about:support page. :thinking:

Maybe, but the one million dollar question for Nvidia users still stands:

is your Firefox broken if you enable Hardware Acceleration and restart it too?

[ ] Use recommended performance settings
 [X] Use hardware acceleration when possible

//EDIT: it seems Intel is also affected, but not AMD: Firefox 88 doesn't run

@moderators maybe we can move all posts about the issue in another thread?


Is manjaro building/packaging FF themselves or do they use the Arch package? (Can’t check myself now. Not at a PC)

I would assume some threads on the arch forum too about this issue.

If manjaro builds their own, maybe try installing the one from arch to see if you can reproduce the issue with that one as well.

I had to have Hardware Acceleration Disabled. IE I had to untick both boxes, not just the Recommended Settings one. (onboard HD-Intel 5500, i915 driver.) (I’m OP of linked Intel thread.)

It says the packager in Helmut Stult so it is probably a Manjaro build.

//EDIT: thanks @linux-aarhus

So it seems to be the same with Firefox from Arch:

[omano@omano-nvme ~]$ pacman -Qi firefox
Name            : firefox
Version         : 88.0-1
Description     : Standalone web browser from
Architecture    : x86_64
URL             :
Licenses        : MPL  GPL  LGPL
Groups          : None
Provides        : None
Depends On      : gtk3  libxt  mime-types  dbus-glib  ffmpeg  nss  ttf-font  libpulse
Optional Deps   : networkmanager: Location detection via available WiFi networks [installed]
                  libnotify: Notification integration [installed]
                  pulseaudio: Audio support [installed]
                  speech-dispatcher: Text-to-Speech
                  hunspell-en_US: Spell checking, American English [installed]
Required By     : None
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 221,49 MiB
Packager        : Jan Alexander Steffens (heftig) <>
Build Date      : lun. 19 avril 2021 15:49:33
Install Date    : mer. 21 avril 2021 18:48:53
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : None

(I removed Firefox, took the package here and it asked to install, which I accepted, so I think I properly installed the Arch version)

hmm - I just updated this specific laptop from unstable branch - I am using the following settings from about config

  • gfx.webrender.all → true
  • gfx.webrender.enabled → true

The system is intel based UHD 620 - i7 8550U and no issues so far.

1 Like

And if you

[ ] Use recommended performance settings
 [X] Use hardware acceleration when possible

in Firefox Settings directly and restart Firefox?