Firefox is already running, but is not responding

I am facing the same issue as fselcukcan. I can use firefox normally, but when another application tries to open firefox while it is already running (for example clicking a link in an email), I get the same error message. When Firefox is closed and an application tries to open it, there are no issues at all. I have tried this on a fully fresh install of manjaro-gnome. Help is apprechiated.

Actually, I want to get into more detail on the issue, because it is more nuanced:
When firefox is open and another application tries to open a website (for example clicking on a link in skype) then it works. BUT
It only works with the first application that tries to do this.
So, when I open firefox and then click on a link in skype and then on a link in discord, the first link opens, the second doesn’t. When I restart firfox and then click a link in discord, it opens, but when I then click a link in skype, it produces the error message.
Opening multiple links with the same application is possible.
Basically whichever application first addresses firefox will be the only application able to address firefox until a restart.

Which of the analyses above have you tried already?

:thinking:

I too have the same issue. I can run Firefox fine, but clicking on links in other programs like Thunderbird, Slack, Gitkraken etc, all cause the following dialog box to appear. Closing Firefox does not fix the issue.

Its been happening since I installed Manjaro a week ago. I’m running Firefox 93.0.1 from the Official repositories.

And you’ve tried all of the proposed solutions above and none of those help neither?

:thinking:

I’m suprised there aren’t more people with the same issue to be honest. I’ve been installing a few different distros the past week, including arch, and this definitely seems to only occur on Manjaro at least as far as my experience goes. This is a fresh install of pahvo.

As we’re not getting any responses that help us solve the issue, nor what does or doesn’t work, I’ve closed this thread.

If you have the same problem, open a new thread and try out all of the proposed solutions in this thread and document your results.

:man_shrugging: