Firefox is already running, but is not responding

  1. I agree with @maycne.sonahoz Please try writing shorter sentences. :writing_hand:
  2. Does this problem also arise when you create a new user and log in there? (E.G. fselcukcan2)


  1. The process is hard to follow. I needed to concatenate a lot to form the user flow and side effects.
    I have shortened it a bit and threw commas here and there, well one sentence. :expressionless:

  2. I have not tried that yet but I can. But if outcome will be negative that should not the way I need to use the browser. It is not much convenient.

Please do and report back. It’s just to see whether this is a system issue or a user profile issue…


Naming of the browser app with app that has the links, e.g. Slack, does happen with Chromium as well.

By creating new user I guess you mean an operating system user. Is that right?

I have tried it. I have logged out off my operating system user and logged in as another user. The problem happens there too, with all details.

What if you run

firefox --safe-mode

Does it happen as well then?

Yes, it does.

Please follow below first:


Before reinstalling, It might be better to try going to about:support page and click Refresh Firefox
To reset Firefox without losing passwords, history and bookmarks

1 Like

:warning: Take a full cold system backup before continuing and only if the above fails.

I’m all out of bright ideas then, except to uninstall firefox with the --no-save option (clearing all configuration files)

pamac remove --no-save firefox*

delete any remaining files too:

find / -iname \*firefox\* -print

Change -print to -exec rm {} \; if you want to actually delete them.

Reinstall firefox:

pamac install firefox


I have tried that but it did not solve the issue. Thanks a lot. I will try the other thing next, later, and come back.

1 Like

Unfortunately I have installed another linux to try it out, not since there is something wrong with manjaro which is great. The point is I will not be able to try the above suggestion. Status of this OP is up to you fellow free softwarers, linuxer.
Greetings from yet another Linux distro.
Stay free!

This post will auto-close in 3 months, so when you come back to Manjaro, try out the above if it’s still happening…


Thanks a lot. I miss some aspects of Manjaro already. Great distro. I will try above.

1 Like

I am facing the same issue as fselcukcan. I can use firefox normally, but when another application tries to open firefox while it is already running (for example clicking a link in an email), I get the same error message. When Firefox is closed and an application tries to open it, there are no issues at all. I have tried this on a fully fresh install of manjaro-gnome. Help is apprechiated.

Actually, I want to get into more detail on the issue, because it is more nuanced:
When firefox is open and another application tries to open a website (for example clicking on a link in skype) then it works. BUT
It only works with the first application that tries to do this.
So, when I open firefox and then click on a link in skype and then on a link in discord, the first link opens, the second doesn’t. When I restart firfox and then click a link in discord, it opens, but when I then click a link in skype, it produces the error message.
Opening multiple links with the same application is possible.
Basically whichever application first addresses firefox will be the only application able to address firefox until a restart.

Which of the analyses above have you tried already?


I too have the same issue. I can run Firefox fine, but clicking on links in other programs like Thunderbird, Slack, Gitkraken etc, all cause the following dialog box to appear. Closing Firefox does not fix the issue.

Its been happening since I installed Manjaro a week ago. I’m running Firefox 93.0.1 from the Official repositories.

And you’ve tried all of the proposed solutions above and none of those help neither?


I’m suprised there aren’t more people with the same issue to be honest. I’ve been installing a few different distros the past week, including arch, and this definitely seems to only occur on Manjaro at least as far as my experience goes. This is a fresh install of pahvo.

As we’re not getting any responses that help us solve the issue, nor what does or doesn’t work, I’ve closed this thread.

If you have the same problem, open a new thread and try out all of the proposed solutions in this thread and document your results.