Firefox has no audio after the system has been upgraded

update
openrc
firefox

#1

Hi, I update my Manjaro this morning and after update reboot and start firefox.
I tryed to play some YouTube videos, but there is no audio and I saw maseg "To play audio, you may need to install the required PulseAudio software."
I open the help page to see where is the problem but I see required PulseAudio version is 10.0

I have already installed:
extra/pulseaudio 10.0-3 [installed]

I reinstal packeg and reboot but problem is not solved.

PS: My firefox version is 54.0 (32 bit)

This is the help info: //If you see a notification saying “To play audio, you may need to install the required PulseAudio software”, it means that Firefox cannot find or use PulseAudio. Starting with Firefox 52, the PulseAudio software is required to play any audio from Firefox. Most Linux distributions now come with PulseAudio pre-installed.

Use your system’s software package manager and ensure that PulseAudio is correctly installed. //


Firefox sound
#2

A workaround would be to download the video/autio file and watch/listen it with a media player. There are Firefox extensions for that but I don’t recommend them if you can get used to command line tools like youtube-dl.
I use to do the following

sudo mount -o remount,size=7G -t tmpfs /tmp
cd /tmp
youtube-dl 'https://www.youtube.com/watch?v=GHf1msJ-I0c'

The link tot he video I get from right-click -> copy link address. The link given it “Peter und der Wolf”

eugen@mjaro ~> cd /tmp
eugen@mjaro /tmp> youtube-dl 'https://www.youtube.com/watch?v=GHf1msJ-I0c'
[youtube] GHf1msJ-I0c: Downloading webpage
[youtube] GHf1msJ-I0c: Downloading video info webpage
[youtube] GHf1msJ-I0c: Extracting video information
[youtube] GHf1msJ-I0c: Downloading js player vfle90bgw
[youtube] GHf1msJ-I0c: Downloading js player vfle90bgw
[youtube] GHf1msJ-I0c: Downloading MPD manifest
WARNING: Requested formats are incompatible for merge and will be merged into mkv.
[download] Destination: Peter und der Wolf _ Augsburger Puppenkiste 1967-GHf1msJ-I0c.f135.mp4
[download]  30.4% of 129.73MiB at 261.38KiB/s ETA 05:53

Of course, this is not a solution for your issue. I hope you will find it.


#3

You should also install pavucontrol to adjust pulseaudio settings (and make sure they’re correct and not muted). Also pulseaudio-alsa.

Then pulseaudio needs to be started. In systemd, it’s run as a service (I think), but it’s different in OpenRC. To test, start pulseaudio with the command pulseaudio --start

Then start Firefox and see if you have sound.

If it works, you can add pulseaudio --start to your application autostart so it runs when you login. This is a little different depending on your desktop environment, so ask if you need help.


#4

Expanding on @cimarronline’s answer:

If you are using Xfce, check that it is enabled in Settings -> Session and Startup.

Also check that autospawn = yes in /etc/pulse/client.conf.


#5

firefox dropped alsa as the default in 52, but there was a build flag available to enable it if you wanted to build it yourself for 52 and 53. arch was kind enough to do that. as of 54, alsa-only is no longer possible.


#6

we can use pulseaudio-alsa

extra/pulseaudio-alsa 2-3 [installé]
ALSA Configuration for PulseAudio


#7

I have Chromium installed for nothing but watching YouTube. Part of a larger strategy of splitting up tasks among browsers and using most of them like appliances. Qupzilla only handles work emails, for example, because it’s good at that (by being bad and defaulting to the ancient interface, which I prefer).

Running the uBlock Origin and ScriptSafe addons under Chromium also ensures that I never see an ad while at YT, unless I want to let a few through to support a content creator.

Edit: to clarify, I’m on OpenRC with no PA of any kind around, and Chromium plays vids on YT just fine.


#8

I have the same problem with no audio on YouTube from Firefox 52.
I uninstalled Pulseaudio early this year because of intermittent skipping on Quod Libet music player.
There are no audio problems on YouTube with Palemoon which I mostly use since late February.


#9

There is no audio on YouTube for Tor browser either.


#10

It doesn’t work in Tor because TB is based on a current Firefox.

It works in PaleMoon, for now, because PM is based on an older Firefox. Eventually the problem will catch up to you there too, I’m thinking.

Edit: Another fresh possible solution!


#11

It looks like Palemoon are not planning on requiring PulseAudio for sound on their browser.
https://forum.palemoon.org/viewtopic.php?f=5&t=15150&p=109928&hilit=pulseaudio#p109928


closed #12

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.