Firefox blocking websites

In Firefox the “Server Not Found” comes up for About - PubMed or even just or any document linked to on that site. I shut off my firewall as the Server Down page suggests could be the issue. I also cleared history, cookies, etc. Nothing worked.

My install of Firefox has no user installed apps, extensions or plugins. (And I just shut the only 2 ext/plugins installed by FF- from Cisco and Google and restarted) But- still get the Sever Down message.

Against better judgement, I even unblocked untrusted and blocked sites in the Firefox settings- made sure I didn’t require https- etc, and chose not to have blocked potentially dangerous content-- All to no avail.

Website status checkers show pubmed as up and running. But so convinced their site was down, I didn’t believe them and went on to two other status site checkers that confirmed the site was up.

Some people wrote of similar problems - and suggested my server might prevent my access to certain websites. Horrified, I opened Chromium to verify the website address was being blocked by my server. How dare they!!! But, in Chromium, the site came up no problem!!! Back in Firefox, the site still comes up with a Firefox error page claiming Pubmed’s Server is Down.

Initially I’d mistakenly suspected Google’s search blocking me or a bad link. But worked. Searching the site for Pubmed the ABOUT Pubmed page would not work in Firefox nor any other opening under the Pubmed status. All came up as if their server was down.

In light of the fact that the Chromium opens the site, Firefox should at least re-write the case, as a problem on their end. But maybe this happened for a good reason.

When trying to fix my Firefox settings I came across a disclosure from Firefox/Mozilla, already checked to allow their experimental study and data collection of my internet use@@!! Once I opted out to DENY this invasion of privacy, a little message comes up that states it will take them 30 DAYS to remove their files from MY computer!!!

I left Chromium for Firefox due to the Chromium- Google Chrome association (ie. accusations of mass data collection.) I thought Firefox was independent, pro privacy, etc, etc.

Disregarding I am in the USA, (formerly a free state)), I’d guess I’d rather us Chromium aka Google Chrome–in bed with my government watching my internet use than a Firefox- a private software conglomerate, denying me access to my own government’s websites --while collecting my data for an experiment that likely will be profitable to sell as part of a massive collection of all their users!
PS My trouble earlier this week with Firefox restore tabs malfunctioning no longer needs resolve on my account–because it won’t be a program on my computer.

Site is down apparently check for yourself.

1 Like

The problem is that fails DNSSEC verifications. Firefox is probably checking the DNSSEC for the site, while Chromium is not. This is not an issue with Firefox. It’s an issue with the domain name

Working in Chromium-- just used the the pubmed search for measles and came up with this: measles - Search Results - PubMed

I’m not an expert but isn’t the domain That site works. The subdomain (in this case 3 subdomains deep) does not have DNSSEC inherited?
For what it is worth-- this shows that the DNSSEC for pubmed is okay. The very next subdomain under that has an issue but that wasn’t part of this issue/website Firefox is blocking.

It works fine here on FF Nightly. Check your FF configuration under “Privacy and Security”. Also check network settings under General Tab- see if enable DNS over HTTPS is set the way you would like. I would also try to rule out any privacy extensions that may be installed.

And check again now it is UP! and I can also access it from my Firefox.

Wild guess, they updated their DNS records yesterday or something, and it needed time to propagate, and you went conspiracy theory nut for nothing because DNS settings on your system, and in your browsers were different and only specific DNS servers were up to date…

Just a wild guess… but pretty sure I’m spot on lol.

Bloody bastard at Mozilla censoring medical publication for world domination!!! (joke aside yeah Mozilla is in favor of more internet censorship but come on… censoring medical publication on government website… pretty far fetched…)

//EDIT: and yesterday the ping was not responding and today:

[omano@omano-nvme ~]$ ping
PING ( 56(84) bytes of data.
64 bytes from ( icmp_seq=1 ttl=115 time=50.1 ms
64 bytes from ( icmp_seq=2 ttl=115 time=51.0 ms
64 bytes from ( icmp_seq=3 ttl=115 time=51.0 ms

See it redirects me from to (note the WIP - Work In Progress - in the redirected subdomain)… I guess my theory might be somewhat correct… it could have been another issue but so far this is what I believe.

PS: using CloudFlare DNS for both my system and Firefox.

Well thanks for the update-- and I just checked and now Firefox brings up the site. You probably are right, that pubmed website configuration must have changed. I know now that I like Chromium better for not having such a problem.

Re: your comment about far-fetched concerning censorship-- well in light of Facebook and Twitter banning people for instance for making a COVID comment, or even a president of the USA due to political differences, i didn’t have to reach far to fetch the notion. It did come to me after going through all of my Firefox Settings finding one from Mozilla-Firefox that described their enabled feature as an experiment to collect my user data. Probably what set me off was the notice after I selected DENY that told me their files would be on my computer for 30 days…that was the last straw…

Well, Chro*** didn’t handle anything.

When DNS propagation is under way, two following requests on the same browser (with a clean cache) will give different outcomes as the route will vary.

[sum@ordi ~]$ traceroute 5
traceroute to (, 30 hops max, 28 byte packets
 1  iPhone.local (  0.859 ms  0.943 ms  1.026 ms
 2 (  34.585 ms  35.165 ms  35.218 ms
 3 (  36.225 ms  36.316 ms  37.039 ms
 4 (  39.218 ms  39.262 ms  39.369 ms
 5 (  38.523 ms  38.268 ms  38.334 ms
 6 (  40.059 ms  103.133 ms  103.166 ms
 7 (  28.331 ms  27.120 ms  28.207 ms
 8 (  28.373 ms  33.481 ms  33.591 ms
 9 (  34.204 ms  35.008 ms (  34.050 ms
10 (  33.657 ms  33.026 ms (  33.859 ms
11 (  33.098 ms  33.211 ms  35.856 ms
[sum@ordi ~]$ traceroute
traceroute to (, 30 hops max, 60 byte packets
 1  iPhone.local (  0.685 ms  0.766 ms  0.873 ms
 2 (  120.426 ms  120.480 ms  120.618 ms
 3 (  121.567 ms  121.711 ms  121.784 ms
 4 (  121.146 ms  121.298 ms  121.397 ms
 5 (  121.972 ms  121.865 ms  122.098 ms
 6 (  120.976 ms  71.071 ms  89.506 ms
 7 (  88.461 ms  119.473 ms  121.314 ms
 8 (  119.546 ms  120.579 ms  120.477 ms
 9 (  120.923 ms (  119.744 ms  119.952 ms
10 (  120.154 ms (  121.301 ms (  121.029 ms
11 (  120.639 ms  120.522 ms  120.817 ms
[sum@ordi ~]$ 

If the route changes, one might suddenly address a server that is not updated yet :

Your paranoïd inferences on Firefox are thus merely void.

Chromium monitors you for sure on the other hand :smiley:

For Mozilla’s data collection, as it’s an open source product I do like and respect, I allow it to “pay” for my free usage.
As you uncheck data collection , it’s because you do contribute financially or with your code, isn’t it ?

I guess simply change your DNS settings in Firefox to use Google DNS servers (so you give them even more of your personnal data :D).

Some DNS servers can update more quickly (because they technically do, or because of chance when event happen). Also the web browser itself can have a DNS cache and even if the DNS server updated to new infos the web browser keeps the old info.

It was just bad luck this time.

About the data collection I disabled it too. And I don’t contribute financially. Don’t start off topic flame it is useless.

1 Like